apr-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436
  1. %define aprver 1
  2. # Arches on which the multilib apr.h hack is needed:
  3. %define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
  4. Name: apr
  5. Summary: Apache Portable Runtime library
  6. Summary(ja): Apache ポータブルランタイムライブラリ
  7. Version: 1.5.2
  8. Release: 1%{?_dist_release}
  9. Group: System Environment/Libraries
  10. License: Apache Software License
  11. URL: http://apr.apache.org/
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Source0: %{name}-%{version}.tar.bz2
  15. Source1: apr-wrapper.h
  16. Patch2: apr-0.9.7-deepbind.patch
  17. Patch3: apr-1.2.2-locktimeout.patch
  18. Patch4: apr-1.2.2-libdir.patch
  19. Patch5: apr-1.3.3-pkgconf.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: autoconf, libtool, python, doxygen
  22. BuildRequires: libuuid-devel
  23. Conflicts: subversion < 0.20.1-2
  24. Obsoletes: apache2-apr
  25. %description
  26. The mission of the Apache Portable Runtime (APR) is to provide a
  27. free library of C data structures and routines, forming a system
  28. portability layer to as many operating systems as possible,
  29. including Unices, MS Win32, BeOS and OS/2.
  30. %package devel
  31. Summary: APR library development kit
  32. Summary(ja): APR ライブラリ開発キット
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. Conflicts: subversion-devel < 0.20.1-2
  36. Obsoletes: apache2-apr-devel
  37. %description devel
  38. This package provides the support files which can be used to
  39. build applications using the APR library. The mission of the
  40. Apache Portable Runtime (APR) is to provide a free library of
  41. C data structures and routines.
  42. %prep
  43. %setup -q
  44. %patch2 -p1 -b .deepbind
  45. %patch3 -p1 -b .locktimeout
  46. %patch4 -p1 -b .libdir
  47. %patch5 -p1 -b .pkgconf
  48. %build
  49. # regenerate configure script etc.
  50. ./buildconf
  51. # Forcibly prevent detection of shm_open (which then picks up but
  52. # does not use -lrt).
  53. export ac_cv_search_shm_open=no
  54. %configure \
  55. --includedir=%{_includedir}/apr-%{aprver} \
  56. --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
  57. --with-devrandom=/dev/urandom \
  58. --disable-static \
  59. CC=gcc CXX=g++
  60. make %{?_smp_mflags} && make dox
  61. %install
  62. rm -rf $RPM_BUILD_ROOT
  63. make install DESTDIR=$RPM_BUILD_ROOT
  64. # Move docs to more convenient location
  65. rm -rf html
  66. mkdir -p html
  67. cp -pr docs/dox/html/* html/
  68. # mv docs/dox/html html
  69. # Trim exported dependecies
  70. sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
  71. $RPM_BUILD_ROOT%{_libdir}/libapr*.la
  72. sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/ */ /g}' \
  73. $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
  74. %ifarch %{multilib_arches}
  75. # Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
  76. # packages:
  77. mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
  78. $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
  79. install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
  80. %endif
  81. # Unpackaged files:
  82. rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
  83. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  84. %check
  85. # Fail if LFS support isn't present in a 32-bit build, since this
  86. # breaks ABI and the soname doesn't change: see #254241
  87. if grep 'define SIZEOF_VOIDP 4' include/apr.h \
  88. && ! grep off64_t include/apr.h; then
  89. cat config.log
  90. : LFS support not present in 32-bit build
  91. exit 1
  92. fi
  93. %clean
  94. rm -rf $RPM_BUILD_ROOT
  95. %post -p /sbin/ldconfig
  96. %postun -p /sbin/ldconfig
  97. %files
  98. %defattr(-,root,root,-)
  99. %doc CHANGES LICENSE NOTICE
  100. %{_libdir}/libapr-%{aprver}.so.*
  101. %files devel
  102. %defattr(-,root,root,-)
  103. %doc docs/APRDesign.html docs/canonical_filenames.html
  104. %doc docs/incomplete_types docs/non_apr_programs
  105. %{_bindir}/apr-%{aprver}-config
  106. #{_libdir}/libapr-%{aprver}.a
  107. %{_libdir}/libapr-%{aprver}.so
  108. %{_libdir}/pkgconfig/*.pc
  109. %dir %{_libdir}/apr-%{aprver}
  110. %dir %{_libdir}/apr-%{aprver}/build
  111. %{_libdir}/apr-%{aprver}/build/*
  112. %dir %{_includedir}/apr-%{aprver}
  113. %{_includedir}/apr-%{aprver}/*.h
  114. %changelog
  115. * Mon May 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
  116. - updated to 1.5.2.
  117. * Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-1
  118. - update to 1.5.1
  119. * Sat Oct 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.5-1
  120. - new upstream release
  121. * Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
  122. - new upstream release
  123. - built with rpm-4.8.1
  124. - removed static libraries from devel package
  125. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
  126. - rebuilt with new toolchain
  127. * Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
  128. - new upstream release
  129. * Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
  130. - new upstream release with security fix (CVE-2009-2412)
  131. * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
  132. - new upstream release
  133. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
  134. - new upstream release
  135. - updated Patch5
  136. * Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
  137. - new upstream release
  138. - removed Patch1 and 6
  139. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
  140. - removed *.la files from devel package
  141. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
  142. - new upstream release
  143. - added Patch2 and 6 from Fedora
  144. * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
  145. - add fix for use of %%pI with psprintf
  146. * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
  147. - use RTLD_DEEPBIND in apr_dso_open by default
  148. * Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  149. - new upstream release
  150. * Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  151. - new upstream release
  152. * Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
  153. - remove Requires: gcc = %%(gcc -dumpversion)
  154. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
  155. - rebuilt with new toolchain
  156. * Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  157. - new upstream release
  158. * Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
  159. - initial build for Vine Linux based on FC package
  160. * Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
  161. - fix another multilib conflict (#192659)
  162. * Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
  163. - BR e2fsprogs-devel for libuuid
  164. * Mon May 8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
  165. - use multilib parallel-installation wrapper hack for apr.h
  166. * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
  167. - fix installbuilddir in apr-1-config
  168. * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
  169. - update to 1.2.7
  170. - use pkg-config in apr-1-config to make it libdir-agnostic
  171. * Thu Apr 6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
  172. - update to 1.2.6
  173. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
  174. - bump again for double-long bug on ppc(64)
  175. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
  176. - rebuilt for new gcc4.1 snapshot and glibc changes
  177. * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
  178. - fix namespace pollution (r354824, r355464)
  179. * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
  180. - fix build with recent glibc (#176911)
  181. * Tue Jan 3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
  182. - rebuilt again
  183. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  184. - rebuilt
  185. * Fri Dec 9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
  186. - rebuild for new gcc
  187. * Thu Dec 8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
  188. - add apr_file_seek() fixes from upstream (r326593, r326597)
  189. * Wed Dec 7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
  190. - apr-1-config: strip more exports (#175124)
  191. * Tue Dec 6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
  192. - avoid linking against -lrt
  193. - don't print -L${libdir} in --libs output
  194. - don't export -lcrypt/-luuid in .la file
  195. * Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
  196. - update to 1.2.2
  197. * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
  198. - use RTLD_DEEPBIND in apr_dso_open by default
  199. * Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
  200. - update to 0.9.7
  201. * Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
  202. - rebuild for new gcc
  203. * Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
  204. - don't override CFLAGS at build time
  205. - allow setting TCP_NODELAY and TCP_CORK concurrently
  206. - use _exit() not exit() in child if exec*() fails (upstream #30913)
  207. * Fri Sep 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
  208. - add from 0.9.x branch:
  209. * fix for apr_{uid,gid}_* error handling (r239592)
  210. * fix for apr_file_ write flushing (r267192)
  211. - add backport for use of readdir64_r (r265032, r265681, r265684)
  212. * Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
  213. - rebuild
  214. * Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
  215. - fix apr_procattr_child_*_set error handling
  216. * Tue Mar 1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
  217. - have apr-devel depend on specific version of gcc
  218. - add NOTICE to docdir
  219. * Wed Feb 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
  220. - update to 0.9.6
  221. * Wed Feb 2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
  222. - don't disable sendfile on s390 (IBM LTC, #146891)
  223. * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
  224. - really fix apr-config --srcdir
  225. * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
  226. - fix apr-config --srcdir again
  227. * Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
  228. - update to 0.9.5
  229. * Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
  230. - rebuild
  231. * Wed Sep 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
  232. - have -devel require apr of same V-R
  233. * Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
  234. - backport fixes from HEAD:
  235. * correct implementation of nested mutexes
  236. * support for POSIX semaphores on LP64 platforms
  237. * Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
  238. - rebuild for another attempt at using sem_open
  239. * Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
  240. - move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
  241. * Thu Jul 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
  242. - rebuild
  243. * Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
  244. - rebuild now /dev/shm is mounted
  245. * Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
  246. - add fix for cleanup structure reuse (part of upstream #23567)
  247. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  248. - rebuilt
  249. * Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
  250. - add support for setuid/setgid/sticky bits (Andr辿 Malo)
  251. - add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
  252. * Mon Jun 7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
  253. - enable posixsem and process-shared pthread mutex support, but
  254. ensure that sysvsem remains the default mechanism
  255. * Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
  256. - entirely remove 2Gb file size limit from apr_file_copy();
  257. fixes "svnadmin hotcopy" on repos with >2Gb strings table
  258. - work around getnameinfo bugs with v4-mapped addresses
  259. - fix apr_time_exp_get() for dates in 2038 (Philip Martin)
  260. * Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
  261. - use APR_LARGEFILE in apr_file_{copy,append}
  262. * Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
  263. - add APR_LARGEFILE flag
  264. * Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
  265. - fix configure check for mmap of /dev/zero
  266. - just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
  267. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
  268. - rebuilt
  269. * Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
  270. - undocument apr_dir_read() ordering constraint and fix tests
  271. * Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
  272. - rebuilt without -Wall -Werror
  273. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
  274. - rebuilt
  275. * Tue Feb 3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
  276. - define apr_off_t as int/long/... to prevent it changing
  277. with _FILE_OFFSET_BITS on 32-bit platforms
  278. * Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
  279. - add apr_temp_dir_get fixes from HEAD
  280. * Thu Jan 8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
  281. - ensure that libapr is linked against libpthread
  282. - don't link libapr against -lnsl
  283. * Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
  284. - -devel package no longer requires libtool
  285. * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
  286. - disable tests on x86_64 (#97611)
  287. * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
  288. - update to 0.9.4, enable tests
  289. - ensure that libresolv is not used
  290. * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
  291. - use /dev/urandom (#103049)
  292. * Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
  293. - add back CC=gcc, CXX=g++
  294. * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
  295. - rebuild
  296. * Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
  297. - work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
  298. * Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
  299. - support --cc and --cpp arguments in apr-config
  300. * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
  301. - force libtool to use CC=gcc, CXX=g++
  302. * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
  303. - fix libtool location in apr_rules.mk
  304. * Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
  305. - use AI_ADDRCONFIG in getaddrinfo() support (#73350)
  306. - include a working libtool script rather than relying on
  307. /usr/bin/libtool (#97695)
  308. * Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
  309. - don't use /usr/bin/libtool
  310. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  311. - rebuilt
  312. * Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
  313. - add fix for psprintf memory corruption (CAN-2003-0245)
  314. - remove executable bit from apr_poll.h
  315. * Thu May 1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
  316. - link libapr against libpthread
  317. - make apr-devel conflict with old subversion-devel
  318. - fix License
  319. * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
  320. - run ldconfig in post/postun
  321. * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
  322. - patch test suite to not care if IPv6 is disabled
  323. * Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
  324. - initial build