gnumeric-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461
  1. %define gnumeric_version %{version}-bonobo
  2. %define goffice_version 0.8.13
  3. Summary: A spreadsheet program for GNOME.
  4. Summary(ja): GNOME スプレッドシート
  5. Name: gnumeric
  6. Version: 1.10.13
  7. Release: 1%{?_dist_release}
  8. License: GPLv2
  9. Group: Applications/Productivity
  10. URL: http://www.gnome.org/projects/gnumeric
  11. Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.10/%{name}-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. # default font: VL Gothic
  14. Patch0: gnumeric-1.10.13-vlgothic.patch
  15. Distribution: Vine Linux
  16. Vendor: Project Vine
  17. BuildRequires: gtk2-devel >= 2.10.0
  18. BuildRequires: libglade2-devel >= 2.3.6
  19. BuildRequires: libgnomeprint-devel >= 2.8.2
  20. BuildRequires: libgnomeprintui-devel >= 2.8.2
  21. BuildRequires: libart_lgpl-devel >= 2.3.11
  22. BuildRequires: libxml2-devel >= 2.4.12
  23. BuildRequires: libgsf-devel >= 1.13.2
  24. BuildRequires: goffice-devel >= %{goffice_version}
  25. BuildRequires: libbonobo-devel libgnomeui-devel
  26. BuildRequires: libffi-devel
  27. #BuildPreReq: libgda-devel >= 1.9.100
  28. #BuildPreReq: libgnomedb-devel >= 1.9.100
  29. BuildRequires: perl python-devel
  30. BuildRequires: automake autoconf libtool docbook-utils
  31. BuildRequires: intltool >= 0.28 desktop-file-utils
  32. BuildRequires: libSM-devel
  33. Requires: gtk2 >= 2.10.0
  34. Requires: libglade2 >= 2.3.6
  35. Requires: libgnomeprint >= 2.8.2
  36. Requires: libgnomeprintui >= 2.8.2
  37. Requires: libgsf >= 1.14.6
  38. Requires: perl python
  39. Requires: GConf2 scrollkeeper
  40. # no longer devel package
  41. #Provides: %{name}-devel
  42. Obsoletes: %{name}-devel
  43. %description
  44. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  45. applications and desktop tools to be used in conjunction with a window
  46. manager for the X Window System.
  47. This is the Gnumeric, a spreadsheet for GNOME. It aims to be a drop in
  48. replacement for commercial spreadsheets. It provides import/export from
  49. MS Excel files and many other formats (csv, latex, xbase, applix).
  50. %description -l ja
  51. GNOME (GNU Network Object Model Environment)は
  52. Xウィンドウシステム用の、ウィンドウマネージャと連結した
  53. GUIアプリケーションおよびデスクトップツールのセットです。
  54. これは Gnumeric, GNOMEスプレッドシート・プログラムです。
  55. 商用のスプレッドシート・プログラムを代替できるものを目指しています。
  56. MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, applix)
  57. を読込み、出力できます.
  58. # %package devel
  59. #Summary: Files necessary to develop gnumeric-based applications.
  60. #Group: Development/Libraries
  61. #Requires: %{name} = %{PACKAGE_VERSION}
  62. #%#description devel
  63. #The gnumeric-devel package includes files necessary to develop gnumeric-based
  64. #applications.
  65. #Install gnumeric-devel if you want to develop programs which will use gnumeric.
  66. %prep
  67. %setup -q
  68. %patch0 -p1 -b vlgothic
  69. %build
  70. %ifarch alpha
  71. MYARCH_FLAGS="--host=alpha-redhat-linux"
  72. %endif
  73. export mllibname=%{_lib}
  74. %configure --with-gnome \
  75. --with-gda --without-gb --with-perl --with-python \
  76. --disable-schemas-install
  77. make
  78. %install
  79. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  80. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  81. make DESTDIR=$RPM_BUILD_ROOT install
  82. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  83. ./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/applications
  84. desktop-file-install --vendor gnome --delete-original \
  85. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  86. --add-category Office \
  87. --add-category Application \
  88. --add-category Spreadsheet \
  89. --remove-mime-type="zz-application/zz-winassoc-xls" \
  90. $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  91. %find_lang %{name}
  92. %find_lang %{name}-functions
  93. cat %{name}-functions.lang >> %{name}.lang
  94. rm -rf $RPM_BUILD_ROOT%{_libdir}/libspreadsheet.la
  95. rm -rf $RPM_BUILD_ROOT%{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*.la
  96. rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  97. rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.10
  98. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  99. %clean
  100. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  101. %post
  102. /sbin/ldconfig
  103. scrollkeeper-update > /dev/null 2>&1 || :
  104. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  105. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnumeric*.schemas > /dev/null
  106. touch --no-create %{_datadir}/icons/hicolor || :
  107. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  108. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  109. fi
  110. %pre
  111. if [ "$1" -gt 1 ]; then
  112. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  113. gconftool-2 --makefile-uninstall-rule \
  114. %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
  115. fi
  116. %preun
  117. if [ "$1" -eq 0 ]; then
  118. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  119. gconftool-2 --makefile-uninstall-rule \
  120. %{_sysconfdir}/gconf/schemas/gnumeric*.schemas >& /dev/null ||:
  121. fi
  122. %postun
  123. /sbin/ldconfig
  124. scrollkeeper-update > /dev/null 2>&1 || :
  125. touch --no-create %{_datadir}/icons/hicolor || :
  126. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  127. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  128. fi
  129. %files -f %{name}.lang
  130. %defattr (-, root, root)
  131. %doc AUTHORS BUGS *ChangeLog* COPYING HACKING NEWS README
  132. %config %{_sysconfdir}/gconf/schemas/*
  133. %{_bindir}/*
  134. %{_libdir}/lib*.so*
  135. %{_libdir}/gnumeric
  136. %{_libdir}/goffice/%{goffice_version}/plugins/gnumeric/*
  137. #{_libdir}/bonobo/servers/*
  138. %{_datadir}/applications/*.desktop
  139. %{_datadir}/gnome/help/gnumeric
  140. %{_datadir}/gnumeric
  141. %{_datadir}/pixmaps/*
  142. #{_datadir}/mime-info/*
  143. #{_datadir}/mc/templates/*
  144. %{_datadir}/omf/*
  145. %{_datadir}/icons/hicolor/*
  146. %{_mandir}/man*/*
  147. %exclude %{_datadir}/pixmaps/win32-gnumeric.ico
  148. #%{_libexecdir}/gnumeric-component
  149. #%#dir %{_libdir}/gnumeric
  150. #%#dir %{_libdir}/gnumeric/%{bonobover}
  151. #%#dir %{_libdir}/gnumeric/%{bonobover}/plugins
  152. #%#dir %{_libdir}/gnumeric/%{bonobover}/plugins/*
  153. # This is really silly. The .la files are useless for plugins.
  154. #%#{_libdir}/gnumeric/%{bonobover}/plugins/*/*.la
  155. #%#{_libdir}/gnumericConf.sh
  156. #%#if %{bonobo}
  157. #%#dir %{_datadir}/gnumeric
  158. #%#dir %{_datadir}/gnumeric/%{bonobover}
  159. #%#{_datadir}/gnumeric/%{bonobover}/idl
  160. #%#endif
  161. %changelog
  162. * Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.13-1
  163. - new upstream release
  164. - add Patch0 (gnumeric-1.10.13-vlgothic.patch)
  165. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.12-1
  166. - new upstream release
  167. * Sat Oct 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.11-1
  168. - new upstream release
  169. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.10-1
  170. - new upstream release
  171. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.9-1
  172. - new upstream release
  173. - add desktop-file-install option: --remove-mime-type="zz-application/zz-winassoc-xls"
  174. (fix error of MIME type)
  175. * Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  176. - new upstream release
  177. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.7-1
  178. - new upstream release
  179. * Wed Jun 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  180. - new upstream release
  181. - fix %post and %postun
  182. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  183. - new upstream release
  184. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
  185. - new upstream release
  186. - add BuildRequires: libSM-devel
  187. - fix BuildRequires: goffice-devel >= 0.8.1
  188. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-3
  189. - spec in UTF-8 (fixed)
  190. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-2
  191. - spec in UTF-8
  192. - added BuildRequires: libffi-devel
  193. - added %%pre, %%preun section
  194. * Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-1
  195. - new upstream release
  196. - built with libgda-3.1.4, libgnomedb-3.1.2
  197. - applied new versioning policy
  198. * Mon Mar 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
  199. - new upstream release
  200. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-0vl2
  201. - rebuild
  202. * Fri May 5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-0vl1
  203. - new upstream release
  204. * Sun Mar 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.2-0vl1
  205. - new upstream release
  206. - updated build dependancies
  207. - rebuilt with libgsf-1.14.0
  208. - built with libgda and libgnomedb again
  209. * Tue Nov 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-0vl1
  210. - new upstream release
  211. - updated build dependancies
  212. - not compile with libgda and libgnomedb in this version
  213. * Mon Mar 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
  214. - new upstream release
  215. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl2
  216. - rebuild with libgda 1.2.0 and libgnome 1.2.0
  217. * Tue Jan 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
  218. - new upstream release
  219. * Mon Dec 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl1
  220. - new upstream release
  221. * Thu Dec 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-0vl1
  222. - new upstream release
  223. * Fri Nov 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl2
  224. - rebuild with gnome-2.8 environment and libgsf-1.10.1
  225. * Tue Jun 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.13-0vl1
  226. - new upstream release
  227. - added BuildRequires: desktop-file-utils
  228. * Thu May 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-0vl1
  229. - new upstream release
  230. - Requires: libgsf >= 1.9.0, BuildPrereq: libgsf-devel >= 1.9.0
  231. * Wed Apr 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
  232. - new upstream release
  233. * Wed Apr 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-0vl1
  234. - new upstream release
  235. * Sun Apr 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
  236. - new upstream release
  237. * Thu Mar 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
  238. - new upstream release
  239. * Wed Mar 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.7-0vl1
  240. - new upstream release
  241. - clean up spec file (a little bit!)
  242. * Thu Jan 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  243. - new upstream release
  244. * Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.4-0vl1
  245. - new upstream release
  246. - to use intltool-0.28
  247. * Sun Dec 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-0vl1
  248. - new upstream release
  249. - rebuild with new toolchains
  250. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
  251. - new upstream release
  252. - build with new libgnomeprint, libgnomeprintui
  253. * Fri Oct 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  254. - new upstream release
  255. * Thu Oct 2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
  256. - rebuild with newer libgda, libgnomedb
  257. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  258. - updated to 1.2.0 (stable release)
  259. - guile support is temporarily off this version.
  260. * Mon Sep 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl1
  261. - update to 1.1.20 (gtk+-2 port)
  262. - based on Redhat Rawhide 1.1.20-1
  263. * Thu May 1 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.13-0vl1
  264. - update to 1.0.13
  265. - rebuild with gal 0.24
  266. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-0vl2
  267. - guile support on
  268. - rebuild with new gal, bonobo, libgda
  269. * Fri Feb 7 2003 Masaki Shinomiya <shino@pos.to> 1.0.12-0vl1
  270. - New upstream release, remove xmliobackward.patch
  271. * Mon Dec 16 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl2
  272. - xml-io back to 1.0.10 because japanese corrups with new xml_parser
  273. * Sun Dec 15 2002 Masaki Shinomiya <shino@pos.to> 1.0.11-0vl1
  274. - New upstream release, fix for xml importing files with non ASCII characters.
  275. - Without guile, changelog.archive, requires, build scripts, description
  276. * Mon Nov 19 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl2
  277. - files: add gnumericConf.sh, which was missing
  278. * Mon Nov 4 2002 Masaki Shinomiya <shino@pos.to> 1.0.10-0vl1
  279. - New upstream release.
  280. - BuildPrereq oaf-devel
  281. * Mon Jul 29 2002 Masaki Shinomiya <shino@pos.to> 1.0.9-0vl1
  282. - New upstream release.
  283. * Mon Jul 1 2002 Masaki Shinomiya <shino@pos.to> 1.0.8-0vl1
  284. - New upstream release.
  285. - Default font and Japanese fonts in excel
  286. - requires
  287. * Sun Jun 30 2002 Masaki Shinomiya <shino@pos.to> 1.0.7-0vl1
  288. - New upstream release.
  289. - fixed plugins, apply patch2, remove patch3
  290. - files - no longer devel package
  291. - function-reference.html in help file
  292. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
  293. - New upstream release.
  294. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.2-0vl1
  295. - New upstream release.
  296. - Fixed several owner dir.
  297. * Tue Jan 15 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
  298. - Build against with new gal
  299. * Mon Jan 7 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
  300. - New upstream release.
  301. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.0-0vl1
  302. - New upstream release.
  303. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.1-0vl1
  304. - New upstream release.
  305. - Applied XIM over-the-spot patch.
  306. - Fixed directories owner.
  307. * Wed Dec 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.99.0-0vl1
  308. - New upstream release.
  309. - Enable Bonobo.
  310. - Merged several RH patches.
  311. - Added BuildPreReq tags.
  312. * Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl3
  313. - Fixed packaging mistake.
  314. * Mon May 14 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl2
  315. - Rebuild for GAL 0.7
  316. * Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.61-0vl1
  317. - New upstream release.
  318. - Use rpmmacros.
  319. * Mon Feb 5 2001 Jun Nishii <jun@vinelinux.org>
  320. - 0.56-0vl2
  321. - update ja.po
  322. - avoid core dump when inserting a row
  323. * Mon Jul 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  324. - updated to 0.56
  325. - remake spec with the orginal gnumeric spec file.
  326. - added ms_excel_read and edit_item patch from Japanese gnome users mailing list.
  327. * Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  328. - updated to 0.53
  329. - remake SPEC based on gnumeric original.
  330. - added libxml183 patch for libxml 1.8.3
  331. * Thu Mar 29 2000 Kjartan Maraas <kmaraas@online.no>
  332. - Removed gnome-gnumeric-xl.png since it is nowhere to be found.
  333. - Added --without-bonobo and --without-gb.
  334. - Added %define for sysconfdir
  335. * Mon Feb 29 2000 Jody Goldberg <jgolbderg@home.com>
  336. - Updated version requirements for gnome-print, and gnome-libs.
  337. * Sun Jan 30 2000 Gregory McLean <gregm@comstar.net>
  338. - Added in some auto-detect the language files logic (rpm 3.0.xx only)
  339. * Mon Jan 12 2000 Jody Goldberg <jgolbderg@home.com>
  340. - Add depend on gtk+ >= 1.2.2 so that we can get gtk_object_get.
  341. * Mon Jan 03 2000 Gregory McLean <gregm@comstar.net>
  342. - Updated to 0.47
  343. * Mon Dec 20 1999 Jody Goldberg <jgolbderg@home.com>
  344. - Updated the libglade dependancy.
  345. - Remove req for guile. We can build without it.
  346. * Thu Sep 02 1999 Gregory McLean <gregm@comstar.net>
  347. - Added small fix so glade generated dialogs appear.
  348. * Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
  349. - Added the gnome-print requirement.
  350. - Updated the file list to try and quiet down the updating.
  351. - added the sysconfdir
  352. * Tue Mar 9 1999 Gregory McLean <gregm@comstar.net>
  353. - Updated the spec file.
  354. * Thu Sep 24 1998 Michael Fulbright <msf@redhat.com>
  355. - Version 0.2