jasper-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. Name: jasper
  4. Summary: implementation of the JPEG-2000 standard, Part 1
  5. Version: 2.0.12
  6. Release: 1%{?_dist_release}
  7. Group: Applications/Graphics
  8. License: Modified BSD (see LICENSE)
  9. URL: http://www.ece.uvic.ca/~mdadams/jasper/
  10. Source: %{name}-version-%{version}.tar.gz
  11. Patch1: jasper-1.900.1-CVE-2008-3520.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: autoconf automake libtool
  14. BuildRequires: freeglut-devel
  15. BuildRequires: libGLU-devel
  16. BuildRequires: libjpeg-devel
  17. BuildRequires: pkgconfig
  18. BuildRequires: cmake
  19. Requires: %{name}-libs = %{version}-%{release}
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. %description
  23. JasPer is a collection of software (i.e., a library and application
  24. programs) for the coding and manipulation of images. This software
  25. can handle image data in a variety of formats. One such format
  26. supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
  27. %package devel
  28. Summary: Include Files and Documentation for jasper
  29. Group: Development/Libraries
  30. Requires: %{name}-libs = %{version}-%{release}
  31. Requires: libjpeg-devel
  32. %description devel
  33. This package contains libjasper, a library implementing the JPEG-2000
  34. image compression standard Part 1.
  35. %package libs
  36. Summary: Runtime libraries for %{name}
  37. Group: System Environment/Libraries
  38. %description libs
  39. This package contains runtime libraries for JasPer.
  40. # compat32
  41. %package -n compat32-%{name}-devel
  42. Summary: Include Files and Documentation for jasper
  43. Group: Development/Libraries
  44. Requires: %{name}-libs = %{version}-%{release}
  45. Requires: compat32-libjpeg-devel
  46. %description -n compat32-%{name}-devel
  47. This package contains libjasper, a library implementing the JPEG-2000
  48. image compression standard Part 1.
  49. %package -n compat32-%{name}-libs
  50. Summary: Runtime libraries for %{name}
  51. Group: System Environment/Libraries
  52. %description -n compat32-%{name}-libs
  53. This package contains runtime libraries for JasPer.
  54. %prep
  55. %setup -q -n %{name}-version-%{version}
  56. %patch1 -p1 -b .CVE-2008-3520
  57. %build
  58. mkdir -p builder
  59. %cmake -G "Unix Makefiles" \
  60. -H%{_builddir}/%{name}-version-%{version} \
  61. -B%{_builddir}/%{name}-version-%{version}/builder
  62. pushd builder
  63. make %{?_smp_mflags} clean all
  64. popd
  65. %install
  66. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  67. pushd builder
  68. make install DESTDIR=%{buildroot}
  69. # remove .la
  70. rm -f %{buildroot}/%{_libdir}/*.la
  71. popd
  72. rm -rf %{buildroot}%{_docdir}/JasPer
  73. %check
  74. pushd builder
  75. LD_PRELOAD=`pwd`/src/libjasper/libjasper.so \
  76. make test
  77. popd
  78. %clean
  79. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  80. %post libs -p /sbin/ldconfig
  81. %postun libs -p /sbin/ldconfig
  82. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  83. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  84. %files
  85. %defattr(-,root,root)
  86. %{!?_licensedir:%global license %%doc}
  87. %license COPYRIGHT LICENSE
  88. %doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
  89. %{_bindir}/*
  90. %{_mandir}/man1/*
  91. %files libs
  92. %defattr(-,root,root)
  93. %{_libdir}/libjasper*.so.*
  94. %files devel
  95. %defattr(-,root,root)
  96. %{_includedir}/jasper
  97. %{_libdir}/libjasper*.so
  98. %{_libdir}/pkgconfig/jasper.pc
  99. # compat32
  100. %if %{build_compat32}
  101. %files -n compat32-%{name}-libs
  102. %defattr(-,root,root)
  103. %{_libdir}/libjasper*.so.*
  104. %files -n compat32-%{name}-devel
  105. %defattr(-,root,root)
  106. %{_libdir}/libjasper*.so
  107. %{_libdir}/pkgconfig/jasper.pc
  108. %endif
  109. %changelog
  110. * Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
  111. - new upstream release.
  112. - dropped all patches.
  113. - imported patch1 from rawhide.
  114. * Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
  115. - added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
  116. * Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
  117. - imported all patches from RawHide.
  118. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
  119. - rebuild with libpng-1.6.12
  120. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
  121. - rebuilt with current VineSeed
  122. * Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
  123. - added compat32 subpackage for x86_64 arch support.
  124. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
  125. - splited out runtime library to sub package
  126. - enable opengl again, add BuildRequires: freeglut-devel
  127. * Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
  128. - remove .la
  129. - add --disable-static to configure option
  130. * Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
  131. - added Patch0 from VinePlus/4.0
  132. * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
  133. - add patch100 for fix CVE-2007-2721
  134. - add Vendor/Distributin Tag
  135. * Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
  136. - remove BuildPrereq: freeglut-devel and Requires freeglut
  137. - add --disable-opengl to configure option
  138. * Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
  139. - add BuildPreReq: unzip (used in the %%pre section)
  140. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
  141. - new upstream release
  142. * Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
  143. - new upstream release
  144. - changed Group to System Environment/Libraries
  145. - added --mandir=%{_mandir}
  146. - added %post and %postun section
  147. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
  148. - added --libdir=%{_libdir} configure option
  149. * Tue Sep 5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
  150. - build with freeglut
  151. - change BuildPrereq and Requires
  152. * Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
  153. - new upstream version (jasper-1.701.0)
  154. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
  155. - rebuild for VineSeedPlus
  156. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
  157. - source upgrade
  158. - change spec to build for VineLinux
  159. * Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
  160. - spec file created