subversion-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623
  1. %bcond_with systemd
  2. %define neon_version 0.30.2
  3. %define swig_version 3.0.0
  4. %define apache_version 2.4
  5. %define apache_dir /usr
  6. %define swigdirs swig_pydir=%{python3_sitearch}/libsvn swig_pydir_extra=%{python3_sitearch}/svn
  7. Summary: Modern Version Control System
  8. Summary(ja): モダンなバージョン管理システム
  9. Name: subversion
  10. Version: 1.14.1
  11. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  12. Group: programming
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: iwaim, daisuke
  16. License: ASL 2.0
  17. URL: https://subversion.apache.org/
  18. Source0: http://ftp.jaist.ac.jp/pub/apache/subversion/subversion-%{version}.tar.bz2
  19. Source1: subversion.conf
  20. Source2: httpd.davcheck.conf
  21. Source3: filter-requires.sh
  22. Source6: svnserve.service
  23. Source7: svnserve.tmpfiles
  24. Source8: svnserve.sysconf
  25. Patch1: subversion-1.12.0-linking.patch
  26. Patch2: subversion-1.14.0-testwarn.patch
  27. Patch3: subversion-1.14.0-soversion.patch
  28. Patch4: subversion-1.8.0-rubybind.patch
  29. Patch5: subversion-1.8.5-swigplWall.patch
  30. BuildRequires: apache2-devel >= %{apache_version}
  31. BuildRequires: apr-devel, apr-util-devel
  32. BuildRequires: autoconf >= 2.53
  33. BuildRequires: libdb-devel
  34. BuildRequires: expat-devel
  35. BuildRequires: gdbm-devel
  36. BuildRequires: libtool >= 1.4.2
  37. BuildRequires: neon-devel >= %{neon_version}
  38. BuildRequires: openssl-devel
  39. BuildRequires: swig >= %{swig_version}
  40. BuildRequires: texinfo
  41. BuildRequires: zlib-devel
  42. BuildRequires: lz4-devel
  43. BuildRequires: utf8proc-devel
  44. BuildRequires: openldap-devel
  45. BuildRequires: ruby >= 2.2.3
  46. BuildRequires: ruby-devel >= 2.2.3
  47. BuildRequires: perl >= 2:5.26.2
  48. BuildRequires: sqlite3-devel
  49. BuildRequires: krb5-devel
  50. BuildRequires: keyutils-libs-devel
  51. BuildRequires: dbus-devel
  52. BuildRequires: libsecret-devel
  53. BuildRequires: libserf-devel
  54. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  55. %if %{with systemd}
  56. BuildRequires: systemd
  57. %{?systemd_requires}
  58. %endif
  59. %define __perllib_requires %{SOURCE3}
  60. %description
  61. Subversion is a concurrent version control system which enables one
  62. or more users to collaborate in developing and maintaining a
  63. hierarchy of files and directories while keeping a history of all
  64. changes. Subversion only stores the differences between versions,
  65. instead of every complete file. Subversion is intended to be a
  66. compelling replacement for CVS.
  67. %package devel
  68. Summary: Development package for Subversion developers.
  69. Group: programming
  70. Requires: subversion = %{version}-%{release}
  71. Requires: apr-devel, apr-util-devel
  72. %description devel
  73. The subversion-devel package includes the static libraries and include files
  74. for developers interacting with the subversion package.
  75. %package mod_dav_svn
  76. Summary: Apache server module for Subversion server.
  77. Group: servers
  78. Requires: apache2 >= %{apache_version}
  79. Requires: subversion = %{version}-%{release}
  80. %description mod_dav_svn
  81. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  82. the Apache directories and configuration.
  83. %package tools
  84. Summary: Tools for Subversion
  85. Group: programming
  86. BuildRequires: perl >= 5.8.0
  87. Requires: perl >= 5.8.0
  88. Requires: subversion = %{version}-%{release}
  89. %description tools
  90. Tools for Subversion.
  91. %package perl
  92. Summary: Perl bindings to the Subversion libraries
  93. Group: programming
  94. Requires: subversion = %{version}-%{release}
  95. Requires: perl >= 5.8.0
  96. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  97. %description perl
  98. This package includes the Perl bindings to the Subversion libraries.
  99. %package ruby
  100. Summary: Ruby bindings to the Subversion libraries
  101. Group: programming
  102. Requires: subversion = %{version}-%{release}
  103. Requires: ruby >= 2.0
  104. %description ruby
  105. This package includes the Ruby bindings to the Subversion libraries.
  106. %package -n python3-subversion
  107. Summary: Python bindings to the Subversion libraries
  108. Group: programming
  109. BuildRequires: python3
  110. BuildRequires: python3-devel
  111. BuildRequires: py3c-devel
  112. Requires: subversion = %{version}-%{release}, python3
  113. %description -n python3-subversion
  114. This package includes the Python bindings to the Subversion libraries.
  115. %debug_package
  116. %prep
  117. %setup -q
  118. %patch1 -p1 -b .linking
  119. %patch2 -p1 -b .testwarn
  120. %patch3 -p1 -b .soversion
  121. %patch4 -p1 -b .rubybind
  122. %patch5 -p1 -b .swigplWall
  123. %build
  124. export LANG=ja_JP.UTF-8
  125. # Regenerate the buildsystem, so that:
  126. # 1) patches applied to configure.in take effect
  127. # 2) the swig bindings are regenerated using the system swig
  128. # (2) is not ideal since typically upstream test with a different
  129. # swig version
  130. # This PATH order makes the fugly test for libtoolize work...
  131. mv build-outputs.mk build-outputs.mk.old
  132. export PYTHON=%{__python3}
  133. ### Force regeneration of swig bindings with the buildroot's SWIG.
  134. # Generated files depend on the build/generator/swig/*.py which
  135. # generates them, so when autogen-standalone.mk's autogen-swig target
  136. # is run by autogen.sh it will regenerate them:
  137. touch build/generator/swig/*.py
  138. PATH=/usr/bin:$PATH ./autogen.sh --release
  139. # fix shebang lines, #111498
  140. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  141. # fix python executable
  142. perl -pi -e 's|/usr/bin/env python.*|%{svn_python}|' subversion/tests/cmdline/svneditor.py
  143. # override weird -shrext from ruby
  144. export svn_cv_ruby_link="%{__cc} -shared"
  145. export svn_cv_ruby_sitedir_libsuffix=""
  146. export svn_cv_ruby_sitedir_archsuffix=""
  147. %if 0
  148. # Fix include path for ruby2.7
  149. export svn_cv_ruby_includes="-I%{_includedir}"
  150. %endif
  151. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
  152. export LIBTOOL=/usr/bin/libtool
  153. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  154. --with-swig --with-serf=%{_prefix} \
  155. --with-ruby-sitedir=%{rarchdir} \
  156. --with-apxs=%{_bindir}/apxs \
  157. --disable-mod-activation \
  158. --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
  159. --with-gnome-keyring \
  160. --with-berkeley-db \
  161. --disable-mod-activation \
  162. --disable-static
  163. make %{?_smp_mflags} all tools
  164. make swig-py swig-py-lib %{swigdirs}
  165. make swig-pl swig-pl-lib
  166. make swig-rb swig-rb-lib
  167. %install
  168. rm -rf $RPM_BUILD_ROOT
  169. make install \
  170. install-swig-py \
  171. install-swig-pl-lib \
  172. install-swig-rb \
  173. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  174. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  175. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  176. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  177. install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
  178. # Add subversion.conf configuration file into apache2/conf.d directory.
  179. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  180. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  181. # Remove unpackaged files
  182. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  183. $RPM_BUILD_ROOT%{python3_sitearch}/*/*.{a,la} \
  184. $RPM_BUILD_ROOT%{_libdir}/*.la
  185. # The SVN build system is broken w.r.t. DSO support; it treats
  186. # normal libraries as DSOs and puts them in $libdir, whereas they
  187. # should go in some subdir somewhere, and be linked using -module,
  188. # etc. So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
  189. # since nothing should ever link against them directly.
  190. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
  191. # remove stuff produced with Perl modules
  192. find $RPM_BUILD_ROOT -type f \
  193. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  194. -print0 | xargs -0 rm -f
  195. # make Perl modules writable so they get stripped
  196. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  197. xargs -0 chmod 755
  198. # unnecessary libraries for swig bindings
  199. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  200. # Remove unnecessary ruby libraries
  201. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  202. # Trim what goes in docdir
  203. rm -rf tools/*/*.in tools/test-scripts
  204. # Rename authz_svn INSTALL doc for docdir
  205. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  206. # Install bash completion
  207. install -Dpm 644 tools/client-side/bash_completion \
  208. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
  209. for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
  210. ln -s svn \
  211. $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
  212. done
  213. # Install tools ex diff*
  214. make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
  215. rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
  216. for f in svn-populate-node-origins-index \
  217. svnauthz-validate svnmucc svnraisetreeconflict; do
  218. echo %{_bindir}/$f
  219. done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
  220. %find_lang %{name}
  221. cat %{name}.lang exclude.tools.files >> %{name}.files
  222. %if %{with systemd}
  223. install -D -p -m 644 %{SOURCE6} %{buildroot}%{_unitdir}/svnserve.service
  224. install -D -p -m 644 %{SOURCE7} %{buildroot}%{_tmpfilesdir}/svnserve.conf
  225. install -D -p -m 644 %{SOURCE8} %{buildroot}%{_sysconfdir}/sysconfig/svnserve
  226. %endif
  227. %if %{with systemd}
  228. %post
  229. %systemd_post svnserve.service
  230. %preun
  231. %systemd_preun svnserve.service
  232. %postun
  233. %systemd_postun_with_restart svnserve.service
  234. %endif
  235. %files
  236. %defattr(-,root,root)
  237. %license LICENSE
  238. %doc BUGS CHANGES COMMITTERS NOTICE INSTALL README
  239. %{_bindir}/*
  240. %{_libdir}/libsvn_*.so.*
  241. %{_localedir}/*/*/subversion.mo
  242. %{_mandir}/man*/*
  243. %{_datadir}/bash-completion/completions/*
  244. %dir %{_sysconfdir}/subversion
  245. %exclude %{_mandir}/man*/*::*
  246. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  247. %exclude %{_libdir}/libsvn_swig_py*.so.*
  248. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  249. %if %{with systemd}
  250. %{_unitdir}/svnserve.service
  251. %{_tmpfilesdir}/svnserve.conf
  252. %config(noreplace) %{_sysconfdir}/sysconfig/svnserve
  253. %endif
  254. %files devel
  255. %defattr(-,root,root)
  256. %{_includedir}/subversion-1
  257. %{_libdir}/libsvn*.so
  258. %exclude %{_libdir}/libsvn_swig_perl*
  259. %exclude %{_libdir}/libsvn_swig_py*
  260. %exclude %{_libdir}/libsvn_swig_ruby*
  261. %{_datadir}/pkgconfig/*
  262. %files mod_dav_svn
  263. %defattr(-,root,root)
  264. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  265. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  266. %files tools -f tools.files
  267. %defattr(-,root,root)
  268. %files perl
  269. %defattr(-,root,root,-)
  270. %{perl_vendorarch}/auto/SVN
  271. %{perl_vendorarch}/SVN
  272. %{_libdir}/libsvn_swig_perl*
  273. %{_mandir}/man*/*::*
  274. %files ruby
  275. %defattr(-,root,root,-)
  276. %{_libdir}/libsvn_swig_ruby*
  277. %{rarchdir}/svn
  278. %files -n python3-subversion
  279. %defattr(-,root,root,-)
  280. %{_libdir}/libsvn_swig_py*
  281. %{python3_sitearch}/*
  282. %changelog
  283. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.1-1
  284. - new upstream release.
  285. - re-imported patches from rawhide.
  286. * Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.0-1
  287. - new upstream release.
  288. * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.2-1
  289. - new upstream release.
  290. - dropped Patch1 and 2.
  291. - imported Patch1 and 2 from rawhide.
  292. - switched to python3.
  293. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
  294. - new upstream release.
  295. - rebuilt with perl-5.26.
  296. - dropped BR:libgnome-keyring-devel.
  297. - added BR:libxcrypt-devel,libnsl2-devel,libsecret-devel,utf8proc-devel.
  298. * Wed May 31 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.17-1
  299. - update to 1.8.17
  300. * Sat Sep 12 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-4
  301. - rebuild with ruby-2.2.3
  302. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.9-3
  303. - build with Perl 5.16
  304. - using %%__perllib_requires
  305. * Fri Jun 27 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-2
  306. - rebuild with ruby-2.1.2-6
  307. * Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-1
  308. - update to 1.8.9
  309. - remove unneeded explisit dependency
  310. - add BR: apache2-devel >= 2.4
  311. - add BR: libdb-devel instead of db4-devel
  312. - add R: apache2 > 2.4 to mod_dav_svn
  313. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  314. - update to 1.8.8
  315. - add BR: libserf-devel to handle http* scheme
  316. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
  317. - update to 1.7.7
  318. - rebuild with ruby-1.9.3
  319. * Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
  320. - new upstream release
  321. - update License
  322. - update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
  323. - drop deplibs patch (Patch1)
  324. - drop obsolete patch files: Patch6, 10
  325. * Fri Jun 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  326. - new upstream release with security fix (CVE-2011-1752, 1783, 1921)
  327. - add configure option with-gnome-keyring
  328. - add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
  329. - fix Packager name
  330. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
  331. - build with perl 5.12.3
  332. - add Requires: perl(:MODULE_COMPAT_...)
  333. * Sat Mar 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
  334. - new upstream release with security fix
  335. - add Vendor/Distri tags
  336. * Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
  337. - new upstream release
  338. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  339. - fix <BTS:VineLinux:941>
  340. - using rpm macro: rarchdir
  341. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  342. - using rpm macros: perl_vendorarch and python_sitearch
  343. - add BuildRequires: sqlite3-devel krb5-devel
  344. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  345. - new upstream release
  346. - update URL
  347. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  348. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  349. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  350. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  351. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  352. - new upstream release
  353. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  354. - new upstream release
  355. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  356. - rebuilt with python-2.5.2
  357. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  358. - new upstream release
  359. - rebuild with neon-0.28.2
  360. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  361. - added Patch6, 8, 9, 10 from Fedora Core
  362. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  363. - Correct install location of java stuff (#433295)
  364. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  365. - fix build with new glibc open()-as-macro
  366. - build all swig code in %%build, not %%install
  367. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  368. - build /usr/bin/* as PIEs
  369. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  370. - rebuild with expat-2.0.1
  371. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  372. - new upstream release
  373. - add Patch10 to build with neon.
  374. 1.3.2-0vl5 does not support neon..
  375. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  376. - rebuild with new neon
  377. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  378. - rebuilt with new toolchain and db4-4.3.x
  379. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  380. - modified %%files section for lib64 architecture
  381. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  382. - new upstream release
  383. - rebuild with new openldap-2.3.24
  384. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  385. - new upstream release
  386. - change Group to Develoment/Tools
  387. - build with apr-1.2.7/apr-util-1.2.7
  388. - require apr/apr-util instead of apache2-apr
  389. - build with swig-1.3.29
  390. - split {perl,python,ruby} related files to subpackage.
  391. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  392. - new upstream release
  393. - add noreplace option for config file
  394. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  395. - fix Requires and BuildPreReq.
  396. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  397. - new upstream release.
  398. - add swig-runtime to 'BuildPreReq:'.
  399. - fix %%files.
  400. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  401. - require neon version 0.24.7 for ra_dav
  402. - add BuildPreReq: openldap-devel
  403. - replace BuildPreReq: httpd to BuildPreReq: apache2
  404. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  405. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  406. - new upstream release
  407. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  408. - new upstream release
  409. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  410. - new upstream release
  411. - clean up specfile.
  412. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  413. - new upstream release
  414. - build with apache2-2.0.47
  415. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  416. - build Vine Linux
  417. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  418. - Enabled RA_DAV checking.
  419. Now requires httpd package to build because of RA_DAV tests.
  420. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  421. - Created tools package to hold the tools.
  422. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  423. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  424. version of APR/APR-UTILS as of 2003.01.15.
  425. - Added svnversion command.
  426. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  427. - Create a svnadmin.static which is copied to svnadmin-version-release
  428. when the package is erased, so users can still dump/load their repositories
  429. even after they have upgraded the RPM package.
  430. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  431. - SWIG now builds so we can use cvs2svn.
  432. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  433. - Made cvs2svn conditional (at least until we can get it to build consistently
  434. and work).
  435. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  436. - Added SWIG dependencies to add cvs2svn capabilities.
  437. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  438. - Now requires neon-0.22.0.
  439. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  440. - Took out loading mod_dav_svn from subversion.spec file and put it in
  441. subversion.conf file which goes into the apache conf directory.
  442. - Simplify what gets put into httpd.conf to only the include for the
  443. subversion.conf file.
  444. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  445. me to do this).
  446. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  447. - Updated to APR/APR-UTIL 2002-08-08.
  448. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  449. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  450. - Previous version had a few problems because of missing apache error/ files.
  451. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  452. - Updated to apache-2.0.40-0.3.
  453. - Updated to subversion-0.13.1-2318.
  454. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  455. - Updated for RedHat 7.3 (autoconf253).
  456. - Added a bunch of pre-requisites I didn't know were needed because I built a
  457. new machine that didn't have them already installed.
  458. - Fixed installation of man and info documentation pages.
  459. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  460. - Back to apache-libapr* stuff, hopefully to stay.
  461. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  462. - Fixed expat.patch to not have to make so many changes by writing a small
  463. shell script that changes libexpat to -lexpat.
  464. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  465. - Updated to neon-0.19.2.
  466. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  467. - Back to using apr and apr-util separately from apache.
  468. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  469. - Updated to APR and APR-UTIL 2002.02.11.
  470. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  471. - Took out a (now non-existant) documentation file.
  472. - Moved SPEC file changelog to after all package definitions.
  473. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  474. - Updated to neon-0.18.5.
  475. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  476. apache-apr-utils, and apache-apr-utils-devel.
  477. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  478. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  479. - Now builds without the separate APR package as it is built into and
  480. "exported" from apache-2.0.31-0.3.
  481. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  482. - Took out patches to install procedure now not required because of fixes
  483. in rev 1130.
  484. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  485. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  486. program was added.
  487. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  488. - Release M5-r340: Added the subversion-server package.
  489. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  490. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  491. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  492. - Release M3-r117: Initial Version.