py3c-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. # A header-only library has no debuginfo
  2. %global debug_package %{nil}
  3. Name: py3c
  4. Version: 1.3
  5. Release: 4%{?_dist_release}
  6. Summary: Guide and compatibility macros for porting extensions to Python 3
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. # Licences differ for subpackages
  11. License: MIT and CC-BY-SA
  12. URL: http://py3c.readthedocs.io/
  13. Source0: https://github.com/encukou/%{name}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  14. BuildRequires: make
  15. BuildRequires: gcc
  16. BuildRequires: python3-devel
  17. BuildRequires: python3-setuptools
  18. %description
  19. py3c helps you port C extensions to Python 3.
  20. It provides a detailed guide, and a set of macros to make porting easy
  21. and reduce boilerplate.
  22. %package devel
  23. Summary: Header files for py3c
  24. License: MIT
  25. Group: programming
  26. Requires: python3-devel
  27. # A header-only library counts as static
  28. Provides: %{name}-static = %{version}-%{release}
  29. %{?_isa:Provides: %{name}-static%{?_isa} = %{version}-%{release}}
  30. %description devel
  31. %{name}-devel is only required for building software that uses py3c.
  32. Because py3c is a header-only library, there is no matching run-time package.
  33. %prep
  34. %setup -q
  35. %build
  36. make %{?_smp_mflags} py3c.pc includedir=%{_includedir}
  37. %install
  38. make install prefix=%{buildroot}%{_prefix} includedir=%{buildroot}%{_includedir}
  39. # Strip buildroot name from the pkgconfig file
  40. sed --in-place -e's!%{buildroot}!!' %{buildroot}%{_datadir}/pkgconfig/py3c.pc
  41. %check
  42. export CFLAGS="%{optflags}"
  43. make %{?_smp_mflags} test-python3
  44. %files devel
  45. %license LICENSE.MIT
  46. %doc README.rst
  47. %{_includedir}/py3c.h
  48. %{_includedir}/py3c/
  49. %{_datadir}/pkgconfig/py3c.pc
  50. %changelog
  51. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.3-4
  52. - initial build for Vine Linux.
  53. * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.3-3
  54. - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
  55. * Thu Jan 07 2021 Petr Viktorin <pviktori@redhat.com> - 1.3-2
  56. - No longer unbundle fonts
  57. * Sun Nov 29 2020 Petr Viktorin <pviktori@redhat.com> - 1.3-1
  58. - Update to 1.3
  59. * Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-2
  60. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  61. * Thu Jan 30 2020 Petr Viktorin <pviktori@redhat.com> - 1.2-1
  62. - Update to 1.2 to fix tests under Python 3.9
  63. - BuildRequire python3-setuptools explicitly
  64. * Thu Jan 30 2020 Petr Viktorin <pviktori@redhat.com> - 1.1-3
  65. - Drop tests and Suggests for Python 2; require python3-devel
  66. * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-2
  67. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  68. * Fri Oct 04 2019 Petr Viktorin <pviktori@redhat.com> - 1.1-1
  69. - Update to 1.1 to fix Python 3.8 compatibility in tests
  70. https://bugzilla.redhat.com/show_bug.cgi?id=1758446
  71. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-6
  72. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  73. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-5
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  75. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-4
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  77. * Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0-3
  78. - Rebuilt for Python 3.7
  79. * Mon Feb 19 2018 Petr Viktorin <pviktori@redhat.com> - 1.0-2
  80. - Add BuildRequires: gcc
  81. * Sun Feb 11 2018 Petr Viktorin <pviktorin@redhat.com> - 1.0-1
  82. - Update to 1.0 (adds Py_UNREACHABLE, Py_RETURN_RICHCOMPARE, Py_UNUSED)
  83. - Strip buildroot name from the pkgconfig file
  84. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.8-5
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  86. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.8-4
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  88. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.8-3
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  90. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.8-2
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  92. * Wed Feb 01 2017 Petr Viktorin <pviktorin@redhat.com> - 0.8-1
  93. - Update to 0.8:
  94. - Add backports for PyMem_Raw*
  95. * Thu May 19 2016 Petr Viktorin <pviktorin@redhat.com> - 0.7-1
  96. - Update to 0.7:
  97. - Fix file shim tests on big endian architectures
  98. (bug in the test suite only, does not affect behavior)
  99. * Thu May 19 2016 Petr Viktorin <pviktorin@redhat.com> - 0.6-2
  100. - Initial package