imake-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225
  1. Summary: imake source code configuration and build system
  2. Name: imake
  3. Version: 1.0.7
  4. Release: 1%{?_dist_release}
  5. License: MIT/X11
  6. Group: User Interface/X
  7. URL: http://www.x.org
  8. Source0: ftp://ftp.x.org/pub/individual/util/%{name}-%{version}.tar.bz2
  9. Source1: ftp://ftp.x.org/pub/individual/util/makedepend-1.0.5.tar.bz2
  10. Source2: ftp://ftp.x.org/pub/individual/util/gccmakedep-1.0.3.tar.bz2
  11. Source3: ftp://ftp.x.org/pub/individual/util/xorg-cf-files-1.0.5.tar.bz2
  12. Source4: ftp://ftp.x.org/pub/individual/util/lndir-1.0.3.tar.bz2
  13. Patch2: xorg-cf-files-1.0.5-redhat.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: pkgconfig
  16. BuildRequires: xorg-x11-util-macros
  17. BuildRequires: xorg-x11-proto-devel
  18. Provides: ccmakedep cleanlinks gccmakedep imake lndir makedepend makeg
  19. Provides: mergelib mkdirhier mkhtmlindex revpath xmkmf
  20. %description
  21. Imake is a deprecated source code configuration and build system which
  22. has traditionally been supplied by and used to build the X Window System
  23. in X11R6 and previous releases. As of the X Window System X11R7 release,
  24. the X Window system has switched to using GNU autotools as the primary
  25. build system, and the Imake system is now deprecated, and should not be
  26. used by new software projects. Software developers are encouraged to
  27. migrate software to the GNU autotools system.
  28. %prep
  29. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
  30. %patch2 -p0 -b .redhat
  31. %build
  32. # Build everything
  33. {
  34. for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
  35. pushd $pkg-*
  36. case $pkg in
  37. imake|xorg-cf-files)
  38. %configure --with-config-dir=%{_datadir}/X11/config
  39. ;;
  40. *)
  41. %configure
  42. ;;
  43. esac
  44. make
  45. popd
  46. done
  47. }
  48. %install
  49. rm -rf $RPM_BUILD_ROOT
  50. # Install everything
  51. {
  52. for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
  53. pushd $pkg-*
  54. case $pkg in
  55. # xorg-cf-files)
  56. # make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_datadir}
  57. # ;;
  58. *)
  59. make install DESTDIR=$RPM_BUILD_ROOT
  60. ;;
  61. esac
  62. popd
  63. done
  64. }
  65. %clean
  66. rm -rf $RPM_BUILD_ROOT
  67. %files
  68. %defattr(-,root,root,-)
  69. %doc
  70. %{_bindir}/ccmakedep
  71. %{_bindir}/cleanlinks
  72. %{_bindir}/gccmakedep
  73. %{_bindir}/imake
  74. %{_bindir}/lndir
  75. %{_bindir}/makedepend
  76. %{_bindir}/makeg
  77. %{_bindir}/mergelib
  78. %{_bindir}/mkdirhier
  79. %{_bindir}/mkhtmlindex
  80. %{_bindir}/revpath
  81. %{_bindir}/xmkmf
  82. %dir %{_datadir}/X11
  83. %dir %{_datadir}/X11/config
  84. %{_datadir}/X11/config/*.cf
  85. %{_datadir}/X11/config/*.def
  86. %{_datadir}/X11/config/*.rules
  87. %{_datadir}/X11/config/*.tmpl
  88. #%dir %{_mandir}/man1x
  89. %{_mandir}/man1/ccmakedep.1.*
  90. %{_mandir}/man1/cleanlinks.1.*
  91. %{_mandir}/man1/gccmakedep.1.*
  92. %{_mandir}/man1/imake.1.*
  93. %{_mandir}/man1/lndir.1.*
  94. %{_mandir}/man1/makedepend.1.*
  95. %{_mandir}/man1/makeg.1.*
  96. %{_mandir}/man1/mergelib.1.*
  97. %{_mandir}/man1/mkdirhier.1.*
  98. %{_mandir}/man1/mkhtmlindex.1.*
  99. %{_mandir}/man1/revpath.1.*
  100. %{_mandir}/man1/xmkmf.1.*
  101. %changelog
  102. * Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
  103. - imake-1.0.7
  104. - gccmakedep-1.0.3
  105. - makedepend-1.0.5
  106. - xorg-cf-files-1.0.5
  107. - update Patch2 (xorg-cf-files-1.0.5-redhat.patch)
  108. * Fri Mar 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
  109. - imake-1.0.5
  110. - lndir-1.0.3
  111. - makedepend-1.0.4
  112. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
  113. - xorg-cf-files-1.0.4
  114. - update Patch2 (xorg-cf-files-1.0.4-redhat.patch)
  115. - delete Patch0,1,3
  116. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  117. - imake-1.0.4
  118. - lndir-1.0.2
  119. - makedepend-1.0.3
  120. - xorg-cf-files-1.0.3
  121. - update Patch2 (xorg-cf-files-1.0.3-redhat.patch)
  122. - update Patch3 (xorg-cf-files-1.0.3-xprint.patch)
  123. - fix %%files
  124. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
  125. - rebuilt with new toolchain
  126. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  127. - new versioning policy
  128. * Fri Jan 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  129. - initial build for Vine Linux
  130. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-5
  131. - Rebuild for build id
  132. * Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1.0.2-4
  133. - makedepend 1.0.1
  134. * Tue Jul 18 2006 Than Ngo <than@redhat.com> 1.0.2-3
  135. - cleanup patch files
  136. - update source files
  137. * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-2
  138. - rebuild
  139. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
  140. - Update to imake-1.0.2, gccmakedep-1.0.2, xorg-cf-files-1.0.2
  141. * Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
  142. - Fix ExtraXawReqs to reflect reality (libXp is unneeded)
  143. * Mon Mar 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
  144. - Updated xorg-cf-files-1.0.1-redhat.patch with fix for (#178177)
  145. * Wed Mar 01 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-2
  146. - Buildrequires: xorg-x11-proto-devel
  147. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  148. - bump again for double-long bug on ppc(64)
  149. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  150. - rebuilt for new gcc4.1 snapshot and glibc changes
  151. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  152. - Updated all packages to version 1.0.1 from X11R7.0
  153. * Wed Dec 21 2005 Than Ngo <than@redhat.com> 1.0.0-4
  154. - final fix for #173593
  155. * Tue Dec 20 2005 Than Ngo <than@redhat.com> 1.0.0-3
  156. - add correct XAppLoadDir #173593
  157. - add more macros for fedora
  158. * Mon Dec 19 2005 Than Ngo <than@redhat.com> 1.0.0-2
  159. - add some macros to fix problem in building of manpages
  160. * Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  161. - Updated all packages to version 1.0.0 from X11R7 RC4
  162. - Added new lndir, gccmakedep tarballs. (#173478)
  163. - Changed manpage dirs from man1x to man1 to match upstream RC4 default.
  164. - Removed all previous 'misc' patch, as we now pass --with-config-dir to
  165. configure to specify the location of the Imake config files.
  166. - Renamed imake patch to xorg-cf-files-1.0.0-ProjectRoot.patch as it did not
  167. patch imake at all. This should probably be changed to be a custom Red Hat
  168. host.def file that is added as a source line instead of randomly patching
  169. various files.
  170. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> 0.99.2-5.1
  171. - rebuilt
  172. * Mon Nov 28 2005 Than Ngo <than@redhat.com> 0.99.2-5
  173. - add correct ProjectRoot for modular X
  174. * Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-4
  175. - add missing host.conf
  176. * Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-3
  177. - fix typo
  178. * Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-2
  179. - fix xmkmf to look config files in /usr/share/X11/config
  180. instead /usr/%%{_lib}/X11/config/
  181. - add host.conf
  182. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  183. - Updated to imake-0.99.2, xorg-cf-files-0.99.2, makedepend-0.99.2 from
  184. X11R7 RC2.
  185. * Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
  186. - Initial build.