libmusicbrainz3-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255
  1. # Fedora package review: http://bugzilla.redhat.com/451643
  2. # do unit tests
  3. %define _with_check 0
  4. Summary: Library for accessing MusicBrainz servers
  5. Name: libmusicbrainz3
  6. Version: 3.0.2
  7. Release: 1%{?_dist_release}
  8. License: LGPLv2+
  9. Group: System Environment/Libraries
  10. URL: http://www.musicbrainz.org/
  11. Source0: ftp://ftp.musicbrainz.org/pub/musicbrainz/libmusicbrainz-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. Source10: doxygen-footer.html
  14. # upstreamed: http://lists.musicbrainz.org/pipermail/musicbrainz-devel/2008-September/002575.html
  15. # updated to comment out even Requires.private for now, to avoid needless deps
  16. # (re)introduced by recent fedora pkgconfig behavior change
  17. Patch2: libmusicbrainz-3.0.1-private.patch
  18. Patch3: libmusicbrainz-3.0.2-gcc44.patch
  19. BuildRequires: cmake
  20. %if 0%{?_with_check}
  21. BuildRequires: cppunit-devel
  22. %endif
  23. BuildRequires: doxygen
  24. BuildRequires: libdiscid-devel
  25. BuildRequires: neon-devel
  26. BuildRequires: pkgconfig
  27. %description
  28. The MusicBrainz client library allows applications to make metadata
  29. lookup to a MusicBrainz server, generate signatures from WAV data and
  30. create CD Index Disk ids from audio CD roms.
  31. %package devel
  32. Summary: Headers for developing programs that will use %{name}
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. Requires: pkgconfig
  36. # patch2 removes the need for these
  37. #Requires: libdiscid-devel neon-devel
  38. %description devel
  39. This package contains the headers that programmers will need to develop
  40. applications which will use %{name}.
  41. %prep
  42. %setup -q -n libmusicbrainz-%{version}
  43. %patch2 -p1 -b .private
  44. %patch3 -p1 -b .gcc44
  45. # until doxygen is fixed, something like
  46. # http://bugzilla.gnome.org/show_bug.cgi?id=579303 , hack out
  47. # mulitilib-conflicting doxygen footers
  48. install -p %{SOURCE10} doxygen-footer.html
  49. echo "HTML_FOOTER = doxygen-footer.html" >> Doxygen
  50. %build
  51. %{cmake} .
  52. make %{?_smp_mflags} all docs
  53. %install
  54. rm -rf %{buildroot}
  55. make install/fast DESTDIR=%{buildroot}
  56. rm -f docs/installdox
  57. %check
  58. %if %{?_with_check}
  59. make check
  60. %endif
  61. %clean
  62. rm -rf %{buildroot}
  63. %post -p /sbin/ldconfig
  64. %postun -p /sbin/ldconfig
  65. %files
  66. %defattr(-,root,root,-)
  67. %doc AUTHORS.txt COPYING.txt NEWS.txt README.txt
  68. %{_libdir}/libmusicbrainz3.so.*
  69. %files devel
  70. %defattr(-,root,root,-)
  71. %doc docs/*
  72. %{_includedir}/musicbrainz3/
  73. %{_libdir}/libmusicbrainz3.so
  74. %{_libdir}/pkgconfig/libmusicbrainz3.pc
  75. %changelog
  76. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.2-1
  77. - initial build for Vine Linux
  78. * Tue May 25 2010 Bastien Nocera <bnocera@redhat.com> 3.0.2-7
  79. - Remove script from devel docs
  80. * Tue Nov 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 3.0.2-7
  81. - fix/enable unit tests
  82. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.2-6
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  84. * Mon Jun 29 2009 Rex Dieter <rdieter@fedoraproject.org> - 3.0.2-5
  85. - fix doxygen-induced multilib conflicts (#480378)
  86. - add %%check section (disabled by default, pending cppunit detection issues)
  87. * Wed Feb 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 3.0.2-4
  88. - work harder to omit extraneous pkgconfig deps
  89. - gcc44 patch
  90. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.2-3
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  92. * Fri Dec 12 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.2-2
  93. - rebuild for pkgconfig deps
  94. * Tue Sep 16 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.2-1
  95. - libmusicbrainz3-3.0.2
  96. * Fri Sep 05 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-4
  97. - Build docs (#461238)
  98. - -devel: drop extraneous Requires
  99. * Fri Jul 25 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-3
  100. - fix recursive linking against libdiscid neon
  101. * Thu Jul 24 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-2
  102. - BR: libdiscid-devel
  103. - -devel: Requires: libdiscid-devel neon-devel
  104. * Mon Jun 16 2008 Rex Dieter <rdieter@fedoraproject.org> 3.0.1-1
  105. - libmusicbrainz3-3.0.1
  106. * Sun Jun 15 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.5-7
  107. - Provides: libmusicbrainz2(-devel), prepare for libmusicbrainz3
  108. * Fri Feb 22 2008 Rex Dieter <rdieter@fedoraproject.org> 2.1.5-6
  109. - gcc43 patch (#434127)
  110. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.1.5-5
  111. - Autorebuild for GCC 4.3
  112. * Mon Feb 18 2008 Rex Dieter <rdieter@fedoraproject.org> - 2.1.5-4
  113. - specfile cosmetics
  114. * Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 2.1.5-3
  115. - use versioned Obsoletes
  116. - drop (Build)Requires: libstdc++-devel
  117. - License: LGPLv2+
  118. * Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 2.1.5-2
  119. - Rebuild for PPC toolchain bug
  120. * Thu Jun 21 2007 - Bastien Nocera <bnocera@redhat.com> - 2.1.5-1
  121. - Update to 2.1.5
  122. * Mon Oct 23 2006 Matthias Clasen <mclasen@redhat.com> - 2.1.4-1
  123. - Update to 2.1.4
  124. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.1.1-4.1
  125. - rebuild
  126. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.1.1-4
  127. - rebuild for -devel deps
  128. * Tue Apr 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.1.1-3
  129. - apply .spec file cleanups from Matthias Saou (#172926)
  130. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.1.1-2.1
  131. - bump again for double-long bug on ppc(64)
  132. * Tue Feb 7 2006 Christopher Aillon <caillon@redhat.com> - 2.1.1-2
  133. - Stop shipping the .a file in the main package
  134. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.1.1-1.2
  135. - rebuilt for new gcc4.1 snapshot and glibc changes
  136. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  137. - rebuilt
  138. * Wed Mar 23 2005 John (J5) Palmieri <johnp@redhat.com> 2.1.1-1
  139. - Update to upstream version 2.1.1
  140. - Removed libmusicbrainz-2.0.2-missing-return.patch
  141. - Removed libmusicbrainz-2.0.2-conf.patch
  142. * Wed Mar 03 2005 John (J5) Palmieri <johnp@redhat.com> 2.0.2-14
  143. - Add patch to fix percision cast error to compile correctly on s390x
  144. * Wed Mar 03 2005 John (J5) Palmieri <johnp@redhat.com> 2.0.2-13
  145. - rebuild with gcc 4.0
  146. * Mon Nov 08 2004 Colin Walters <walters@redhat.com> 2.0.2-12
  147. - Add libmusicbrainz-2.0.2-missing-return.patch (bug #137289)
  148. * Thu Oct 07 2004 Colin Walters <walters@redhat.com> 2.0.2-11
  149. - BuildRequire expat-devel
  150. * Tue Sep 28 2004 Colin Walters <walters@redhat.com> 2.0.2-10
  151. - Move .so symlink to -devel package
  152. * Tue Aug 31 2004 Colin Walters <walters@redhat.com> 2.0.2-9
  153. - Add ldconfig calls (bz #131281)
  154. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  155. - rebuilt
  156. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  157. - rebuilt
  158. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  159. - rebuilt
  160. * Thu Dec 18 2003 Brent Fox <bfox@redhat.com> 2.0.2-6
  161. - add a BuildPreReq for libstdc++-devel and gcc-c++ (bug #106556)
  162. - add a Requires for libstdc++-devel for libmusicbrainz-devel
  163. * Mon Sep 1 2003 Bill Nottingham <notting@redhat.com>
  164. - Obsoletes musicbrainz-devel too
  165. * Mon Sep 1 2003 Jonathan Blandford <jrb@redhat.com>
  166. - Obsoletes musicbrainz
  167. * Fri Aug 22 2003 Bill Nottingham <notting@redhat.com> 2.0.2-5
  168. - fix autoconf/libtool weirdness, remove exclusivearch
  169. * Fri Aug 22 2003 Brent Fox <bfox@redhat.com> 2.0.2-4
  170. - add ExcludeArch for s390x (something is really broken)
  171. * Fri Aug 22 2003 Brent Fox <bfox@redhat.com> 2.0.2-3
  172. - add ExcludeArch for ppc64
  173. * Fri Aug 22 2003 Brent Fox <bfox@redhat.com> 2.0.2-2
  174. - add ExcludeArch for x86_64 for now
  175. * Thu Aug 21 2003 Brent Fox <bfox@redhat.com>
  176. - Initial build.