libmpc-vl.spec 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122
  1. Summary: C library for multiple precision complex arithmetic
  2. Name: libmpc
  3. Version: 1.0.1
  4. Release: 1%{?_dist_release}
  5. License: LGPLv3+
  6. Group: Development/Tools
  7. URL: http://www.multiprecision.org/
  8. Source0: mpc-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  10. BuildRequires: gmp-devel >= 4.3.2
  11. BuildRequires: mpfr-devel >= 2.4.2
  12. BuildRequires: texinfo
  13. %description
  14. MPC is a C library for the arithmetic of complex numbers with
  15. arbitrarily high precision and correct rounding of the result. It is
  16. built upon and follows the same principles as Mpfr.
  17. %package devel
  18. Summary: Header and shared development libraries for MPC
  19. Group: Development/Libraries
  20. Requires: %{name} = %{version}-%{release}
  21. Requires: mpfr-devel gmp-devel
  22. %description devel
  23. Header files and shared object symlinks for MPC is a C library.
  24. %prep
  25. %setup -q -n mpc-%{version}
  26. %build
  27. export CPPFLAGS="%{optflags} -std=gnu99"
  28. export CFLAGS="%{optflags} -std=gnu99"
  29. export EGREP=egrep
  30. %configure
  31. make %{?_smp_mflags}
  32. %check
  33. make check
  34. %install
  35. rm -rf $RPM_BUILD_ROOT
  36. make install DESTDIR=$RPM_BUILD_ROOT
  37. rm -f $RPM_BUILD_ROOT/%{_libdir}/libmpc.{l,}a
  38. rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
  39. %clean
  40. rm -rf $RPM_BUILD_ROOT
  41. %post -p /sbin/ldconfig
  42. %postun -p /sbin/ldconfig
  43. %post devel
  44. if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
  45. /sbin/install-info %{_infodir}/mpc.info.gz %{_infodir}/dir || :
  46. fi
  47. %preun devel
  48. if [ $1 = 0 ]; then
  49. if [ -f %{_infodir}/mpc.info.gz ]; then # for --excludedocs
  50. /sbin/install-info --delete %{_infodir}/mpc.info.gz %{_infodir}/dir || :
  51. fi
  52. fi
  53. %files
  54. %defattr(-,root,root,-)
  55. %doc README NEWS COPYING.LESSER
  56. %{_libdir}/libmpc.so.*
  57. %files devel
  58. %defattr(-,root,root,-)
  59. %{_libdir}/libmpc.so
  60. %{_includedir}/mpc.h
  61. %{_infodir}/*.info*
  62. %changelog
  63. * Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
  64. - update to 1.0.1
  65. * Tue Nov 01 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 0.9-2
  66. - initial build for Vine Linux
  67. * Wed Jun 22 2011 <pmachata@redhat.com> - 0.9-1
  68. - Upstream 0.9
  69. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-0.3.svn855
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  71. * Tue Nov 30 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.2.svn855
  72. - Bump for rebuild against the new mpfr
  73. * Fri Nov 19 2010 Petr Machata <pmachata@redhat.com> - 0.8.3-0.1.svn855
  74. - Devel updates (to-be-0.8.3, SVN release 855)
  75. - New functions mpc_set_dc, mpc_set_ldc, mpc_get_dc, mpc_get_ldc
  76. - Speed-up mpc_pow_si and mpc_pow_z
  77. - Bug fixes in trigonometric functions, exp, sqrt
  78. - Upstream 0.8.2
  79. - Speed-up mpc_pow_ui
  80. - Adjust BuildRequires
  81. - Resolves: #653931
  82. * Wed Jan 20 2010 Petr Machata <pmachata@redhat.com> - 0.8.1-1
  83. - Upstream 0.8.1
  84. - acosh, asinh, atanh: swap of precisions between real and imaginary parts
  85. - atan: memory leak
  86. - log: wrong ternary value in data file; masked by bug in Mpfr 2.4.1
  87. - Resolves: #555471 FTBFS libmpc-0.8-3.fc13
  88. * Fri Nov 13 2009 Petr Machata <pmachata@redhat.com> - 0.8-3
  89. - Require mpfr-devel, gmp-devel in -devel subpackage
  90. - Don't pass --entry to install-info
  91. * Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-2
  92. - Rename the package to libmpc, it's a better choice of name
  93. - %%preun should uninstall mpc's info page, not make's
  94. - Move info page to -devel
  95. - BR on -devel packages
  96. - Drop postscript documentation
  97. * Thu Nov 12 2009 Petr Machata <pmachata@redhat.com> - 0.8-1
  98. - Initial package.