rhythmbox-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 0.13.1
  8. Release: 2%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: libgpod-devel
  15. BuildRequires: libgnomeui-devel >= 2.18.0
  16. BuildRequires: brasero-devel
  17. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  18. BuildRequires: gettext, rarian-compat
  19. BuildRequires: totem-pl-parser-devel
  20. BuildRequires: sqlite3-devel
  21. BuildRequires: libffi-devel
  22. BuildRequires: gnome-vfs2-devel >= 2.18.0
  23. BuildRequires: avahi-glib-devel >= 0.6
  24. BuildRequires: libmusicbrainz-devel >= 2.1.0
  25. BuildRequires: libnotify-devel
  26. BuildRequires: libsexy-devel
  27. BuildRequires: libgudev1-devel
  28. BuildRequires: libsoup-devel
  29. BuildRequires: dbus-devel >= 1.0
  30. BuildRequires: dbus-glib-devel
  31. BuildRequires: gnome-doc-utils >= 0.3.2
  32. BuildRequires: python-devel, pygtk2-devel
  33. BuildRequires: check >= 0.8.2
  34. BuildRequires: intltool >= 0.35.0
  35. BuildRequires: gstreamer-python
  36. BuildRequires: popt-devel
  37. BuildRequires: lirc
  38. BuildRequires: libmtp-devel
  39. BuildRequires: libgnome-keyring-devel >= 2.30.0
  40. BuildRequires: gnome-media-devel
  41. BuildRequires: libSM-devel
  42. Requires: libgpod
  43. Requires: libnotify
  44. Requires: libsexy
  45. Requires: lirc
  46. Requires: libmtp
  47. Requires: libgnomeui
  48. Requires: brasero
  49. Requires: gnome-python gnome-vfs2
  50. Requires: gnome-themes
  51. Requires: libgnome-keyring
  52. Requires: gstreamer-python
  53. %if %{enable_DLNA_UPnP}
  54. Requires: python-Coherence
  55. %endif
  56. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  57. Requires: scrollkeeper GConf2
  58. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  59. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  60. # # respectively.
  61. # Requires: self-build-gstreamer-plugins-ffmpeg
  62. # Requires: self-build-gstreamer-plugins-ugly
  63. %description
  64. Rhythmbox is an integrated music management application based on the powerful
  65. GStreamer media framework. It has a number of features, including an easy to
  66. use music browser, searching and sorting, comprehensive audio format support
  67. through GStreamer, Internet Radio support, playlists and more.
  68. Rhythmbox is extensible through a plugin system.
  69. %description -l ja
  70. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  71. 統合音楽管理アプリケーションです。
  72. 見やすいユーザインターフェースを備え、検索や整列ができ、
  73. GStreamer により数多くの音声フォーマットをサポート、
  74. インターネットラジオをサポート、プレイリスト管理などの
  75. 数多くの特徴を持ちます。
  76. %package devel
  77. Summary: Development tools for rhythmbox applications.
  78. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  79. Group: Development/Libraries
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: pkgconfig
  82. Requires: glib2-devel
  83. Requires: gtk2-devel
  84. Requires: libsoup-devel
  85. Requires: gnome-media-devel
  86. Requires: totem-pl-parser-devel
  87. Requires: gstreamer-devel
  88. %description devel
  89. Header files and libraries for building a extension library for the rhythmbox.
  90. %description devel -l ja
  91. %prep
  92. %setup -q
  93. # autoreconf -i
  94. # Use the installed louie, not the one in Coherence
  95. find plugins/coherence/upnp_coherence/ -type f \
  96. -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
  97. %build
  98. # work around a gstreamer bug
  99. /usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
  100. %configure --with-ipod \
  101. --with-mtp \
  102. --with-dbus \
  103. --with-mdns=avahi \
  104. --with-libnautilus-burn \
  105. --with-cd-burning \
  106. --with-metadata-helper \
  107. --enable-lirc \
  108. --enable-python \
  109. --disable-vala \
  110. --disable-browser-plugin \
  111. --disable-static \
  112. --disable-scrollkeeper \
  113. --disable-schemas-install \
  114. --without-hal
  115. %__make %{?_smp_mflags}
  116. %install
  117. %__rm -rf $RPM_BUILD_ROOT
  118. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  119. %__make install DESTDIR=$RPM_BUILD_ROOT
  120. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  121. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  122. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  123. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  124. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  125. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  126. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  127. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  128. ## Don't package DLNA/UPnP plugin
  129. %if !%{enable_DLNA_UPnP}
  130. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  131. %endif
  132. %find_lang %{name}
  133. # Don't package api docs
  134. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  135. # Don't package scrollkeeper catalogs
  136. %__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
  137. # And don't package vala
  138. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  139. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  140. # save space by linking identical images in translated docs
  141. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  142. for f in $helpdir/C/figures/*.png; do
  143. b="$(basename $f)"
  144. for d in $helpdir/*; do
  145. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  146. g="$d/figures/$b"
  147. if [ -f "$g" ]; then
  148. if cmp -s $f $g; then
  149. %__rm "$g"; ln -s "../../C/figures/$b" "$g"
  150. fi
  151. fi
  152. fi
  153. done
  154. done
  155. %clean
  156. %__rm -rf $RPM_BUILD_ROOT
  157. %post
  158. /sbin/ldconfig
  159. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  160. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
  161. update-desktop-database -q
  162. scrollkeeper-update -q
  163. touch --no-create %{_datadir}/icons/hicolor
  164. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  165. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  166. fi
  167. %preun
  168. if [ "$1" -eq 0 ]; then
  169. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  170. gconftool-2 --makefile-uninstall-rule \
  171. %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
  172. fi
  173. %postun
  174. /sbin/ldconfig
  175. update-desktop-database -q
  176. scrollkeeper-update -q
  177. touch --no-create %{_datadir}/icons/hicolor
  178. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  179. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  180. fi
  181. %files -f %{name}.lang
  182. %defattr(-, root, root)
  183. %doc AUTHORS COPYING ChangeLog README NEWS
  184. %{_sysconfdir}/gconf/schemas/rhythmbox.schemas
  185. %{_bindir}/*
  186. %{_libdir}/lib*.so.*
  187. %{_libdir}/rhythmbox/plugins
  188. %{_datadir}/applications/rhythmbox.desktop
  189. %{_datadir}/applications/rhythmbox-device.desktop
  190. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
  191. %{_datadir}/gnome/help/rhythmbox
  192. %{_datadir}/icons/*
  193. %{_datadir}/omf/rhythmbox
  194. %{_datadir}/rhythmbox
  195. %{_mandir}/man1/*
  196. %{_libexecdir}/rhythmbox-metadata
  197. %files devel
  198. %defattr(-, root, root)
  199. %{_includedir}/%{name}/*
  200. %{_libdir}/*.so
  201. %{_libdir}/pkgconfig/*.pc
  202. %changelog
  203. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  204. - rebuild with rpm-4.8.1 for pkg-config file
  205. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  206. - new upstream release
  207. - fix %files (add rhythmbox-device.desktop)
  208. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  209. - new upstream release
  210. - change BuildRequires: gnome-media-devel instead of gnome-media
  211. - add devel package
  212. - drop Patch0
  213. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  214. - new upstream release
  215. - drop Patch1, Patch2, Patch3
  216. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  217. - change Requires: nautilus-cd-burner -> brasero
  218. - change BuildRequires: hal-devel -> libgudev1-devel
  219. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  220. - change Requires: gnome-keyring -> libgnome-keyring
  221. - add configure option (--without-hal)
  222. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  223. - rebuilt with new environment
  224. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  225. - new upstream release
  226. - dropped upstreamed/obsolete patches
  227. - added patches applied Fedora development
  228. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  229. - new upstream release
  230. - added configure options:
  231. --disable-vala
  232. --disable-browser-plugin
  233. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  234. - added Japanese description
  235. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  236. - new upstream release
  237. - dropped rb-disable-power-plugin-by-default.patch
  238. - added BuildRequires:
  239. - libSM-devel
  240. - gnome-media
  241. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  242. - rebuild with libgpod-0.7.2
  243. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  244. - new upstream release
  245. - corrected License tag
  246. - dropped rhythmbox-0.11.6-libmtp.patch
  247. - added BuildRequires:
  248. - sqlite3-devel
  249. - libffi-devel
  250. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  251. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  252. - applied rhythmbox-0.11.6-libmtp.patch
  253. - added Requires:
  254. - libgpod
  255. - libnotify
  256. - libsexy
  257. - lirc
  258. - libmtp
  259. - libgnomeui
  260. - nautilus-cd-burner
  261. - gstreamer-python
  262. - gnome-vfs2
  263. - gnome-themes
  264. - gnome-keyring
  265. - python-Coherence, if enable_DLNA_UPnP = 1
  266. - added BuildRequires:
  267. - libnotify-devel
  268. - libsexy-devel
  269. - lirc
  270. - libmtp-devel
  271. - gnome-vfs2-devel, instead of gnome-vfs2
  272. - gnome-keyring-devel
  273. - dropped --with-internal-libsexy in configure options
  274. - added in configure options:
  275. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  276. - added %%preun to remove the schema
  277. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  278. - new upstream release
  279. - changed to --with-metadata-helper in configure options
  280. - added BuildRequires:
  281. - gstreamer-python
  282. - intltool >= 0.35.0
  283. - popt-devel
  284. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  285. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  286. - rebuilt with python-2.5.2
  287. - applied new versioning policy
  288. - spec in utf-8
  289. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  290. - rebuilt with libgpod-0.6.0
  291. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  292. - new upstream release
  293. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  294. - new upstream release
  295. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  296. - rebuilt with new toolchain and libgpod-0.4.2
  297. - add BuildRequires: dbus-glib-devel
  298. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  299. - new upstream release
  300. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  301. - rebuilt for VineSeed
  302. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  303. - new upstream release
  304. - added --enable-python option to %%configure
  305. - added Requires: gnome-python
  306. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  307. - new upstream release
  308. - built with libsoup 2.2.99
  309. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  310. - added --with-cd-burner to configure
  311. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  312. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  313. - add BuildRequires:
  314. - gnome-doc-utils >= 0.3.2
  315. - python-devel
  316. - pygtk2-devel
  317. - check >= 0.8.2
  318. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  319. - rebuild with gnutls-1.4.1
  320. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  321. - new upstream release
  322. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  323. - new upstream release
  324. - run scrollkeeper-update at %post and %postun
  325. - added BuildRequires: libnotify-devel
  326. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  327. - new upstream release (dropped patch0)
  328. - added --without-metadata-helper at configure
  329. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  330. - Initial build for Vine Linux based on FC pacakge
  331. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  332. - add patch from James "Doc" Livingston to stop a hang
  333. for new users (bug 183883)
  334. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  335. - bump again for double-long bug on ppc(64)
  336. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  337. - rebuilt for new gcc4.1 snapshot and glibc changes
  338. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  339. - Update to 0.9.3.1
  340. - Use gstreamer (0.10)
  341. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  342. - Remove hack for 173869, as its no longer needed.
  343. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  344. - 0.9.3
  345. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  346. - Newer CVS snapshot
  347. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  348. - Update to latest CVS
  349. - Add hack to workaround bug #173869
  350. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  351. - Rebuild, now that gstreamer08-plugins has been fixed
  352. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  353. - bonobo multilib issue (bug 156982)
  354. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  355. - rebuild with ipod support
  356. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  357. - rebuilt again
  358. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  359. - rebuilt
  360. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  361. - rebuild
  362. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  363. - rebuild for new dbus
  364. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  365. - Update to 0.9.2
  366. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  367. - Update to 0.9.1
  368. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  369. - Add configure flags --with-bonobo --with-dbus
  370. - BR nautilus-cd-burner-devel
  371. - New upstream CVS snapshot for testing
  372. - Drop IDL file and ui .xml
  373. - Add dbus service file
  374. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  375. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  376. * Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  377. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  378. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  379. cell renderer for playback icon (no longer necessary) and
  380. changes the rating renderer to work with non-b&w icons
  381. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  382. - Rebuild for GCC4
  383. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  384. - New upstream version
  385. - Remove librb-nautilus-context-menu.so, killed upstream
  386. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  387. - PreReq desktop-file-utils >= 0.9
  388. * Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  389. - New upstream version
  390. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  391. - Fix postun to use correct syntax, thanks Nils Philippsen
  392. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  393. - New upstream version
  394. - Call update-desktop-database in post and postun
  395. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  396. - New upstream version
  397. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  398. - rebuilt
  399. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  400. - New upstream version
  401. - Remove backported patches
  402. - Gratuitiously bump various BuildRequires versions
  403. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  404. - Remove code to unregister GConf schema for now (Closes: #122532)
  405. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  406. - Apply tiny patch from 0.8 arch to fix GConf key used
  407. for initial sorting
  408. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  409. - Apply patch from 0.8 arch tree to fix a number of memleaks
  410. * Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  411. - Update to 0.8.3: fixes showstopper bug with internet radio
  412. * Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  413. - Update to 0.8.2
  414. - Fix Source url
  415. - Add smp_mflags
  416. - Bump BuildRequires on gstreamer to 0.8.1
  417. * Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  418. - Uninstall GConf schemas on removal
  419. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  420. - Update to 0.8.1
  421. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  422. - Update to 0.8.0
  423. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  424. - Update to 0.7.2
  425. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  426. - Remove BuildRequires on autoconf and libvorbis-devel
  427. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  428. - New major version - I know we are past major version slush, but
  429. this should have been done two weeks ago along with the GNOME 2.6
  430. upload. As upstream author as well, I believe this version is
  431. good enough for FC2.
  432. - Remove --disable-mp3
  433. - Remove id3, flac variables
  434. - Remove GStreamer major version patch
  435. - Fix typo in description
  436. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  437. - rebuild for new gstreamer
  438. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  439. - update to 0.6.8
  440. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  441. - rebuilt
  442. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  443. - update to 0.6.7
  444. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  445. - rebuilt
  446. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  447. - New upstream version
  448. - Don't re-run the autotools; upstream incorporates newer versions.
  449. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  450. - new version
  451. - remove smp_flags
  452. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  453. - remove the initial iradio channels as they all are mp3 based.
  454. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  455. - Fix category from Development/Libraries to Applications/Multimedia.
  456. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  457. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  458. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  459. - Removed unnecessary date expansion define.
  460. - Updated description, including mp3 reference removal.
  461. - Added libid3tag and flac optional support for convenient rebuild.
  462. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  463. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  464. - new version
  465. - use %{_sysconfdir} instead of /etc
  466. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  467. - rebuilt
  468. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  469. - gave up on other archs for the Beta
  470. - new version
  471. - remove werror and add missing files
  472. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  473. - update to newer cvs snap
  474. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  475. - update to cvs snap
  476. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  477. - use %%(lang)
  478. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  479. - fix post to actually install the schema
  480. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  481. - Added gconf file
  482. - Added i18n directory
  483. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  484. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  485. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  486. - removed bonobo dependency
  487. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  488. - created new spec file