Browse Source

updated 12 packages

cdparanoia-10.2-5

dnsmasq-2.85-1

gstreamer1-plugins-base-1.18.4-1

gstreamer1-plugins-good-1.18.4-1

gstreamer1-1.18.4-1

libavc1394-0.5.4-4

libdv-1.0.0-5

libiec61883-1.2.0-4

libraw1394-2.1.2-1

libvpx-1.10.0-1

taglib-1.12-1

v4l-utils-1.20.0-1
Tomohiro "Tomo-p" KATO 1 year ago
parent
commit
c2e571e74f

+ 29 - 13
c/cdparanoia/cdparanoia-vl.spec

@@ -4,9 +4,9 @@ Name: cdparanoia
 Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
 Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
 Version: 10.2
-Release: 4%{?_dist_release}
+Release: 5%{?_dist_release}
+Group: system,multimedia
 
-Group: Applications/Multimedia
 License: GPLv2 and LGPLv2
 URL: http://www.xiph.org/paranoia/index.html
 
@@ -19,6 +19,10 @@ Patch0: cdparanoia-10.2-#463009.patch
 Patch1: cdparanoia-10.2-endian.patch
 Patch2: cdparanoia-10.2-install.patch
 Patch3: cdparanoia-10.2-format-security.patch
+Patch4: cdparanoia-use-proper-gnu-config-files.patch
+Patch5: cdparanoia-10.2-ldflags.patch
+# https://svn.xiph.org/trunk/cdparanoia@17289
+Patch6: cdparanoia-10.2-add-pkgconfig.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 
@@ -32,10 +36,11 @@ drives prone to misalignment, frame jitter and loss of streaming during
 atomic reads.  Cdparanoia is also good at reading and repairing data from
 damaged CDs.
 
+
 %package devel
 Summary: Development tools for libcdda_paranoia (Paranoia III).
 Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
-Group: Development/Libraries
+Group: programming
 License: LGPLv2
 Requires: %{name} = %{version}-%{release}
 
@@ -43,11 +48,12 @@ Requires: %{name} = %{version}-%{release}
 The cdparanoia-devel package contains the static libraries and header
 files needed for developing applications to read CD Digital Audio disks.
 
+
 # compat32
 %package -n compat32-%{name}
 Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
 Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
-Group: Applications/Multimedia
+Group: system,legacy
 Requires: %{name} = %{version}-%{release}
 
 %description -n compat32-%{name}
@@ -63,7 +69,7 @@ damaged CDs.
 %package -n compat32-%{name}-devel
 Summary: Development tools for libcdda_paranoia (Paranoia III).
 Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
-Group: Development/Libraries
+Group: programming,legacy
 Requires: compat32-%{name} = %{version}-%{release}
 Requires: %{name}-devel = %{version}-%{release}
 
@@ -72,19 +78,28 @@ The cdparanoia-devel package contains the static libraries and header
 files needed for developing applications to read CD Digital Audio disks.
 
 
+%debug_package
+
+
 %prep
 %setup -q -n %{name}-III-%{version}
 %patch0 -p3 -b .#463009
 %patch1 -p1 -b .endian
 %patch2 -p1 -b .install
 %patch3 -p1 -b .fmt-sec
+%patch4 -p1 -b .config
+%patch5 -p1 -b .ldflags
+%patch6 -p1 -b .pkgconfig
+
 
 %build
+autoreconf -ifv
 %configure --includedir=%{_includedir}/cdda
 # Using -O0 is mandatory, the build fails otherwise...
 # Also remove many warnings which we are aware of
 # Lastly, don't use _smp_mflags since it also makes the build fail
-make OPT="$RPM_OPT_FLAGS -O0 -Wno-pointer-sign -Wno-unused"
+make OPT="$RPM_OPT_FLAGS -Wno-pointer-sign -Wno-unused" LDFLAGS="%{?__global_ldflags}"
+
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -92,17 +107,11 @@ make install DESTDIR=$RPM_BUILD_ROOT
 mkdir -p %{buildroot}%{_mandir}/ja/man1
 install -m644 cdparanoia.1.jp %{buildroot}%{_mandir}/ja/man1/cdparanoia.1
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
-
-%post -n compat32-%{name} -p /sbin/ldconfig
-
-%postun -n compat32-%{name} -p /sbin/ldconfig
 
 %clean
 [ "$RPM_BUILD_ROOT" != "/" -a -d "$RPM_BUILD_ROOT" ] && rm -rf "$RPM_BUILD_ROOT"
 
+
 %files
 %defattr(-,root,root)
 %doc README COPYING-GPL COPYING-LGPL
@@ -116,6 +125,7 @@ install -m644 cdparanoia.1.jp %{buildroot}%{_mandir}/ja/man1/cdparanoia.1
 %{_includedir}/cdda
 %{_libdir}/lib*.so
 %{_libdir}/*.a
+%{_libdir}/pkgconfig/cdparanoia-3.pc
 
 # compat32
 %if %{build_compat32}
@@ -128,7 +138,13 @@ install -m644 cdparanoia.1.jp %{buildroot}%{_mandir}/ja/man1/cdparanoia.1
 %{_libdir}/*.so
 %endif
 
+
 %changelog
+* Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.2-5
+- rebuilt with current environment.
+- dropped ldconfig scriptlets.
+- imported Patch4-6 from rawhide.
+
 * Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.2-4
 - imported Patch1-3 from rawhide.
 

+ 7 - 4
d/dnsmasq/dnsmasq-vl.spec

@@ -1,8 +1,8 @@
 %bcond_with systemd
 
 Name:           dnsmasq
-Version:        2.84
-Release:        2%{?_dist_release}%{?with_systemd:.systemd}
+Version:        2.85
+Release:        1%{?_dist_release}%{?with_systemd:.systemd}
 Summary:        A lightweight DHCP/caching DNS server
 Summary(ja):    軽量 DHCP/DNSキャッシュサーバ
 Group:          servers
@@ -10,8 +10,8 @@ Vendor:         Project Vine
 Distribution:   Vine Linux
 
 License:        GPLv2 or GPLv3
-URL:            http://www.thekelleys.org.uk/dnsmasq/
-Source0:        http://www.thekelleys.org.uk/dnsmasq/%{name}-%{version}.tar.xz
+URL:            https://www.thekelleys.org.uk/dnsmasq/
+Source0:        https://www.thekelleys.org.uk/dnsmasq/%{name}-%{version}.tar.xz
 Source1:        %{name}.service
 Source2:        dnsmasq-systemd-sysusers.conf
 Patch0:         %{name}-2.33-initscript.patch
@@ -220,6 +220,9 @@ fi
 
 
 %changelog
+* Thu Apr 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.85-1
+- new upstream release.
+
 * Thu Mar 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.84-2
 - updated the configuration file to fix CVE-2020-14312.
 

+ 61 - 54
g/gstreamer1-plugins-base/gstreamer1-plugins-base-vl.spec

@@ -2,13 +2,12 @@
 
 %define major 1.0
 
-%define _gst_ver	1.16.0
+%define _gst_ver	1.18.0
 %define _glib2_ver	2.55.0
 %define _gtk3_ver	3.20.6
-%define _gtk_doc_ver	1.3
-%define _qt5_ver	5.6
+%define _qt5_ver	5.15
 %define _check_ver	0.9.2
-%define _python_ver	2.7
+%define _python_ver	3.8
 %define _alsa_lib_ver	0.9.1
 %define _libogg_ver	1.0
 %define _libvorbis_ver	1.0
@@ -20,40 +19,49 @@
 Summary:	GStreamer Streaming-media framework base plugins
 Summary(ja):	GStreamer ストリーミングメディアフレームワーク用基本プラグイン
 Name:		gstreamer1-plugins-base
-Version:	1.16.2
+Version:	1.18.4
 Release:	1%{?_dist_release}
-Group:		System Environment/Libraries
+Group:		system,multimedia
 Vendor:		Project Vine
 Distribution:	Vine Linux
 
 License:	LGPL
 URL:		https://gstreamer.freedesktop.org/
 Source:		https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.xz
-BuildRoot:	%{_tmppath}/%{name}-%{version}-root
+Patch0:		0001-missing-plugins-Remove-the-mpegaudioversion-field.patch
 
-Requires:	gstreamer1 >= %{_gst_ver}
+BuildRoot:	%{_tmppath}/%{name}-%{version}-root
 
+BuildRequires:	alsa-lib-devel >= %{_alsa_lib_ver}
+BuildRequires:	gdk-pixbuf2-devel
 BuildRequires:	gstreamer1-devel >= %{_gst_ver}
-BuildRequires:	gtk-doc >= %{_gtk_doc_ver}
-BuildRequires:	python >= %{_python_ver}, python-pyxml
-BuildRequires:	glib2-devel >= %{_glib2_ver}
-BuildRequires:	check >= %{_check_ver}
 BuildRequires:	gtk3-devel >= %{_gtk3_ver}
-BuildRequires:	qt5-qtbase-devel >= %{_qt5_ver}
-BuildRequires:	alsa-lib-devel >= %{_alsa_lib_ver}
 BuildRequires:	cdparanoia-devel
+BuildRequires:	libjpeg-turbo-devel
 BuildRequires:	libogg-devel >= %{_libogg_ver}
-BuildRequires:	libtheora-devel, libvorbis-devel >= %{_libvorbis_ver}
+BuildRequires:	libtheora-devel
+BuildRequires:	libvorbis-devel >= %{_libvorbis_ver}
+BuildRequires:	libXv-devel
+BuildRequires:	meson
 BuildRequires:	opus-devel
+BuildRequires:	orc-devel >= %{_orc_ver}
 BuildRequires:	pango-devel
-BuildRequires:	freetype2-devel >= %{_freetype2_ver}
-BuildRequires:  fontconfig-devel
-BuildRequires:  libX11-devel
-BuildRequires:  libXv-devel
-BuildRequires:  libvisual-devel
-BuildRequires:  orc-devel >= %{_orc_ver}
-BuildRequires:  gobject-introspection-devel
+# for autogen.sh
+BuildRequires:	mesa-libGL-devel
+BuildRequires:	mesa-libGLES-devel
+BuildRequires:	mesa-libGLU-devel
+BuildRequires:	mesa-libEGL-devel
+BuildRequires:	wayland-devel
+BuildRequires:	egl-wayland-devel
+BuildRequires:	graphene-devel
+# pkgconfig-style deps specifically searched-for by autotools/configure
+BuildRequires:	pkgconfig(wayland-client) >= 1.0
+BuildRequires:	pkgconfig(wayland-cursor) >= 1.0
+BuildRequires:	pkgconfig(wayland-egl)
+BuildRequires:	pkgconfig(wayland-protocols) >= 1.15
+BuildRequires:	iso-codes
 
+Requires:	gstreamer1 >= %{_gst_ver}
 
 %description
 GStreamer is a streaming-media framework, based on graphs of filters which
@@ -65,10 +73,11 @@ plugins.
 
 This package contains a set of well-maintained base plugins.
 
+
 %package devel
 Summary:	Libraries/include files for GStreamer base plugins
 Summary(ja):	GStreamer 基本プラグインの開発用ライブラリ
-Group:		Development/Libraries
+Group:		programming
 Requires:	%{name} = %{version}-%{release}
 Requires:	gstreamer1-devel >= %{_gst_ver}
 
@@ -83,11 +92,12 @@ plugins.
 This package contains GStreamer base plugins library depvelopment and header
 files.
 
+
 # compat32
 %package -n compat32-%{name}
 Summary:	GStreamer Streaming-media framework base plugins
 Summary(ja):	GStreamer ストリーミングメディアフレームワーク用基本プラグイン
-Group:		System Environment/Libraries
+Group:		system,multimedia,legacy
 Requires:	%{name} = %{version}-%{release}
 
 %description -n compat32-%{name}
@@ -100,10 +110,11 @@ plugins.
 
 This package contains a set of well-maintained base plugins.
 
+
 %package -n compat32-%{name}-devel
 Summary:	Libraries/include files for GStreamer base plugins
 Summary(ja):	GStreamer 基本プラグインの開発用ライブラリ
-Group:		Development/Libraries
+Group:		programming,legacy
 Requires:	compat32-%{name} = %{version}-%{release}
 Requires:	%{name}-devel = %{version}-%{release}
 Requires:	compat32-gstreamer1-devel >= %{_gst_ver}
@@ -120,65 +131,57 @@ This package contains GStreamer base plugins library depvelopment and header
 files.
 
 
+%debug_package
+
+
 %prep
 %setup -q -n gst-plugins-base-%{version}
+%patch0 -p1
 
-%build
-%ifarch alpha
-%define optflags -O2 -mieee -fPIC
-%endif
 
-%configure \
-	--with-package-name='Vine Linux gstreamer-plugins-base package' \
-	--disable-static \
-	--disable-debug \
-        --enable-orc \
-	--enable-introspection=yes \
-	--enable-wayland=no
+%build
+%meson \
+  -Dpackage-name='Vine Linux GStreamer-plugins-base package' \
+  -Dpackage-origin='https://vinelinux.org/' \
+  -Ddoc=disabled \
+  -Dgtk_doc=disabled \
+  -Dorc=enabled \
+  -Dtremor=disabled \
+  -Dlibvisual=disabled \
+  -Dtests=disabled \
+  -Dexamples=disabled
+%meson_build
 
-make %{?_smp_mflags}
 
 %install
 [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
-make install DESTDIR=$RPM_BUILD_ROOT
+%meson_install
+
+%find_lang %{po_package}
 
 # Clean out files that should not be part of the rpm.
-rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.{a,la}
-rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
+find $RPM_BUILD_ROOT -name '*.la' -exec rm -fv {} ';'
 
-%find_lang %{po_package}
 
 %clean
 [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
-
-%post -n compat32-%{name} -p /sbin/ldconfig
-
-%postun -n compat32-%{name} -p /sbin/ldconfig
 
 %files -f %{po_package}.lang
 %defattr(-,root,root)
 %license COPYING*
 %doc AUTHORS ChangeLog NEWS README RELEASE REQUIREMENTS
-
 # helper programs
 %{_bindir}/gst-*
 %{_mandir}/man1/gst-*
-
-%{_datadir}/gst-plugins-base/1.0/license-translations.dict
-
 # libraries
 %{_libdir}/libgst*-%{major}.so.*
 %{_libdir}/girepository-1.0/*.typelib
 %{_libdir}/gstreamer-%{major}/libgst*.so
+%{_datadir}/gst-plugins-base/1.0/license-translations.dict
 
 %files devel
 %defattr(-,root,root)
-%{_datadir}/gtk-doc/html/gst-plugins-base-libs-%{major}
-%{_datadir}/gtk-doc/html/gst-plugins-base-plugins-%{major}
 %{_datadir}/gir-1.0/*.gir
 %dir %{_includedir}/gstreamer-%{major}
 %dir %{_includedir}/gstreamer-%{major}/gst
@@ -202,6 +205,10 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
 
 
 %changelog
+* Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.18.4-1
+- new upstream release.
+- dropped ldconfig scriptlets.
+
 * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.2-1
 - new upstream release.
 

+ 129 - 83
g/gstreamer1-plugins-good/gstreamer1-plugins-good-vl.spec

@@ -1,12 +1,26 @@
+%bcond_without qt
+
+Name:		gstreamer1-plugins-good
+Summary:	GStreamer Streaming-media framework good plugins
+Summary(ja):	GStreamer ストリーミングメディアフレームワーク用優良プラグイン
+Version:	1.18.4
+Release:	1%{?_dist_release}
+Group:		system,multimedia
+Vendor:		Project Vine
+Distribution:	Vine Linux
+
+License:	LGPL
+URL:		https://gstreamer.freedesktop.org/
+Source:		https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-%{version}.tar.xz
+Patch0:		gstreamer1-plugins-good-gcc11.patch
+
 %define major 1.0
 
-%define _gst_ver	1.16.2
-%define _gstpb_ver	1.16.2
+%define _gst_ver	1.18.4
+%define _gstpb_ver	1.18.4
 %define _glib2_ver	2.38.0
 %define _gtk3_ver	3.10.0
-%define _gtk_doc_ver	1.3
 %define _check_ver	0.9.2
-%define _python_ver	2.7
 %define _cairo_ver	1.0.0
 %define _flac_ver	1.2.0
 %define _libdv_ver	0.100
@@ -19,28 +33,12 @@
 
 %define po_package	gst-plugins-good-%{major}
 
-Name:		gstreamer1-plugins-good
-Summary:	GStreamer Streaming-media framework good plugins
-Summary(ja):	GStreamer ストリーミングメディアフレームワーク用優良プラグイン
-Version:	1.16.2
-Release:	1%{?_dist_release}
-Group:		System Environment/Libraries
-Vendor:		Project Vine
-Distribution:	Vine Linux
-
-License:	LGPL
-URL:		https://gstreamer.freedesktop.org/
-Source:		https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-%{version}.tar.xz
-
 BuildRoot:	%{_tmppath}/%{name}-%{version}-root
 BuildRequires:	gstreamer1-devel >= %{_gst_ver}
 BuildRequires:	gstreamer1-plugins-base-devel >= %{_gstpb_ver}
-BuildRequires:	gtk-doc >= %{_gtk_doc_ver}
-BuildRequires:	python >= %{_python_ver}, python-pyxml
 BuildRequires:	glib2-devel >= %{_glib2_ver}
 BuildRequires:	check-devel >= %{_check_ver}
 BuildRequires:	gtk3-devel >= %{_gtk3_ver}
-BuildRequires:	aalib-devel
 BuildRequires:	cairo-devel >= %{_cairo_ver}
 BuildRequires:	flac-devel >= %{_flac_ver}
 BuildRequires:	libjpeg-devel
@@ -63,14 +61,21 @@ BuildRequires:  libXv-devel
 BuildRequires:  bzip2-devel
 BuildRequires:  jack-audio-connection-kit-devel
 BuildRequires:  libuuid-devel
+BuildRequires:  lame-devel
+BuildRequires:  nasm
+BuildRequires:  meson
+%if %{with qt}
+BuildRequires:	pkgconfig(Qt5Gui)
+BuildRequires:	pkgconfig(Qt5Qml)
+BuildRequires:	pkgconfig(Qt5Quick)
+BuildRequires:	pkgconfig(Qt5X11Extras)
+BuildRequires:	pkgconfig(Qt5WaylandClient)
+%endif
 
 Requires:	gstreamer1 >= %{_gst_ver}
 Requires:	gstreamer1-plugins-base >= %{_gstpb_ver}
-#Requires:	cairo >= %{_cairo_ver}
-#Requires:	libjpeg
-#Requires:	libpng >= %{_libpng_ver}
-#Requires:	taglib >= %{_taglib_ver}
-#Requires:	dbus >= %{_dbus_ver}
+Obsoletes:	%{name}-doc < 1.18.0
+Obsoletes:	%{name}-aa < 1.18.0
 
 %description
 GStreamer is a streaming-media framework, based on graphs of filters which
@@ -83,10 +88,11 @@ plugins.
 This package contains a set of well-supported plugins of good quality and
 under the LGPL license.
 
+
 %package flac
 Summary:	GStreamer plugin for de/encoding FLAC files
 Summary(ja):	GStreamer FLAC ファイルデコード/エンコードプラグイン
-Group:		System Environment/Libraries
+Group:		system,multimedia
 Requires:	%{name} = %{version}-%{release}
 Requires:	flac >= %{_flac_ver}
 
@@ -100,10 +106,11 @@ plugins.
 
 This package contains GStreamer plugin for de/encoding FLAC files.
 
+
 %package speex
 Summary:	GStreamer plugin for de/encoding Speex files
 Summary(ja):	GStreamer Speex ファイルデコード/エンコードプラグイン
-Group:		System Environment/Libraries
+Group:		system,multimedia
 Requires:	%{name} = %{version}-%{release}
 Requires:	speex >= %{_speex_ver}
 
@@ -117,10 +124,11 @@ plugins.
 
 This package contains GStreamer plugin for de/encoding Speex files.
 
+
 %package dv
 Summary:	GStreamer DV plugin
 Summary(ja):	GStreamer DV プラグイン
-Group:		System Environment/Libraries
+Group:		system,multimedia
 Requires:	%{name} = %{version}-%{release}
 Requires:	libdv >= %{_libdv_ver}
 
@@ -135,10 +143,11 @@ plugins.
 This package contains GStreamer plugin for digital video support using
 libdv.
 
+
 %package raw1394
 Summary:	GStreamer raw1394 FireWire plugin
 Summary(ja):	GStreamer raw1394 FireWire プラグイン
-Group:		System Environment/Libraries
+Group:		system,multimedia
 Requires:	%{name} = %{version}-%{release}
 Requires:	libavc1394, libraw1394, libiec61883
 
@@ -153,63 +162,94 @@ plugins.
 This package contains GStreamer plugin for digital video support using
 raw1394.
 
-%package aa
-Summary:	GStreamer plugin for Ascii-art output
-Summary(ja):	GStreamer アスキーアート出力プラグイン
-Group:		System Environment/Libraries
-Requires:	%{name} = %{version}-%{release}
-Requires:	aalib
 
-%description aa
-GStreamer is a streaming-media framework, based on graphs of filters which
-operate on media data. Applications using this library can do anything
-from real-time sound processing to playing videos, and just about anything
-else media-related.  Its plugin-based architecture means that new data
-types or processing capabilities can be added simply by installing new
-plugins.
+%package gtk
+Summary:	GStreamer "good" plugins gtk plugin
+Group:		system,multimedia
+Requires:	%{name}%{?_isa} = %{version}-%{release}
 
-This package contains GStreamer plugin for viewing movies in Ascii-art
-using aalib.
+%description gtk
+GStreamer is a streaming media framework, based on graphs of elements which
+operate on media data.
 
-%package doc
-Summary:	Documentation files for GStreamer good plugins.
-Summary(ja):	GStreamer 優良プラグインのドキュメント
-Group:		Development/Libraries
-Requires:	%{name} = %{version}-%{release}
-BuildArch:	noarch
+GStreamer Good Plugins is a collection of well-supported plugins of
+good quality and under the LGPL license.
+
+This package (%{name}-gtk) contains the gtksink output plugin.
+
+
+%if %{with qt}
+%package qt
+Summary:	GStreamer "good" plugins qt qml plugin
+Group:		system,multimedia
+Requires:	%{name}%{?_isa} = %{version}-%{release}
+Supplements:	(gstreamer1-plugins-good and qt5-qtdeclarative)
+
+%description qt
+GStreamer is a streaming media framework, based on graphs of elements which
+operate on media data.
+
+GStreamer Good Plugins is a collection of well-supported plugins of
+good quality and under the LGPL license.
+
+This package (%{name}-qt) contains the qtsink output plugin.
+%endif
+
+
+%package jack
+Summary:	GStreamer plugins for jack-audio-connector-kit
+Group:		system,multimedia
+Requires:	%{name}%{?_isa} = %{version}-%{release}
+
+%description jack
+GStreamer is a streaming media framework, based on graphs of filters
+which operate on media data.
+
+GStreamer Good Plugins is a collection of well-supported plugins of
+good quality and under the LGPL license.
+
+This package contains the jack-audio-connector-kit output plugin.
+
+
+%debug_package
 
-%description doc
-This package contains documentation for GStreamer good plugins.
-files.
 
 %prep
 %setup -q -n gst-plugins-good-%{version}
-sed -i 's/GT_REQ/GTK_REQ/g' configure
-sed -i 's/$with_gtk/3.0/g' configure
+%patch0 -p2
+
 
 %build
-%ifarch alpha
-%define optflags -O2 -mieee -fPIC
-%endif
+%meson \
+  -Dpackage-name='Vine Linux GStreamer-plugins-good package' \
+  -Dpackage-origin='https://vinelinux.org/' \
+  -Ddoc=disabled \
+  -Dasm=enabled \
+  -Dgtk_doc=disabled \
+  -Djack=enabled \
+  -Dorc=enabled \
+  -Dmonoscope=disabled \
+  -Dlibcaca=disabled \
+  -Drpicamsrc=disabled \
+  -Dshout2=disabled \
+  -Dmpg123=disabled \
+  -Dtwolame=disabled \
+  -Daalib=disabled \
+  -Dwavpack=disabled \
+  -Dtests=disabled \
+  %{nil}
+%meson_build
 
-%configure \
-	-with-package-name='Vine Linux gstreamer-plugins-good package' \
-	--enable-nls \
-	--disable-libcaca \
-	--disable-shout2 \
-	--enable-gtk-doc --disable-debug 
-make %{?_smp_mflags}
 
 %install
 [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
-make install DESTDIR=$RPM_BUILD_ROOT
+%meson_install
 
-# Clean out files that should not be part of the rpm.
-rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.{a,la}
-rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
+find $RPM_BUILD_ROOT -name '*.la' -exec rm -fv {} ';'
 
 %find_lang %{po_package}
 
+
 %clean
 [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
 
@@ -241,13 +281,11 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
 %{_libdir}/gstreamer-%{major}/libgstflxdec.so
 %{_libdir}/gstreamer-%{major}/libgstgoom.so
 %{_libdir}/gstreamer-%{major}/libgstgoom2k1.so
-%{_libdir}/gstreamer-%{major}/libgstgtk.so
 %{_libdir}/gstreamer-%{major}/libgsticydemux.so
 %{_libdir}/gstreamer-%{major}/libgstid3demux.so
 %{_libdir}/gstreamer-%{major}/libgstimagefreeze.so
 %{_libdir}/gstreamer-%{major}/libgstinterleave.so
 %{_libdir}/gstreamer-%{major}/libgstisomp4.so
-%{_libdir}/gstreamer-%{major}/libgstjack.so
 %{_libdir}/gstreamer-%{major}/libgstlevel.so
 %{_libdir}/gstreamer-%{major}/libgstmatroska.so
 %{_libdir}/gstreamer-%{major}/libgstmulaw.so
@@ -255,35 +293,35 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
 %{_libdir}/gstreamer-%{major}/libgstmultipart.so
 %{_libdir}/gstreamer-%{major}/libgstnavigationtest.so
 %{_libdir}/gstreamer-%{major}/libgstoss4.so
-%{_libdir}/gstreamer-%{major}/libgstossaudio.so
 %{_libdir}/gstreamer-%{major}/libgstreplaygain.so
 %{_libdir}/gstreamer-%{major}/libgstrtp.so
-%{_libdir}/gstreamer-%{major}/libgstrtpmanager.so
 %{_libdir}/gstreamer-%{major}/libgstrtsp.so
 %{_libdir}/gstreamer-%{major}/libgstshapewipe.so
 %{_libdir}/gstreamer-%{major}/libgstsmpte.so
 %{_libdir}/gstreamer-%{major}/libgstspectrum.so
 %{_libdir}/gstreamer-%{major}/libgstudp.so
-%{_libdir}/gstreamer-%{major}/libgstvideo4linux2.so
 %{_libdir}/gstreamer-%{major}/libgstvideobox.so
 %{_libdir}/gstreamer-%{major}/libgstvideocrop.so
 %{_libdir}/gstreamer-%{major}/libgstvideofilter.so
 %{_libdir}/gstreamer-%{major}/libgstvideomixer.so
-%{_libdir}/gstreamer-%{major}/libgstvpx.so
 %{_libdir}/gstreamer-%{major}/libgstwavenc.so
 %{_libdir}/gstreamer-%{major}/libgstwavparse.so
 %{_libdir}/gstreamer-%{major}/libgstximagesrc.so
 %{_libdir}/gstreamer-%{major}/libgsty4menc.so
-#%{_libdir}/gstreamer-%{major}/libgstwavpack.so
 
 # base plugins with external dependencies, but in the main package
 %{_libdir}/gstreamer-%{major}/libgstcairo.so
 %{_libdir}/gstreamer-%{major}/libgstgdkpixbuf.so
 %{_libdir}/gstreamer-%{major}/libgstjpeg.so
+%{_libdir}/gstreamer-%{major}/libgstlame.so
+%{_libdir}/gstreamer-%{major}/libgstossaudio.so
 %{_libdir}/gstreamer-%{major}/libgstpng.so
+%{_libdir}/gstreamer-%{major}/libgstpulseaudio.so
+%{_libdir}/gstreamer-%{major}/libgstrtpmanager.so
 %{_libdir}/gstreamer-%{major}/libgstsoup.so
 %{_libdir}/gstreamer-%{major}/libgsttaglib.so
-%{_libdir}/gstreamer-%{major}/libgstpulseaudio.so
+%{_libdir}/gstreamer-%{major}/libgstvideo4linux2.so
+%{_libdir}/gstreamer-%{major}/libgstvpx.so
 
 %files flac
 %defattr(-,root,root)
@@ -301,15 +339,23 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
 %defattr(-,root,root)
 %{_libdir}/gstreamer-%{major}/libgst1394.so
 
-%files aa
-%defattr(-,root,root)
-%{_libdir}/gstreamer-%{major}/libgstaasink.so
+%files gtk
+%{_libdir}/gstreamer-%{major}/libgstgtk.so
+
+%if %{with qt}
+%files qt
+%{_libdir}/gstreamer-%{major}/libgstqmlgl.so
+%endif
+
+%files jack
+%{_libdir}/gstreamer-%{major}/libgstjack.so
 
-%files doc
-%defattr(-,root,root)
-%{_datadir}/gtk-doc/html/gst-plugins-good-plugins-%{major}
 
 %changelog
+* Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.18.4-1
+- new upstream release.
+- dropped doc package.
+
 * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.2-1
 - new upstream release.
 

+ 43 - 41
g/gstreamer1/gstreamer1-vl.spec

@@ -1,8 +1,6 @@
 # keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
 %define major		1.0
 
-%define _gtk_doc_ver	1.6
-
 %define po_package	gstreamer-%{major}
 
 %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
@@ -10,22 +8,28 @@
 Name:		gstreamer1
 Summary:	GStreamer streaming media framework runtime.
 Summary(ja):	GStreamer ストリーミングメディアフレームワークランタイム
-Version:	1.16.2
+Version:	1.18.4
 Release:	1%{?_dist_release}
-Group:		System Environment/Libraries
+Group:		multimedia,system
 Vendor:		Project Vine
 Distribution:	Vine Linux
 
 License:	LGPL
-URL:		http://gstreamer.freedesktop.org/
-Source:		http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
+URL:		https://gstreamer.freedesktop.org/
+Source:		https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
 
 BuildRoot:	%{_tmppath}/%{name}-%{version}-root
 
+BuildRequires:	meson
+BuildRequires:	glib2-devel
 BuildRequires:	gobject-introspection-devel
+BuildRequires:	libxml2-devel
 BuildRequires:	bison
-BuildRequires:	gtk-doc >= %{_gtk_doc_ver}
 BuildRequires:	flex
+BuildRequires:	gettext
+BuildRequires:	libunwind-devel
+BuildRequires:	elfutils-devel
+BuildRequires:  bash-completion
 
 %description
 GStreamer is a streaming-media framework, based on graphs of filters which
@@ -38,8 +42,10 @@ plugins.
 %package devel
 Summary:	Libraries/header files for GStreamer streaming media framework.
 Summary(ja):	GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
-Group:		Development/Libraries
+Group:		programming
 Requires:	%{name} = %{version}-%{release}
+Requires:	glib2-devel%{?_isa}
+Requires:	libxml2-devel%{?_isa}
 
 %description devel
 GStreamer is a streaming-media framework, based on graphs of filters which
@@ -52,11 +58,12 @@ plugins.
 This package contains the libraries and includes files necessary to develop
 applications and plugins for GStreamer.
 
+
 # compat32
 %package -n compat32-%{name}
 Summary:	GStreamer streaming media framework runtime.
 Summary(ja):	GStreamer ストリーミングメディアフレームワークランタイム
-Group:		System Environment/Libraries
+Group:		system,multimedia,legacy
 
 %description -n compat32-%{name}
 GStreamer is a streaming-media framework, based on graphs of filters which
@@ -66,10 +73,11 @@ else media-related.  Its plugin-based architecture means that new data
 types or processing capabilities can be added simply by installing new 
 plugins.
 
+
 %package -n compat32-%{name}-devel
 Summary:	Libraries/header files for GStreamer streaming media framework.
 Summary(ja):	GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
-Group:		Development/Libraries
+Group:		programming
 Requires:	compat32-%{name} = %{version}-%{release}
 Requires:	%{name}-devel = %{version}-%{release}
 
@@ -84,43 +92,37 @@ plugins.
 This package contains the libraries and includes files necessary to develop
 applications and plugins for GStreamer.
 
+
+%debug_package
+
+
 %prep
 %setup -q -n gstreamer-%{version}
 
+
 %build
-%configure \
-	--with-package-name='Vine Linux gstreamer package' \
-	--with-cachedir=%{_var}/cache/gstreamer-%{major} \
-	--enable-introspection=yes \
-	--disable-docbook --enable-gtk-doc \
-	--disable-static --disable-examples \
-	--disable-tests --disable-debug
+%meson \
+  -Dpackage-name='Vine Linux gstreamer package' \
+  -Dpackage-origin='https://vinelinux.org/' \
+  -Dgtk_doc=disabled \
+  -Dtests=disabled \
+  -Dexamples=disabled \
+  -Dcheck=disabled \
+  -Ddbghelp=disabled \
+  -Ddoc=disabled
+%meson_build
 
-make %{?_smp_mflags}
 
 %install
 [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
 
-make install DESTDIR=$RPM_BUILD_ROOT
-
-mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
-
-rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
-rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
-#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
-
+%meson_install
 %find_lang %{po_package}
 
+
 %clean
 [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
-
-%post -n compat32-%{name} -p /sbin/ldconfig
-
-%postun -n compat32-%{name} -p /sbin/ldconfig
 
 %files -f %{po_package}.lang
 %defattr(-, root, root)
@@ -132,14 +134,13 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
 %{_libdir}/*.so.*
 %{_libdir}/girepository-1.0/*.typelib
 %dir %{_libexecdir}/gstreamer-%{major}
-%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
-%{_libexecdir}/gstreamer-%{major}/gst-ptp-helper
-%{_libexecdir}/gstreamer-%{major}/gst-completion-helper
+%{_libexecdir}/gstreamer-%{major}/*
+%dir %{_datadir}/bash-completion
+%dir %{_datadir}/bash-completion/completions
 %{_datadir}/bash-completion/completions/gst-inspect-1.0
 %{_datadir}/bash-completion/completions/gst-launch-1.0
 %{_datadir}/bash-completion/helpers/gst
-%{_mandir}/man1/*
-%dir %{_var}/cache/gstreamer-%{major}
+%doc %{_mandir}/man1/*
 
 %files devel
 %defattr(-, root, root)
@@ -148,9 +149,6 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/gstreamer*.pc
 %{_datadir}/aclocal/*.m4
-%{_datadir}/gtk-doc/html/gstreamer-%{major}
-%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
-%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
 %{_datadir}/gir-1.0/*.gir
 %dir %{_datadir}/gdb
 %dir %{_datadir}/gdb/auto-load
@@ -176,6 +174,10 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
 %endif
 
 %changelog
+* Thu Apr 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.18.2-1
+- new upstream release.
+- dropped ldconfig scriptlets.
+
 * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.2-1
 - new upstream release.
 

+ 27 - 15
lib/liba/libavc1394/libavc1394-vl.spec

@@ -2,21 +2,19 @@ Name: libavc1394
 Summary: Audio/Video Control library for IEEE-1394 devices
 Summary(ja): IEEE1394 デバイス用 AV コントロールライブラリ
 Version: 0.5.4
-Release: 3%{?_dist_release}
+Release: 4%{?_dist_release}
+Group: system
+Vendor: Project Vine
+Distribution: Vine Linux
 
-Group: System Environment/Libraries
 License: LGPLv2
 URL: http://libavc1394.sourceforge.net/
-
 Source: http://downloads.sourceforge.net/libavc1394/libavc1394-%{version}.tar.gz
+Patch1: libavc1394-%{version}-librom.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: libraw1394-devel
 
-Vendor: Project Vine
-Distribution: Vine Linux
-
-
 %description
 The libavc1394 library allows utilities to control IEEE-1394 devices.
 
@@ -24,10 +22,11 @@ The libavc1394 library allows utilities to control IEEE-1394 devices.
 libavc1394 ライブラリは IEEE-1394 デバイスの制御をするためのユーティリティ
 です。
 
+
 %package devel
 Summary: Development libs for libavc1394
 Summary(ja): libavc1394 用開発ライブラリ
-Group: Development/Libraries
+Group: programming
 Requires: %{name} = %{version}-%{release}
 Requires: libraw1394-devel
 
@@ -35,27 +34,35 @@ Requires: libraw1394-devel
 Development libraries required to build applications using libavc1394.
 
 
+%debug_package
+
+
 %prep
 %setup -q
+%patch1 -p1 -b .librom
+chmod -x test/dvcont.c
+
 
 %build
-%configure --disable-static
-make
+%configure
+%make_build
+
 
 %install
 rm -rf %{buildroot}
-make install DESTDIR=$RPM_BUILD_ROOT
+%make_install
+
+rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
+
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
 
 %files
 %defattr(-,root,root)
-%doc COPYING INSTALL README
+%license COPYING
+%doc INSTALL README
 %{_bindir}/*
 %{_mandir}/man1/*
 %{_libdir}/lib*.so.*
@@ -69,6 +76,11 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.5.4-4
+- rebuilt with current environment.
+- imported Patch1 from rawhide.
+- dropped ldconfig scriptlets.
+
 * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.5.4-3
 - rebuild with VineSeed environment
 

+ 34 - 20
lib/libd/libdv/libdv-vl.spec

@@ -2,20 +2,22 @@ Name: libdv
 Summary: A software codec for DV video.
 Summary(ja): DVビデオのためのソフトウエアコーデック
 Version: 1.0.0
-Release: 4%{?_dist_release}
+Release: 5%{?_dist_release}
+Group: system
+Vendor: Project Vine
+Distribution: Vine Linux
 
-Group: System Environment/Libraries
 License: LGPLv2
 URL: http://libdv.sourceforge.net/
 
 Source: http://prdownloads.sourceforge.net/libdv/%{name}-%{version}.tar.gz
-Patch0: libdv-0.104-amd64reloc.patch
-Patch1: libdv-1.0.0-gtk2.patch
-Patch2: libdv-1.0.0-playdv.patch
+Patch1: libdv-0.104-no-exec-stack.patch
+Patch2: libdv-1.0.0-pic.patch
+Patch3: libdv-1.0.0-gtk2.patch
+Patch4: libdv-1.0.0-dso-linking.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: pkgconfig >= 0.9.0
-BuildRequires: gtk2-devel
 BuildRequires: SDL-devel
 BuildRequires: libXv-devel
 
@@ -29,7 +31,7 @@ according to the official standards for DV video: IEC 61834 and SMPTE 314M.
 %package devel
 Summary: Development package for libdv library.
 Summary(ja): libdv ライブラリの開発用パッケージ
-Group: Development/Libraries
+Group: programming
 Requires: %{name} = %{version}-%{release}
 
 %description devel
@@ -44,8 +46,8 @@ incorporate libdv into applications.
 
 %package tools
 Summary: Basic tools to manipulate Digital Video streams
-Summary: デジタルビデオストリームを扱うための基本ツール
-Group: Applications/Multimedia
+Summary(ja): デジタルビデオストリームを扱うための基本ツール
+Group: multimedia
 Requires: %{name} = %{version}-%{release}
 
 %description tools
@@ -55,41 +57,47 @@ a software codec for DV video, the encoding format used by most
 digital camcorders, typically those that support the IEEE 1394
 (a.k.a. FireWire or i.Link) interface.
 
+
+%debug_package
+
+
 %prep
 %setup -q
-%patch1 -p1 -b .gtk2
-%patch2 -p1 -b .playdv
+%patch1 -p0 -b .no-exec-stack
+%patch2 -p1 -b .pic
+%patch3 -p1 -b .gtk2
+%patch4 -p1 -b .dso-linking
 
-%build
 libtoolize
-autoreconf -f -i
+autoreconf -fiv
+
 
-%configure --disable-static
+%build
+%configure --disable-static --with-pic --disable-gtk
 make %{?_smp_mflags}
 
+
 %install
 rm -rf %{buildroot}
 make install DESTDIR=$RPM_BUILD_ROOT
 
-#rm -f %{buildroot}%{_libdir}/*.{a,la}
-
-%post -p /sbin/ldconfig
+rm -f %{buildroot}%{_libdir}/*.{a,la}
 
-%postun -p /sbin/ldconfig
 
 %clean
 rm -rf %{buildroot}
 
+
 %files
 %defattr(-, root, root)
-%doc AUTHORS ChangeLog COPY* NEWS README* TODO
+%license COPY*
+%doc AUTHORS ChangeLog NEWS README* TODO
 %{_libdir}/*.so.*
 
 %files devel
 %defattr(-, root, root)
 %{_includedir}/%{name}
 %{_libdir}/*.so
-%exclude %{_libdir}/*.la
 %{_libdir}/pkgconfig/*
 
 %files tools
@@ -97,7 +105,13 @@ rm -rf %{buildroot}
 %{_bindir}/*
 %{_mandir}/man1/*
 
+
 %changelog
+* Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.0-5
+- rebuilt with current environment.
+- replaced all patches.
+- disabled gtk2.
+
 * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-4
 - rebuild with VineSeed environment
 - add BuildRequires: SDL-devel, libXv-devel

+ 32 - 17
lib/libi/libiec61883/libiec61883-vl.spec

@@ -2,14 +2,16 @@ Name: libiec61883
 Summary: Streaming library for IEEE1394
 SUmmary(ja): IEEE1394 用ストリーミングライブラリ
 Version: 1.2.0
-Release: 3%{?_dist_release}
+Release: 4%{?_dist_release}
+Group: system
+Vendor: Project Vine
+Distribution: Vine Linux
 
-Group: System Environment/Libraries
 License: LGPLv2
 URL: https://ieee1394.wiki.kernel.org/
-
 Source: http://www.kernel.org/pub/linux/libs/ieee1394/%{name}-%{version}.tar.gz
-Patch0: libiec61883-1.1.0-installtests.patch
+Patch0: libiec61883-1.2.0-installtests.patch
+Patch1: libiec61883-channel-allocation-without-local-node-rw.patch
 
 ExcludeArch: s390 s390x
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
@@ -23,54 +25,60 @@ functionality, this library acts as a filter that accepts DV-frames,
 MPEG-2 frames or audio samples from the application and breaks these
 down to isochronous packets, which are transmitted using libraw1394.
 
+
 %package devel
 Summary:  Development files for libiec61883
-Group:    Development/Libraries
+Group:    programming
 Requires: %{name} = %{version}-%{release}
 Requires: libraw1394-devel >= 1.2.1
 
 %description devel
 Development files needed to build applications against libiec61883
 
+
 %package utils
 Summary:  Utilities for use with libiec61883
-Group:    Applications/System
+Group:    multimedia
 Requires: %{name} = %{version}-%{release}
 
 %description utils
 Utilities that make use of iec61883
 
+
+%debug_package
+
+
 %prep
-%setup -q
-%patch0 -p1 -b .installtests
+%autosetup -p1
+
 
 %build
-autoreconf -if
 %configure --disable-static
-make
+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+%make_build
+
 
 %install
 rm -rf %{buildroot}
-make DESTDIR=%{buildroot} install
+%make_install
+
+find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
 
-#rm $RPM_BUILD_ROOT%{_libdir}/libiec61883.la
 
 %clean
 rm -rf %{buildroot}
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
 
 %files
 %defattr(-,root,root,-)
-%doc AUTHORS COPYING NEWS README
+%license COPYING
+%doc AUTHORS NEWS README
 %{_libdir}/libiec61883.so.*
 
 %files devel
 %defattr(-,root,root,-)
 %{_libdir}/libiec61883.so
-%exclude %{_libdir}/libiec61883.la
 %{_includedir}/libiec61883/*.h
 %{_libdir}/pkgconfig/libiec61883.pc
 
@@ -79,7 +87,14 @@ rm -rf %{buildroot}
 %{_bindir}/*
 %{_mandir}/man1/*.1*
 
+
 %changelog
+* Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.0-4
+- rebuilt with current environment.
+- dropped ldconfig scriptlets.
+- updated Patch0.
+- imported Patch0 from rawhide.
+
 * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.0-3
 - rebuild with VineSeed environment
 

+ 23 - 10
lib/libr/libraw1394/libraw1394-vl.spec

@@ -1,12 +1,15 @@
 Name: libraw1394
 Summary: Library providing low-level IEEE-1394 access
 Summary(ja): 低レベル IEEE-1394 アクセスライブラリ
-Version: 2.1.0
-Release: 2%{?_dist_release}
+Version: 2.1.2
+Release: 1%{?_dist_release}
+Group: system
+Vendor: Project Vine
+Distribution: Vine Linux
 
-Group: System Environment/Libraries
 License: LGPL
-Source: http://www.kernel.org/pub/linux/libs/ieee1394/%{name}-%{version}.tar.xz
+URL: http://www.dennedy.org/libraw1394/
+Source: https://www.kernel.org/pub/linux/libs/ieee1394/%{name}-%{version}.tar.xz
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 
@@ -15,35 +18,41 @@ The libraw1394 library provides direct access to the
 IEEE-1394 bus through the Linux 1394 subsystem's raw1394 user space
 interface.
 
+
 %package devel
 Summary: Development libs for libraw1394
-Group: Development/Libraries
+Group: programming
 Requires: %{name} = %{version}-%{release}
 
 %description devel
 Development libraries needed to build applications against libraw1394.
 
+
+%debug_package
+
+
 %prep
 %setup -q
 
+
 %build
 %configure --disable-static
-make
+make %{?_smp_mflags}
+
 
 %install
 rm -rf $RPM_BUILD_ROOT
 make install DESTDIR=$RPM_BUILD_ROOT
+rm -f %{buildroot}%{_libdir}/libraw1394.la
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
 
 %files
 %defattr(-,root,root)
-%doc AUTHORS ChangeLog COPYING.LIB NEWS README
+%license COPYING.LIB
+%doc AUTHORS ChangeLog NEWS README
 %{_bindir}/*
 %{_libdir}/libraw1394.so.*
 %{_mandir}/man1/*
@@ -58,6 +67,10 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.2-1
+- new upstream release.
+- dropped ldconfig scriptlets.
+
 * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-2
 - rebuild with VineSeed environment
 

+ 21 - 11
lib/libv/libvpx/libvpx-vl.spec

@@ -1,14 +1,14 @@
 %global somajor 6
-%global sominor 0
+%global sominor 3
 %global sotiny  0
 %global soversion %{somajor}.%{sominor}.%{sotiny}
 
 Name:		libvpx
-Version:	1.8.2
+Version:	1.10.0
 Release:	1%{?_dist_release}
 Summary:	The VP8/VP9 Codec SDK
 Summary(ja):	VP8/VP9 コーデックソフトウェア開発キット
-Group:		System Environment/Libraries
+Group:		system
 Vendor:		Project Vine
 Distribution:	Vine Linux
 Packager:	daisuke
@@ -18,6 +18,8 @@ URL:		https://www.webmproject.org/code/
 Source0:	https://github.com/webmproject/libvpx/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
 Source1:	vpx_config.h
 Source2:	libvpx.ver
+# Do not disable FORTIFY_SOURCE=2
+Patch0:		libvpx-1.7.0-leave-fortify-source-on.patch
 
 BuildRoot:	%{_tmppath}/%{name}-%{version}-%{release}-root
 %ifarch %{ix86} x86_64
@@ -35,10 +37,11 @@ WebM VP8/VP9 コーデック SDK は、VP8/VP9 ビデオコーデックをアプ
 かつオープンソースのコーデックで、世界中の多くのコンピュータやデバイスで利用されて
 います。
 
+
 %package devel
 Summary:	Development files for %{name}
 Summary(ja):	%{name} の開発ファイル
-Group:		Development/Libraries
+Group:		programming
 Requires:	%{name} = %{version}-%{release}
 
 %description devel
@@ -48,10 +51,11 @@ The %{name}-devel package contains development files for
 %description devel -l ja
 %{name}-devel パッケージは %{name} の開発用ファイルを含んでいます。
 
+
 %package utils
 Summary:	example programs for %{name}
 Summary(ja):	%{name} のサンプルプログラム
-Group:		Applications/Multimedia
+Group:		multimedia
 Requires:	%{name} = %{version}-%{release}
 
 %description utils
@@ -63,8 +67,13 @@ use %{name}.
 アプリケーションを含んでいます。
 
 
+%debug_package
+
+
 %prep
 %setup -q
+%patch0 -p1 -b .leave-fs-on
+
 
 %build
 
@@ -90,7 +99,6 @@ use %{name}.
  --enable-vp9-decoder --enable-vp9-encoder \
  --enable-experimental \
  --enable-vp9-highbitdepth \
- --enable-experimental \
 %if ! %{generic_target}
  --enable-shared \
 %endif
@@ -114,6 +122,7 @@ tmp/*.o
 rm -rf tmp
 %endif
 
+
 %install
 %{__rm} -rf $RPM_BUILD_ROOT
 %{__make} DIST_DIR=$RPM_BUILD_ROOT%{_prefix} dist
@@ -180,15 +189,11 @@ mv %{buildroot}%{_prefix}/src/vpx_scale %{buildroot}%{_includedir}/
 
 rm -rf %{buildroot}%{_prefix}/src
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
-
-
 %files
 %defattr(-,root,root,-)
 %license LICENSE
@@ -212,6 +217,11 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
+- new upstream release.
+- dropped ldconfig scriptlets.
+- imported Patch0 from rawhide.
+
 * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
 - new upstream release.
 

+ 28 - 21
t/taglib/taglib-vl.spec

@@ -1,16 +1,16 @@
 Name: taglib
 Summary: TagLib Audio Meta-Data Library
 Summary(ja): オーディオメタデータライブラリ
-Version: 1.9.1
-Release: 2%{?_dist_release}
+Version: 1.12
+Release: 1%{?_dist_release}
+Group: system
+Vendor: Project Vine
+Distribution: Vine Linux
 
-Group: System Environment/Libraries
 License: LGPLv2 and MPL
-URL: http://taglib.github.com/
-
-Source: http://taglib.github.com/releases/taglib-%{version}.tar.gz
-Patch0:	http://www.cc.rim.or.jp/~yaz/taglib-1.4_wchar.diff
-Patch2: taglib-1.5rc1-multilib.patch
+URL: https://taglib.github.com/
+Source: https://github.com/taglib/taglib/releases/download/v%{version}/taglib-%{version}.tar.gz
+Patch2: taglib-1.12-multilib.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: cmake >= 2.6.0
@@ -23,44 +23,45 @@ several popular audio formats. Currently it supports both ID3v1
 and ID3v2 for MP3 files, Ogg Vorbis comments and ID3 tags 
 and Vorbis comments in FLAC files. 
 
+
 %package devel
 Summary: TagLib Development environment
 Summary(ja): TagLib 開発用ファイル
-Group: Development/Libraries
+Group: programming
 Requires: %{name} = %{version}-%{release}
 
 %description devel
 Libraries and header files required for TagLib development.
 
+
+%debug_package
+
+
 %prep
 %setup -q
-#patch0 -p1 -b .wchar
 %patch2 -p1 -b .multilib
 
+
 %build
-mkdir -p %{_target_platform}
-pushd %{_target_platform}
-%cmake -DWITH_ASF=1 -DWITH_MP4=1 ..
-popd
+%cmake -DWITH_ASF=1 -DWITH_MP4=1
+%cmake_build
 
-make %{?_smp_mflags} -C %{_target_platform}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
+%cmake_install
 
 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
 
 %files
 %defattr(-,root,root)
-%doc AUTHORS COPYING.* NEWS
+%license COPYING.*
+%doc AUTHORS NEWS
 %{_libdir}/lib*.so.*
 
 %files devel
@@ -71,7 +72,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/lib*.so
 %{_libdir}/pkgconfig/*.pc
 
+
 %changelog
+* Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12-1
+- new upstream release.
+- updated Patch2.
+- dropped ldconfig scriptlets.
+
 * Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.1-2
 - rebuild with gcc-5.4.0
 
@@ -97,7 +104,7 @@ rm -rf $RPM_BUILD_ROOT
 - new upstream release
 - used cmake for building
 
-* Sun Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5-1
+* Mon Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5-1
 - new upstream release
 - removed lib*.la files
 

+ 20 - 34
v/v4l-utils/v4l-utils-vl.spec

@@ -1,8 +1,11 @@
 Name:           v4l-utils
-Version:        1.16.7
+Version:        1.20.0
 Release:        1%{?_dist_release}
 Summary:        Utilities for video4linux and DVB devices
-Group:          Applications/System
+Group:          multimedia
+Vendor:         Project Vine
+Distribution:   Vine Linux
+
 # ir-keytable and v4l2-sysfs-path are GPLv2 only
 License:        GPLv2+ and GPLv2
 URL:            https://linuxtv.org/downloads/v4l-utils/
@@ -10,13 +13,8 @@ Source0:        https://linuxtv.org/downloads/v4l-utils/v4l-utils-%{version}.tar
 BuildRequires:  libudev-devel libjpeg-devel kernel-headers desktop-file-utils
 BuildRequires:  alsa-lib-devel doxygen gettext
 BuildRequires:  qt5-qtbase-devel qt5-qt3d-devel
-# For /lib/udev/rules.d ownership
-Requires:       eudev
 Requires:       libv4l = %{version}-%{release}
 
-Vendor: Project Vine
-Distribution: Vine Linux
-
 %description
 v4l-utils is a collection of various video4linux (V4L) and DVB utilities. The
 main v4l-utils package contains cx18-ctl, ir-keytable, ivtv-ctl, v4l2-ctl and
@@ -25,6 +23,7 @@ v4l2-sysfs-path.
 
 %package        devel-tools
 Summary:        Utilities for v4l2 / DVB driver development and debugging
+Group:          multimedia
 # decode_tm6000 is GPLv2 only
 License:        GPLv2+ and GPLv2
 Requires:       libv4l = %{version}-%{release}
@@ -36,6 +35,7 @@ v4l2-dbg.
 
 %package -n     qv4l2
 Summary:        QT v4l2 test control and streaming test application
+Group:          multimedia
 License:        GPLv2+
 Requires:       libv4l = %{version}-%{release}
 
@@ -45,10 +45,9 @@ QT v4l2 test control and streaming test application.
 
 %package -n     libv4l
 Summary:        Collection of video4linux support libraries 
-Group:          System Environment/Libraries
+Group:          system
 # Some of the decompression helpers are GPLv2, the rest is LGPLv2+
 License:        LGPLv2+ and GPLv2
-URL:            http://hansdegoede.livejournal.com/3636.html
 
 %description -n libv4l
 libv4l is a collection of libraries which adds a thin abstraction layer on
@@ -70,7 +69,7 @@ application transparent libv4lconvert conversion where necessary.
 
 %package -n     libdvbv5
 Summary:        Libraries to control, scan and zap on Digital TV channels
-Group:          Development/Libraries
+Group:          system
 License:        GPLv2
 
 %description -n libdvbv5
@@ -79,7 +78,7 @@ Libraries to control, scan and zap on Digital TV channels
 
 %package -n     libv4l-devel
 Summary:        Development files for libv4l
-Group:          Development/Libraries
+Group:          programming
 License:        LGPLv2+
 URL:            http://hansdegoede.livejournal.com/3636.html
 Requires:       libv4l = %{version}-%{release}
@@ -91,7 +90,7 @@ developing applications that use libv4l.
 
 %package -n     libdvbv5-devel
 Summary:        Development files for libdvbv5
-Group:          Development/Libraries
+Group:          programming
 License:        GPLv2
 Requires:       libdvbv5%{?_isa} = %{version}-%{release}
 
@@ -100,10 +99,14 @@ The libdvbv5-devel package contains libraries and header
 files for developing applications that use libdvbv5.
 
 
+%debug_package
+
+
 %prep
 %setup -q
 
 %build
+export CXXFLAGS="-std=c++14 $RPM_OPT_FLAGS"
 %configure --disable-static --enable-libdvbv5 --enable-doxygen-man
 # Don't use rpath!
 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
@@ -124,27 +127,6 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/qv4l2.desktop
 %find_lang libdvbv5
 
 
-%post -n libv4l -p /sbin/ldconfig
-
-%postun -n libv4l -p /sbin/ldconfig
-
-%post -n libdvbv5 -p /sbin/ldconfig
-
-%postun -n libdvbv5 -p /sbin/ldconfig
-
-%post -n qv4l2
-touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
-
-%postun -n qv4l2
-if [ $1 -eq 0 ] ; then
-    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
-    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
-fi
-
-%posttrans -n qv4l2
-gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
-
-
 %files -f %{name}.lang
 %doc README
 %dir %{_sysconfdir}/rc_keymaps
@@ -164,6 +146,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
 %{_bindir}/v4l2-ctl
 %{_bindir}/v4l2-sysfs-path
 %{_mandir}/man1/*.1*
+%{_mandir}/man5/*.5*
 %exclude %{_mandir}/man1/qv4l2.1*
 %exclude %{_mandir}/man1/v4l2-compliance.1*
 
@@ -184,7 +167,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
 %{_datadir}/icons/hicolor/*/apps/qvidcap.*
 %{_mandir}/man1/qv4l2.1*
 
-
 %files -n libv4l
 %doc ChangeLog README.libv4l TODO
 %license COPYING.libv4l COPYING
@@ -210,6 +192,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
 
 
 %changelog
+* Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.20.0-1
+- new upstream release.
+- dropped scriptlets.
+
 * Thu Sep 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.16.7-1
 - new upstream release.