Browse Source

updated 2 packages

gd-2.3.0-2

zabbix-5.0.6-1

git-svn-id: http://trac.vinelinux.org/repos/projects/specs@12517 ec354946-7b23-47d6-9f5a-488ba84defc7
tomop 1 year ago
parent
commit
82721e09bd
2 changed files with 34 additions and 16 deletions
  1. 30 15
      g/gd/gd-vl.spec
  2. 4 1
      z/zabbix/zabbix-vl.spec

+ 30 - 15
g/gd/gd-vl.spec

@@ -5,8 +5,8 @@ Summary: A graphics library for drawing .png files.
 Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
 Name: gd
 Version: 2.3.0
-Release: 1%{_dist_release}
-Group: System Environment/Libraries
+Release: 2%{_dist_release}
+Group: system
 Vendor: Project Vine
 Distribution: Vine Linux
 Packager: daisuke
@@ -14,7 +14,12 @@ Packager: daisuke
 License: BSD-style
 URL: http://www.libgd.org/
 Source0: https://github.com/libgd/libgd/releases/download/gd-%{version}/libgd-%{version}.tar.xz
+# https://github.com/libgd/libgd/issues/610
+Source1: https://raw.githubusercontent.com/libgd/libgd/master/config/getlib.sh
 Patch0: gd-2.1.0-multilib.patch
+# https://github.com/libgd/libgd/issues/615
+Patch1: gdImageStringFT.patch
+Patch2: textLayout.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: freetype2-devel
@@ -57,10 +62,11 @@ PNGファイルを描写する必要のあるアプリケーションを開発
 Gdをインストールしてください。gdをインストールした場合、gd-devel
 パッケージも必要になります。
 
+
 %package progs
 Summary: Utility programs that use libgd.
 Summary(ja): libgd を用いたユーティリティプログラム
-Group: Applications/Graphics
+Group: graphics
 Requires: gd = %{version}
 Requires: perl
 
@@ -73,10 +79,11 @@ If you install these, you must install gd.
 プログラムです。これをインストールするには, gdをインストールする必要
 があります。
 
+
 %package devel
 Summary: The development libraries and header files for gd.
 Summary(ja): Gd用の開発ライブラリとヘッダファイル
-Group: Development/Libraries
+Group: programming
 Requires: gd = %{version}
 Requires: freetype2-devel
 Requires: fontconfig-devel
@@ -107,7 +114,7 @@ gdをインストールした場合、gd-develパッケージも必要になり
 ## to build compat32 for x86_64 architecture support
 %package -n compat32-%{name}
 Summary: A graphics library for drawing .png files.
-Group: System Environment/Libraries
+Group: system
 %description -n compat32-%{name}
 Gd is a graphics library for drawing .png files.  Gd allows your code to
 quickly draw images (lines, arcs, text, multiple colors, cutting and
@@ -120,9 +127,10 @@ Install gd if you are developing applications which need to draw .png
 files.  If you install gd, you'll also need to install the gd-devel
 package.
 
+
 %package -n compat32-%{name}-devel
 Summary: The development libraries and header files for gd.
-Group: Development/Libraries
+Group: programming
 Requires: compat32-freetype2-devel
 Requires: compat32-fontconfig-devel
 Requires: compat32-libjpeg-turbo-devel
@@ -142,19 +150,18 @@ graphics library.
 If you're installing the gd graphics library, you must install gd-devel.
 
 
+%debug_package
+
+
 %prep
 %setup -q -n libgd-%{version}
 #patch0 -p1 -b .mlib
+%patch1 -p1 -b .text1
+%patch2 -p1 -b .text2
 
-# disable until till this bug is fixed.
-#  - https://github.com/libgd/libgd/issues/610
-#: regenerate autotool stuff
-#if [ -f configure ]; then
-#   libtoolize --copy --force
-#   autoreconf -vif
-#else
-#   ./bootstrap.sh
-#fi
+cp %{SOURCE1} ./config/
+chmod 755 ./config/getlib.sh
+autoreconf -vif
 
 
 %build
@@ -180,6 +187,7 @@ CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
 	--disable-rpath
 make %{?_smp_mflags}
 
+
 %install
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
 make DESTDIR=$RPM_BUILD_ROOT install
@@ -191,9 +199,11 @@ rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
 make %{?_smp_mflags} check
 %endif
 
+
 %clean
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
 
+
 %post -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
@@ -202,6 +212,7 @@ make %{?_smp_mflags} check
 %postun -n compat32-%{name} -p /sbin/ldconfig
 %endif
 
+
 %files
 %defattr(-,root,root)
 %license COPYING
@@ -227,7 +238,11 @@ make %{?_smp_mflags} check
 %{_libdir}/*.so
 %endif
 
+
 %changelog
+* Sun Dec 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-2
+- add Patch1 and 2 to fix drawing text.
+
 * Fri Apr 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-1
 - new upstream release.
 

+ 4 - 1
z/zabbix/zabbix-vl.spec

@@ -18,7 +18,7 @@
 
 Summary: The Enterprise-class Monitoring Solution for Everyone
 Name: zabbix
-Version: 5.0.3
+Version: 5.0.6
 Release: 1%{?_dist_release}%{?with_systemd:.systemd}
 Group: system
 Vendor: Project Vine
@@ -639,6 +639,9 @@ fi
 
 
 %changelog
+* Sun Dec 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.6-1
+- new upstream release.
+
 * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
 - new upstream release.