Browse Source

2015-01-12 Ryoichi INAGAKI <ryo1@toki.waseda.jp>

	* WindowMaker-Icons, remmina: rebuilt
	* gutenprint: changed Group
	* libmicrohttpd, pbzip2: updated
	


git-svn-id: http://trac.vinelinux.org/repos/projects/specs@9257 ec354946-7b23-47d6-9f5a-488ba84defc7
inagaki 7 years ago
parent
commit
375060a75d

+ 10 - 6
W/WindowMaker-Icons/WindowMaker-Icons-vl.spec

@@ -1,16 +1,17 @@
+%define extrafile WindowMaker-extra-0.1
+%define vdata WindowMaker-VineDatas
+
 Summary: Picutrers for WindowMaker
-Summary(ja): WindowMakerで用いるアイコンや背景等の画像集です
+Summary(ja): WindowMaker で用いるアイコンや背景等の画像集
 Name: WindowMaker-Icons
 Version: 2.0
-Release: 3%{?_dist_release}
+Release: 4%{?_dist_release}
 Group: User Interface/Desktops
 License: distributable for non-commercial use
-%define extrafile WindowMaker-extra-0.1
-%define vdata WindowMaker-VineDatas
 Source0: ftp://windowmaker.org/pub/%{extrafile}.tar.gz
 Source1: %{vdata}.tar.bz2
 Buildarch: noarch
-Buildroot: %{_tmppath}/%{name}-root
+Buildroot: %{_tmppath}/%{name}-%{version}-root
 Vendor: Project Vine
 Distribution: Vine Linux
 
@@ -18,7 +19,7 @@ Distribution: Vine Linux
 Many icons, tiles, background for WindowMaker.
 
 %description -l ja
-WindowMakerでアイコンや背景, タイル等として用いる画像データ集です. 
+WindowMaker でアイコンや背景, タイル等として用いる画像データ集です. 
 
 %prep
 %setup -q -a 1 -c -n WindowMaker-Datas
@@ -74,6 +75,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/pixmaps/*
 
 %changelog
+* Wed Jan  7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0-4
+- rebuilt on current VineSeed
+
 * Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 2.0-3
 - rebuilt with rpm-4.8.1-3
 

+ 40 - 17
g/gutenprint/gutenprint-vl.spec

@@ -3,10 +3,13 @@
 
 Name:           gutenprint
 Summary:        Printer Drivers Package
+Summary(ja):    プリンタドライバ集
 Version:        5.2.10
-Release:        1%{?_dist_release}
-Group:          System Environment/Base
+Release:        2%{?_dist_release}
+Group:          System Environment/Libraries
+License:        GPLv2+
 URL:            http://gimp-print.sourceforge.net/
+
 Source0:	http://dl.sf.net/gimp-print/gutenprint-5.2/%{version}/gutenprint-%{version}.tar.bz2
 # Post-install script to update foomatic PPDs.
 Source1:        gutenprint-foomaticppdupdate
@@ -19,17 +22,28 @@ Patch3:         gutenprint-postscriptdriver.patch
 Patch4:         gutenprint-yyin.patch
 Patch5:         gutenprint-manpage.patch
 Patch6:         gutenprint-test-suite.patch
-License:        GPLv2+
-BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires:  cups-libs >= 1.4.0, cups >= 1.4.0
-BuildRequires:  gettext-devel,cups-devel,pkgconfig,gimp-devel
-BuildRequires:  libtiff-devel,libjpeg-devel,libpng-devel
-BuildRequires:  foomatic,gtk2-devel
+
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires:  cups >= 1.4.0
+BuildRequires:  cups-libs >= 1.4.0
+BuildRequires:  cups-devel
+BuildRequires:  foomatic
+BuildRequires:  gettext-devel
+BuildRequires:  gimp-devel
+BuildRequires:  gtk2-devel
+BuildRequires:  libjpeg-devel
+BuildRequires:  libpng-devel
+BuildRequires:  libtiff-devel
+BuildRequires:  libusb1-devel
+BuildRequires:  pkgconfig
 %if %{build_with_ijs_support}
 BuildRequires: ghostscript-devel
 %endif
 BuildRequires:  gimp
 BuildRequires:  chrpath
+# Make sure we get postscriptdriver tags.
+BuildRequires:  python-cups
+
 Obsoletes: gimp-print-utils <= 4.2.7-25
 Provides: gimp-print-utils = 4.2.7-25
 
@@ -37,9 +51,6 @@ Vendor: Project Vine
 Distribution: Vine Linux
 Packager: tomop
 
-# Make sure we get postscriptdriver tags.
-BuildRequires: cups, python-cups
-
 ## NOTE ##
 # The README file in this package contains suggestions from upstream
 # on how to package this software. I'd be inclined to follow those
@@ -52,6 +63,7 @@ Gutenprint was formerly called Gimp-Print.
 
 %package doc
 Summary:        Documentation for gutenprint
+Summary(ja):    Gutenprint のドキュメント
 Group:          Documentation
 
 %description doc
@@ -59,11 +71,12 @@ Documentation for gutenprint.
 
 %package devel
 Summary:        Library development files for gutenprint
+Summary(ja):    Gutenprint の開発用ライブラリ
 Group:          Development/Libraries
 Requires:       %{name} = %{version}-%{release}
 Requires:       gtk2-devel
-Obsoletes: gimp-print-devel <= 4.2.7-25
-Provides: gimp-print-devel = 4.2.7-25
+Obsoletes:      gimp-print-devel <= 4.2.7-25
+Provides:       gimp-print-devel = 4.2.7-25
 
 %description devel
 This package contains headers and libraries required to build applications that
@@ -71,17 +84,19 @@ uses gutenprint package.
 
 %package plugin
 Summary:        GIMP plug-in for gutenprint
-Group:          System Environment/Base
+Summary(ja):    Gutenprint GIMP プラグイン
+Group:          Applications/Graphics
 Requires:       %{name} = %{version}-%{release}
 Requires:       gimp
-Obsoletes: gimp-print-plugin <= 4.2.7-25
-Provides:  gimp-print-plugin = 4.2.7-25
+Obsoletes:      gimp-print-plugin <= 4.2.7-25
+Provides:       gimp-print-plugin = 4.2.7-25
 
 %description plugin
 This package contains the gutenprint GIMP plug-in.
 
 %package foomatic
 Summary:        Foomatic printer database information for gutenprint
+Summary(ja):    Gutenprint 用 Foomatic プリンタデータベース
 Group:          System Environment/Libraries
 Requires:       %{name} = %{version}-%{release}
 Requires(post): foomatic
@@ -95,6 +110,7 @@ and driver descriptions.
 
 %package extras
 Summary:        Sample test pattern generator for gutenprint-devel
+Summary(ja):    Gutenprint-devel 用のサンプルテストパターン生成器
 Group:          Applications/Publishing
 Requires:       %{name} = %{version}-%{release}
 
@@ -104,7 +120,8 @@ that is used by gutenprint-devel package.
 
 %package cups
 Summary:        CUPS drivers for Canon, Epson, HP and compatible printers
-Group:          Applications/Publishing
+Summary(ja):    Canon, EPSON, HP 並びにそれらの互換プリンタ用の CUPS ドライバ集
+Group:          System Environment/Libraries
 Requires:       cups >= 1.2.1-1.7
 Requires:       %{name} = %{version}-%{release}
 Obsoletes: gimp-print-cups < 4.2.7-26
@@ -305,6 +322,12 @@ fi
 /bin/rm -f /var/cache/foomatic/*
 
 %changelog
+* Mon Jan 12 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.2.10-2
+- added BR: libusb1-devel
+- added Japanese summary
+- moved main package to System Environment/Libraries Group
+- moved plugin subpackage to Applications/Graphics Group
+
 * Sun Jun  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.2.10-1
 - new upstream release.
 

+ 34 - 28
lib/libm/libmicrohttpd/libmicrohttpd-vl.spec

@@ -1,18 +1,20 @@
 Summary: Lightweight library for embedding a webserver in applications
 Name: libmicrohttpd
-Version: 0.9.2
+Version: 0.9.39
 Release: 1%{?_dist_release}
-Group: Development/Libraries
+Group: System Environment/Libraries
 License: LGPLv2+
-BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
 URL: http://www.gnu.org/software/libmicrohttpd/
+
 Source0: ftp://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
-#Patch0: %{name}-0.9.2-fix-https-tests.patch
 
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires:  autoconf, automake, libtool
 BuildRequires:  curl-devel
 BuildRequires:  gnutls-devel
 BuildRequires:  libgcrypt-devel
+BuildRequires:  openssl-devel
+BuildRequires:  zlib-devel
 BuildRequires:  graphviz
 BuildRequires:  doxygen
 
@@ -35,6 +37,7 @@ Key features that distinguish libmicrohttpd from other projects are:
 
 %package devel
 Summary:        Development files for libmicrohttpd
+Summary(ja):    libmicrohttpd の開発用ファイル
 Group:          Development/Libraries
 Requires:       %{name} = %{version}-%{release}
 
@@ -43,7 +46,9 @@ Development files for libmicrohttpd
 
 %package doc
 Summary:        Documentation for libmicrohttpd
+Summary(ja):    libmicrohttpd のドキュメント
 Group:          Documentation
+Buildarch:      noarch
 Requires:       %{name} = %{version}-%{release}
 
 %description doc
@@ -51,19 +56,12 @@ Doxygen documentation for libmicrohttpd and some example source code
 
 %prep
 %setup -q
-#patch0 -p1 -b .explicit-dso
-
-# The doxygen file contains references to /home/grothoff/svn/libmicrohttpd/... replace these with .
-sed s/\\/home\\/grothoff\\/svn\\/libmicrohttpd/./ doc/Doxyfile > tmp
-unlink doc/Doxyfile
-mv tmp doc/Doxyfile
 
 %build
-# Required because patches modify .am files
-# autoreconf --force
 %configure --disable-static --with-gnutls
 make %{?_smp_mflags}
-doxygen doc/Doxyfile
+make full -C doc/doxygen
+
 
 # Disabled for now due to problems reported at
 # https://gnunet.org/bugs/view.php?id=1619
@@ -75,41 +73,45 @@ rm -rf %{buildroot}
 make install DESTDIR=%{buildroot}
 
 rm -f %{buildroot}%{_libdir}/libmicrohttpd.la
+rm -f %{buildroot}%{_libdir}/libmicrospdy.la
 rm -f %{buildroot}%{_infodir}/dir
 
 # Install some examples in /usr/share/doc/libmicrohttpd-${version}/examples
-mkdir examples
+rm -rf examples
+mkdir -p examples
 install -m 644 src/examples/*.c examples
 
 # Install the doxygen documentation in /usr/share/doc/libmicrohttpd-${version}/html
-cp -R doc/doxygen/html html
+rm -rf html
+cp -R doc/doxygen/html .
 
 %clean
 rm -rf %{buildroot}
 
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %post doc
-/sbin/install-info %{_infodir}/microhttpd.info.gz %{_infodir}/dir || :
-/sbin/install-info %{_infodir}/microhttpd-tutorial.info.gz %{_infodir}/dir || :
+/sbin/install-info %{_infodir}/libmicrohttpd.info.gz %{_infodir}/dir || :
+/sbin/install-info %{_infodir}/libmicrohttpd-tutorial.info.gz %{_infodir}/dir || :
 
 %preun doc
 if [ $1 = 0 ] ; then
-/sbin/install-info --delete %{_infodir}/microhttpd.info.gz %{_infodir}/dir || :
-/sbin/install-info --delete %{_infodir}/microhttpd-tutorial.info.gz %{_infodir}/dir || :
+    /sbin/install-info --delete %{_infodir}/libmicrohttpd.info.gz %{_infodir}/dir || :
+    /sbin/install-info --delete %{_infodir}/libmicrohttpd-tutorial.info.gz %{_infodir}/dir || :
 fi
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-
 %files
 %defattr(-,root,root,-)
 %doc COPYING
-%{_libdir}/libmicrohttpd.so.*
+%{_bindir}/microspdy2http
+%{_libdir}/libmicro*.so.*
 
 %files devel
 %defattr(-,root,root,-)
-%{_includedir}/microhttpd.h
-%{_libdir}/libmicrohttpd.so
-%{_libdir}/pkgconfig/libmicrohttpd.pc
+%{_includedir}/micro*.h
+%{_libdir}/libmicro*.so
+%{_libdir}/pkgconfig/libmicro*.pc
 
 %files doc
 %doc AUTHORS README ChangeLog
@@ -117,10 +119,14 @@ fi
 %doc html
 %defattr(-,root,root,-)
 %{_mandir}/man3/libmicrohttpd.3.gz
-%{_infodir}/microhttpd.info.gz
-%{_infodir}/microhttpd-tutorial.info.gz
+%{_infodir}/libmicrohttpd.info.gz
+%{_infodir}/libmicrohttpd-tutorial.info.gz
 
 %changelog
+* Mon Jan 12 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.39-1
+- updated to 0.9.39
+- built with libgcrypt 1.6.0 and gnutls 3.2.20
+
 * Mon Jan 17 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9.2-1
 - initial build for Vine Linux based on fedora development
 

+ 5 - 3
p/pbzip2/pbzip2-vl.spec

@@ -1,13 +1,12 @@
 Summary:	Parallel implementation of bzip2
 Summary(ja):	bzip2 の並列処理実装
 Name:		pbzip2
-Version:	1.1.0
+Version:	1.1.12
 Release:	1%{?_dist_release}
 URL:		http://www.compression.ca/pbzip2/
 License:	BSD
 Group:		Applications/Archiving
-Source0:	http://www.compression.ca/pbzip2/%{name}-%{version}.tar.gz
-
+Source0:	https://launchpad.net/pbzip2/1.1/1.1.12/+download/%{name}-%{version}.tar.gz
 BuildRoot:	%{_tmppath}/%{name}-%{version}-root
 BuildRequires:	bzip2-devel
 
@@ -52,6 +51,9 @@ rm -rf %{buildroot}
 %{_mandir}/man1/*
 
 %changelog
+* Sun Jan 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.12-1
+- new upstream release
+
 * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
 - new upstream release
 

+ 40 - 36
r/remmina/remmina-vl.spec

@@ -2,7 +2,11 @@ Summary: 	Remote Desktop Connection utility
 Summary(ja): 	リモートデスクトップ接続ユーティリティ
 Name: 		remmina
 Version: 	1.0.0
-Release:        1%{?_dist_release}
+Release:        2%{?_dist_release}
+
+License: 	GPLv2+ and MIT
+Group: 		User Interface/Desktops
+URL: 		http://remmina.sourceforge.net/
 
 Source0:	https://github.com/downloads/FreeRDP/Remmina/Remmina-%{version}.tar.gz
 #VCS: git:https://github.com/FreeRDP/Remmina.git
@@ -34,14 +38,9 @@ Patch11:        remmina-1.0.0-fix-memory-leak.patch
 # https://bugzilla.redhat.com/show_bug.cgi?id=819976
 Patch20:        remmina-1.0.0-dsofix.patch
 
-
-License: 	GPLv2+ and MIT
-Group: 		Applications/Internet
-URL: 		http://remmina.sourceforge.net/
-
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires:  gtk3-devel
-BuildRequires:  vte3-devel
+BuildRequires:  vte290-devel
 BuildRequires:  libgcrypt-devel
 BuildRequires:  libssh-devel
 BuildRequires:  avahi-ui-devel
@@ -50,6 +49,9 @@ BuildRequires:  desktop-file-utils
 BuildRequires:  gnutls-devel
 BuildRequires:  libjpeg-devel
 BuildRequires:  libvncserver-devel
+BuildRequires:  libgnome-keyring-devel
+BuildRequires:  freerdp-devel >= 1.0.1
+BuildRequires:  telepathy-glib-devel
 
 BuildRequires:  cmake
 BuildRequires:  gettext
@@ -60,9 +62,10 @@ Provides: grdc = %{version}
 Obsoletes: remmina-gnome <= 0.7.3
 
 %description
-Grdc is a remote desktop connection client that can view and control a
-desktop session running on another system. It can connect to a VNC platform
-(using libvncserver0) as well windows terminal servers (with rdesktop).
+Remmina is a remote desktop client written in GTK+, aiming to be
+useful for system administrators and travelers, who need to work 
+with lots of remote computers in front of either large monitors or 
+tiny netbooks.
 
 
 %package devel
@@ -79,7 +82,7 @@ remmina.
 %package        plugins-common
 Summary:        Common files for Remmina Remote Desktop Client plugins
 Summary(ja):    Remmina プラグインの共通ファイル
-Group:          Applications/System
+Group: 		User Interface/Desktops
 Requires:       %{name} >= 0.9
 
 %description    plugins-common
@@ -94,10 +97,9 @@ remote desktop client.
 
 %package        plugins-gnome
 Summary:        GNOME keyring integration for Remmina Remote Desktop Client
-Summary(ja):	RemminaのGNOMEキーリング統合
-BuildRequires:  libgnome-keyring-devel
-Group:          Applications/System
-Requires:       %{name}-plugins-common%{?_isa} = %{version}-%{release}
+Summary(ja):	Remmina の GNOMEキーリング統合
+Group: 		User Interface/Desktops
+Requires:       %{name}-plugins-common = %{version}-%{release}
 Requires:       libgnome-keyring
 
 %description    plugins-gnome
@@ -112,10 +114,11 @@ Remmina remote desktop client.
 
 %package        plugins-nx
 Summary:        NX plugin for Remmina Remote Desktop Client
-Summary(ja):	RemminaのNXプラグイン
-Group:          Applications/System
-Requires:       %{name}-plugins-common%{?_isa} = %{version}-%{release}
-Requires:       nx
+Summary(ja):	Remmina の NX プラグイン
+Group: 		User Interface/Desktops
+Requires:       %{name}-plugins-common = %{version}-%{release}
+# temporally disabled
+#Requires:       nx
 
 %description    plugins-nx
 Remmina is a remote desktop client written in GTK+, aiming to be
@@ -129,10 +132,9 @@ client.
 
 %package        plugins-rdp
 Summary:        RDP plugin for Remmina Remote Desktop Client
-Summary(ja):	RemminaのRDPプラグイン
-Group:          Applications/System
-BuildRequires:  freerdp-devel >= 1.0.1
-Requires:       %{name}-plugins-common%{?_isa} = %{version}-%{release}
+Summary(ja):	Remmina の RDP プラグイン
+Group: 		User Interface/Desktops
+Requires:       %{name}-plugins-common = %{version}-%{release}
 Requires:       freerdp
 
 %description    plugins-rdp
@@ -147,10 +149,10 @@ Remmina remote desktop client.
 
 %package        plugins-telepathy
 Summary:        Telepathy plugin for Remmina Remote Desktop Client
-Summary(ja):	RemminaのTelepathyプラグイン
-Group:          Applications/System
-BuildRequires:  telepathy-glib-devel
-Requires:       %{name}-plugins-common%{?_isa} = %{version}-%{release}
+Summary(ja):	Remmina  Telepathy プラグイン
+Group: 		User Interface/Desktops
+Group: 		Applications/Internet
+Requires:       %{name}-plugins-common = %{version}-%{release}
 
 %description    plugins-telepathy
 Remmina is a remote desktop client written in GTK+, aiming to be
@@ -164,12 +166,9 @@ desktop  client.
 
 %package        plugins-vnc
 Summary:        VNC plugin for Remmina Remote Desktop Client
-Summary(ja):	RemminaのVNCプラグイン
-Group:          Applications/System
-BuildRequires:  gnutls-devel
-BuildRequires:  libjpeg-devel
-BuildRequires:  libvncserver-devel
-Requires:       %{name}-plugins-common%{?_isa} = %{version}-%{release}
+Summary(ja):	Remmina の VNC プラグイン
+Group: 		User Interface/Desktops
+Requires:       %{name}-plugins-common = %{version}-%{release}
 
 %description    plugins-vnc
 Remmina is a remote desktop client written in GTK+, aiming to be
@@ -183,9 +182,9 @@ client.
 
 %package        plugins-xdmcp
 Summary:        XDMCP plugin for Remmina Remote Desktop Client
-Summary(ja):	RemminaのXDMCPプラグイン
-Group:          Applications/System
-Requires:       %{name}-plugins-common%{?_isa} = %{version}-%{release}
+Summary(ja):	Remmina  XDMCP プラグイン
+Group: 		User Interface/Desktops
+Requires:       %{name}-plugins-common = %{version}-%{release}
 Requires:       xorg-x11-server-Xephyr
 
 %description    plugins-xdmcp
@@ -344,6 +343,11 @@ fi
 %{_datadir}/icons/hicolor/*/emblems/remmina-xdmcp.png
 
 %changelog
+* Mon Jan 12 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.0-2
+- rebuilt with libgcrypt 1.6.0 and gnutls 3.2.20
+- modified BR: vte290-devel instead of vte3-devel
+- moved to User Interface/Desktops Group
+
 * Fri Oct 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
 - Update to 1.0.0
 - add BuildRequires