Browse Source

updated 19 packages

g-wrap-1.9.15-2

gjs-1.54.3-2

glib2-2.64.2-2

gobject-introspection-1.64.1-1

guile-2.2.7-1

guile20-2.0.14-5

hardinfo-0.5.1-4

llvm-10.0.0-2

libffi-3.3-1

libffi321-3.2.1-1

p11-kit-0.23.20-2

pycairo-1.18.2-1

pygobject-2.28.6-7

pygobject3-3.34.0-1

python-cffi-1.14.0-1

python-2.7.17-1

python3-3.5.9-1

ruby-2.6.6-2

uim-1.8.8-3

git-svn-id: http://trac.vinelinux.org/repos/projects/specs@12376 ec354946-7b23-47d6-9f5a-488ba84defc7
tomop 2 years ago
parent
commit
1b21e6dd1a

+ 4 - 1
g/g-wrap/g-wrap-vl.spec

@@ -2,7 +2,7 @@ Summary: A tool for creating Scheme interfaces to C libraries.
 Summary(ja): C ライブラリへの Scheme 言語インタフェースを作成するツール
 Name: g-wrap
 Version: 1.9.15
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 Group: Development/Libraries
 License: GPL
 URL: https://www.nongnu.org/g-wrap/
@@ -141,6 +141,9 @@ fi
 
 
 %changelog
+* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.15-2
+- rebuilt with libffi-3.3.
+
 * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.15-1
 - new upstream release.
 - built with guile-2.2.6.

+ 6 - 6
g/gjs/gjs-vl.spec

@@ -1,23 +1,20 @@
-%define pkg_version 1.54.3
-%define pkg_release 1%{?_dist_release}
 %define mozjs mozjs60
 
 Summary:        Javascript binding for GNOME
 Summary(ja):    GNOME 向け JavaScript バインディング
 Name:           gjs
-Version:        %{pkg_version}
-Release:        %{pkg_release}
+Version:        1.54.3
+Release:        2%{?_dist_release}
 Group:          System Environment/Libraries
-
 Vendor:         Project Vine
 Distribution:   Vine Linux
+BuildRoot:      %{_tmppath}/%{name}-%{version}-root
 
 License:        MPL1.1/LGPLv2+/GPLv2+
 URL:            https://wiki.gnome.org/Projects/GnomeShell
 %global         shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
 Source0:        https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
 
-BuildRoot:      %{_tmppath}/%{name}-%{version}-root
 BuildRequires:  pkgconfig >= 0.14.0
 BuildRequires:  glib2-devel
 BuildRequires:  dbus-glib-devel
@@ -100,6 +97,9 @@ find %{buildroot} -name '*.la' -exec rm -f {} \;
 
 
 %changelog
+* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.54.3-2
+- rebuilt with libffi-3.3.
+
 * Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.54.3-1
 - new upstream release.
 - dropped Patch0: fixed in upstream.

+ 11 - 5
g/glib2/glib2-vl.spec

@@ -3,13 +3,12 @@
 
 Summary:        A library of handy utility functions.
 Name:           glib2
-Version:        2.62.2
-Release:        1%{?_dist_release}
+Version:        2.64.2
+Release:        2%{?_dist_release}
 Group:          System Environment/Libraries
-
 Vendor:         Project Vine
 Distribution:   Vine Linux
-Packager:       Daisuke SUZUKI <daisuke@linux.or.jp>
+Packager:       daisuke
 
 License:        LGPLv2+
 URL:            http://www.gtk.org
@@ -54,6 +53,7 @@ Requires: %{name} = %{version}
 Requires: pkgconfig >= 0.14
 Requires: libffi-devel
 Requires: zlib-devel
+Requires: python3
 
 Obsoletes: glib-gtkbeta-devel
 Conflicts: glib-devel <= 1.2.8
@@ -145,7 +145,7 @@ gio-querymodules %{_libdir}/gio/modules
 %{_bindir}/gapplication
 %{_bindir}/gdbus
 %{_bindir}/gio
-%{_bindir}/gio-launch-desktop
+#{_bindir}/gio-launch-desktop
 %{_bindir}/gio-querymodules
 %{_bindir}/glib-compile-schemas
 %{_bindir}/gsettings
@@ -214,6 +214,12 @@ gio-querymodules %{_libdir}/gio/modules
 %endif
 
 %changelog
+* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.2-2
+- rebuilt with libffi-3.3.
+
+* Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.2-1
+- new upstream release.
+
 * Fri Nov 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.62.2-1
 - new upstream release.
 

+ 5 - 1
g/gobject-introspection/gobject-introspection-vl.spec

@@ -1,5 +1,5 @@
 Name:           gobject-introspection
-Version:        1.62.0
+Version:        1.64.1
 Release:        1%{?_dist_release}
 Summary:        Introspection system for GObject-based libraries
 
@@ -62,6 +62,7 @@ Libraries and headers for gobject-introspection
 
 %build
 %meson \
+	-Ddoctool=disabled \
 	-Dgtk_doc=true
 
 %meson_build
@@ -107,6 +108,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/*.gz
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.64.1-1
+- new upstream release.
+
 * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.62.0-1
 - new upstream release.
 

+ 7 - 4
g/guile/guile-vl.spec

@@ -5,14 +5,14 @@
 Name: guile
 Summary: A GNU implementation of Scheme for application extensibility.
 Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
-Version: 2.2.6
-Release: 2%{?_dist_release}
+Version: 2.2.7
+Release: 1%{?_dist_release}
 
 Group: Development/Languages
 License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
-URL: http://www.gnu.org/software/guile/
+URL: https://www.gnu.org/software/guile/
 
-Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.xz
+Source: https://ftp.gnu.org/gnu/guile/guile-%{version}.tar.xz
 
 # following patchs are imported from fedora-dev 
 Patch1: guile-multilib.patch
@@ -339,6 +339,9 @@ fi
 
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.7-1
+- new upstream release.
+
 * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-2
 - made guile-devel alternatives-ready.
 

+ 6 - 3
g/guile20/guile20-vl.spec

@@ -4,13 +4,13 @@ Name: guile20
 Summary: A GNU implementation of Scheme for application extensibility.
 Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
 Version: 2.0.14
-Release: 4%{?_dist_release}
+Release: 5%{?_dist_release}
 
 Group: Development/Languages
 License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
-URL: http://www.gnu.org/software/guile/
+URL: https://www.gnu.org/software/guile/
 
-Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.xz
+Source: https://ftp.gnu.org/gnu/guile/guile-%{version}.tar.xz
 
 # following patchs are imported from fedora-dev 
 Patch1: guile-1.8.7-multilib.patch
@@ -326,6 +326,9 @@ fi
 
 
 %changelog
+* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.14-5
+- rebuilt with libffi-3.3.
+
 * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.14-4
 - made guile20-devel alternatives-ready.
 

+ 23 - 12
h/hardinfo/hardinfo-vl.spec

@@ -1,18 +1,20 @@
-%define name hardinfo
-%define version 0.5.1
-%define release 3%{?_dist_release}
-
 Summary: Displays information about your hardware and operating system
 Summary(ja): ハードウェア情報を表示するアプリケーション
-Name: %{name}
-Version: %{version}
-Release: %{release}
+Name: hardinfo
+Version: 0.5.1
+Release: 4%{?_dist_release}
+Group: Applications/System
+Vendor: Project Vine
+Distribution: Vine Linux
+
+License: GPLv2
+URL: https://www.berlios.de/software/hardinfo/
 Source: http://download.berlios.de/hardinfo/%{name}-%{version}.tar.bz2
 Patch: hardinfo-0.5.1-computer.patch
 Patch2: hardinfo-0.5.1-gmodule.patch
-License: GPLv2
-Group: Applications/System
-URL: http://hardinfo.berlios.de/
+# to fix linker error
+# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=757525
+Patch3: 757525.patch
 
 BuildRequires: gtk2-devel >= 2.6
 BuildRequires: libsoup-devel >= 2.4
@@ -28,26 +30,31 @@ USB, IDE, SCSI, Serial and parallel port devices.
 HardInfo はハードウェアと OS の情報を表示する小さなアプリケーションです.
 PCI, ISA PnP, USB, IDE, SCSI, シリアル/パラレルポートデバイスに対応しています.
 
+
 %prep
 %setup
 
 %patch -p1 -b .vine
-
 %patch2 -p1 -b .gmodule
+%patch3 -p1 -b .link
 
 %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' Makefile.in
 
+
 %build
 %configure
 %{__make} %{?_smp_mflags}
 
+
 %install
 %{__rm} -rf %{buildroot}
 %{__make} install DESTDIR="%{buildroot}"
 
+
 %clean
 %{__rm} -rf %{buildroot}
 
+
 %post
 /sbin/ldconfig
 %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
@@ -56,9 +63,10 @@ PCI, ISA PnP, USB, IDE, SCSI, シリアル/パラレルポートデバイスに
 /sbin/ldconfig
 %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
 
+
 %files
 %defattr(-, root, root, 0755)
-%doc LICENSE
+%license LICENSE
 %{_bindir}/hardinfo
 %{_datadir}/applications/hardinfo.desktop
 %{_datadir}/hardinfo/
@@ -66,6 +74,9 @@ PCI, ISA PnP, USB, IDE, SCSI, シリアル/パラレルポートデバイスに
 
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.5.1-4
+- rebuilt with libffi-3.3.
+
 * Thu Jul 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.1-3
 - rebuild with libpng-1.6.12
 - add BuildRequires: libsoup-devel

+ 8 - 2
l/llvm/llvm-vl.spec

@@ -21,7 +21,7 @@
 
 Name:           llvm
 Version:        10.0.0
-Release:        1%{?_dist_release}
+Release:        2%{?_dist_release}
 Summary:        The Low Level Virtual Machine
 Summary(ja):    LLVM - 低レベルバーチャルマシン
 
@@ -85,7 +85,7 @@ BuildRequires:  flex
 BuildRequires:  git
 BuildRequires:  gcc-c++ >= 3.4
 BuildRequires:  groff
-BuildRequires:  libffi-devel
+BuildRequires:  libffi-devel >= 3.3
 BuildRequires:  libstdc++-devel
 BuildRequires:  libstdc++-static
 BuildRequires:  libtool-ltdl-devel
@@ -864,6 +864,12 @@ exit 0
 %endif
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
+- rebuilt with libffi-3.3.
+
+* Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
+- new upstream release.
+
 * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
 - new upstream release.
 

+ 35 - 40
lib/libf/libffi/libffi-vl.spec

@@ -1,26 +1,21 @@
 %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
 
-%define name	libffi
-%define version	3.2.1
-%define release	1%{?_dist_release}
-
-Summary:	Foreign function interface library
-Summary(ja): 	Foreign function interface ライブラリ
-Name:		%{name}
-Version:	%{version}
-Release: 	%{release}
-Source0:	ftp://sourceware.org/pub/libffi/%{name}-%{version}.tar.gz
-Patch0:		libffi-3.1-fix-include-path.patch
-License:	Distributable
-Group:		System Environment/Libraries
-URL:		http://sourceware.org/libffi/
-
-BuildRequires:	gcc
-BuildRequires:	texinfo
-BuildRoot:	%{_tmppath}/%{name}-%{version}-root
-
-Vendor: Project Vine
-Distribution: Vine Linux
+Summary:        Foreign function interface library
+Summary(ja):    Foreign function interface ライブラリ
+Name:           libffi
+Version:        3.3
+Release:        1%{?_dist_release}
+Group:          System Environment/Libraries
+Vendor:         Project Vine
+Distribution:   Vine Linux
+
+License:        Distributable
+URL:            http://sourceware.org/libffi/
+Source0:        https://github.com/libffi/libffi/releases/download/v%{version}/%{name}-%{version}.tar.gz
+
+BuildRequires:  gcc
+BuildRequires:  texinfo
+BuildRoot:      %{_tmppath}/%{name}-%{version}-root
 
 %description
 A foreign function interface is the popular name for the interface
@@ -34,12 +29,12 @@ Foreign function interface は一般に普及しているインターフェイ
 
 #-----------------------------------------------------------------------------
 
-%package devel
-Summary:	Libraries and headers for %{name}
-Summary(ja): 	%{name} 用の開発ライブラリおよびヘッダファイル
-Group:		Development/Libraries
-Requires:	%{name} = %{version}
-Requires:	pkgconfig
+%package        devel
+Summary:        Libraries and headers for %{name}
+Summary(ja):    %{name} 用の開発ライブラリおよびヘッダファイル
+Group:          Development/Libraries
+Requires:       %{name} = %{version}
+Requires:       pkgconfig
 
 %description devel
 This package includes the files needed for developing and compiling
@@ -56,11 +51,11 @@ libffi を使用したアプリケーションを開発するなら、このパ
 をインストールしてください。
 
 #compat32
-%package -n compat32-%{name}
+%package -n     compat32-%{name}
 Summary:        Foreign function interface library
 Summary(ja):    Foreign function interface ライブラリ
 Group:          System Environment/Libraries
-Requires:	%{name} = %{version}
+Requires:       %{name} = %{version}
 
 %description -n compat32-%{name}
 A foreign function interface is the popular name for the interface
@@ -72,12 +67,12 @@ Foreign function interface は一般に普及しているインターフェイ
 ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
 とを可能にします。
 
-%package -n compat32-%{name}-devel
+%package -n     compat32-%{name}-devel
 Summary:        Libraries and headers for %{name}
 Summary(ja):    %{name} 用の開発ライブラリおよびヘッダファイル
 Group:          Development/Libraries
-Requires:	compat32-%{name} = %{version}
-Requires:	%{name}-devel = %{version}
+Requires:       compat32-%{name} = %{version}
+Requires:       %{name}-devel = %{version}
 
 %description -n compat32-%{name}-devel
 This package includes the files needed for developing and compiling
@@ -97,9 +92,9 @@ libffi を使用したアプリケーションを開発するなら、このパ
 
 
 %prep
-
 %setup -q
-%patch0 -p1
+sed -i -e 's/{toolexeclibdir}/{libdir}/' libffi.pc.in
+
 
 %build
 autoreconf -ifv
@@ -111,11 +106,6 @@ autoreconf -ifv
 %{__rm} -rf ${RPM_BUILD_ROOT}
 %{__make} install DESTDIR=${RPM_BUILD_ROOT}
 
-# move include files.
-%{__mv} ${RPM_BUILD_ROOT}/%{_libdir}/libffi-%{version}/include ${RPM_BUILD_ROOT}/%{_includedir}
-sed -i -e "s|^includedir=.*include$|includedir=%{_includedir}|" \
-	${RPM_BUILD_ROOT}/%{_libdir}/pkgconfig/libffi.pc
-
 # remove unnecessary files.
 %{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libffi.la
 %{__rm} -rf ${RPM_BUILD_ROOT}/%{_infodir}/dir
@@ -130,7 +120,8 @@ sed -i -e "s|^includedir=.*include$|includedir=%{_includedir}|" \
 
 %files
 %defattr(-,root,root)
-%doc ChangeLog* LICENSE README  
+%license LICENSE
+%doc ChangeLog* README  
 %{_libdir}/libffi.so.*
 %{_infodir}/libffi.info*
 %{_mandir}/man3/ffi.3*
@@ -157,6 +148,10 @@ sed -i -e "s|^includedir=.*include$|includedir=%{_includedir}|" \
 %endif
 
 %changelog
+* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
+- updated to 3.3.
+- dropped Patch0.
+
 * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.1-1
 - updated to 3.2.1.
 - imported Patch0 from rawhide.

+ 115 - 0
lib/libf/libffi321/libffi321-vl.spec

@@ -0,0 +1,115 @@
+Summary:	Foreign function interface library
+Summary(ja): 	Foreign function interface ライブラリ
+Name:		libffi321
+Version:	3.2.1
+Release: 	1%{?_dist_release}
+Source0:	ftp://sourceware.org/pub/libffi/libffi-%{version}.tar.gz
+Patch0:		libffi-3.1-fix-include-path.patch
+License:	Distributable
+Group:		System Environment/Libraries
+URL:		http://sourceware.org/libffi/
+
+BuildRequires:	gcc
+BuildRequires:	texinfo
+BuildRoot:	%{_tmppath}/%{name}-%{version}-root
+Obsoletes:	libffi < 3.3
+Provides:	libffi = %{version}-%{release}
+
+Vendor: Project Vine
+Distribution: Vine Linux
+
+%description
+A foreign function interface is the popular name for the interface
+that allows code written in one language to call code written in
+another language. 
+
+%description -l ja
+Foreign function interface は一般に普及しているインターフェイスで、
+ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
+とを可能にします。
+
+#-----------------------------------------------------------------------------
+
+%prep
+
+%setup -q -n libffi-%{version}
+%patch0 -p1
+
+%build
+autoreconf -ifv
+%configure
+%{__make}
+
+
+%install
+%{__rm} -rf ${RPM_BUILD_ROOT}
+%{__make} install DESTDIR=${RPM_BUILD_ROOT}
+
+# move include files.
+%{__mv} ${RPM_BUILD_ROOT}/%{_libdir}/libffi-%{version}/include ${RPM_BUILD_ROOT}/%{_includedir}
+sed -i -e "s|^includedir=.*include$|includedir=%{_includedir}|" \
+	${RPM_BUILD_ROOT}/%{_libdir}/pkgconfig/libffi.pc
+
+# remove unnecessary files.
+%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libffi.la
+%{__rm} -rf ${RPM_BUILD_ROOT}/%{_infodir}/dir
+
+rm -f %{buildroot}%{_libdir}/pkgconfig/*
+rm -f %{buildroot}%{_libdir}/libffi.a
+rm -f %{buildroot}%{_libdir}/libffi.so
+rm -f %{buildroot}%{_includedir}/*.h
+rm -f %{buildroot}%{_infodir}/*
+rm -f %{buildroot}%{_mandir}/man3/*
+
+
+%clean
+%{__rm} -rf ${RPM_BUILD_ROOT}
+
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+
+%files
+%defattr(-,root,root)
+%license LICENSE
+%doc ChangeLog* README  
+%{_libdir}/libffi.so.*
+
+
+%changelog
+* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.1-1
+- renamed from libffi to libffi321.
+- built for compatibility.
+
+* Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.1-1
+- updated to 3.2.1.
+- imported Patch0 from rawhide.
+
+* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.13-1
+- update to 3.0.13
+
+* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-4
+- create compat32 sub packages
+
+* Fri Nov 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.9-3
+- fixed includedir in libffi.pc
+
+* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 3.0.9-2
+- build with rpm-4.8.1-1 for pkg-config file
+
+* Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0.9-1
+- new upstream release
+- built with new toolchain
+
+* Wed Jan 21 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.8-1
+- new upstream release
+- spec in UTF-8
+
+* Thu Apr 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.0.5-1
+- updated to new upstream release
+
+* Wed Apr 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-1
+- apply new versioning policy
+
+* Sun Mar 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-0vl1
+- initial build for Vine Linux

+ 13 - 16
p/p11-kit/p11-kit-vl.spec

@@ -1,13 +1,12 @@
 %define		build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
 
-%define         pkg_version 0.23.20
-%define         pkg_release 1%{?_dist_release}
-
 Name:           p11-kit
-Version:        %{pkg_version}
-Release:        %{pkg_release}
+Version:        0.23.20
+Release:        2%{?_dist_release}
 Summary:        Provides a way to load and enumerate PKCS#11 modules
 Group:          System Environment/Libraries
+Vendor:         Project Vine
+Distribution:   Vine Linux
 
 License:        LGPLv2+
 URL:            https://p11-glue.github.io/p11-glue/p11-kit.html
@@ -15,15 +14,11 @@ Source0:        https://github.com/p11-glue/p11-kit/releases/download/%{version}
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
 
-BuildRequires:	libtasn1-devel
-BuildRequires:	libffi-devel
-BuildRequires:	ca-certificates
-
-Requires:		ca-certificates
-
+BuildRequires:  libtasn1-devel
+BuildRequires:  libffi-devel
+BuildRequires:  ca-certificates
 
-Vendor:		Project Vine
-Distribution:	Vine Linux
+Requires:       ca-certificates
 
 %description
 Provides a way to load and enumerate PKCS#11 modules. Provides a standard
@@ -34,7 +29,7 @@ Also solves problems with coordinating the use of PKCS#11 by different
 components or libraries living in the same process.
 
 
-%package	devel
+%package        devel
 Summary:        Development tools for p11-kit
 Summary(ja):    p11-kit の開発環境
 Group:          Development/Libraries
@@ -76,8 +71,7 @@ Summary:        Development tools for p11-kit
 Summary(ja):    p11-kit の開発環境
 Group:          Development/Libraries
 Requires:       compat32-%{name} = %{version}-%{release}
-Requires:	%{name}-devel = %{version}-%{release}
-Requires:       pkgconfig
+Requires:       %{name}-devel = %{version}-%{release}
 
 %description -n compat32-%{name}-devel
 Header files and libraries for building a extension library for the
@@ -147,6 +141,9 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.23.20-2
+- rebuilt with libffi-3.3.
+
 * Thu Mar 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.23.20-1
 - new upstream release.
 

+ 79 - 9
p/pycairo/pycairo-vl.spec

@@ -1,26 +1,34 @@
+%bcond_without python2
+%bcond_without python3
+
 %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
 
 Name: pycairo
 Summary: Python bindings for the cairo library
 Summary(ja): cairo ライブラリの Python バインディング
-Version: 1.8.10
-Release: 3%{?_dist_release}
+Version: 1.18.2
+Release: 1%{?_dist_release}
 
 Group: Development/Languages
 License: LGPLv2
 URL: http://cairographics.org/pycairo
 
-Source: http://cairographics.org/releases/py2cairo-%{version}.tar.gz
+Source: pycairo-%{version}.tar.gz
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: cairo-devel >= 1.8.10
+%if %{with python2}
 BuildRequires: python-devel >= 2.6
+BuildRequires: python-setuptools
+BuildRequires: python-rpm-macros
+%endif
 BuildRequires: pkgconfig
 Requires: cairo >= 1.8.10
 
 %description
 Python bindings for the cairo library.
 
+%if %{with python2}
 %package devel
 Summary: Libraries and headers for pycairo
 Group: Development/Libraries
@@ -31,33 +39,95 @@ Requires: python-devel
 %description devel
 This package contains files required to build wrappers for cairo add-on
 libraries so that they interoperate with pycairo.
+%endif
+
+
+%if %{with python3}
+%package -n python3-pycairo
+Summary: Python3 bindings for the cairo library
+Summary(ja): cairo ライブラリの Python3 バインディング
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-rpm-macros
+
+%description -n python3-pycairo
+Python3 bindings for the cairo library.
+
+
+%package -n python3-pycairo-devel
+Summary: Libraries and headers for pycairo
+Group: Development/Libraries
+Requires: python3-pycairo = %{version}-%{release}
+Requires: cairo-devel
+Requires: python3-devel
+
+%description -n python3-pycairo-devel
+This package contains files required to build wrappers for cairo add-on
+libraries so that they interoperate with pycairo.
+%endif
+
 
 %prep
 %setup -q 
 
 %build
-%configure --disable-static
-%__make %{?_smp_mflags}
+%if %{with python2}
+%py_build
+%endif
+%if %{with python3}
+%py3_build
+%endif
+
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%__make DESTDIR=$RPM_BUILD_ROOT install
+%if %{with python2}
+%py_install
+%endif
+%if %{with python3}
+%py3_install
+%endif
+
 find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+
+%if %{with python2}
 %files
 %defattr(-,root,root,-)
-%doc AUTHORS COPYING* INSTALL NEWS README
-%{python_sitearch}/cairo/
+%license COPYING*
+%doc NEWS README*
+%{python_sitearch}/*
 
 %files devel
 %defattr(-,root,root,-)
-%{_includedir}/pycairo/
+%dir %{_includedir}/pycairo/
+%{_includedir}/pycairo/pycairo.h
 %{_libdir}/pkgconfig/pycairo.pc
+%endif
+
+%if %{with python3}
+%files -n python3-pycairo
+%defattr(-,root,root,-)
+%license COPYING*
+%doc NEWS README*
+%{python3_sitearch}/*
+
+%files -n python3-pycairo-devel
+%defattr(-,root,root,-)
+%dir %{_includedir}/pycairo/
+%{_includedir}/pycairo/py3cairo.h
+%{_libdir}/pkgconfig/py3cairo.pc
+%endif
+
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.18.2-1
+- new upstream release.
+
 * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
 - rebuild with VineSeed environment
 

+ 4 - 1
p/pygobject/pygobject-vl.spec

@@ -4,7 +4,7 @@ Name: pygobject
 Summary: Python bindings for GObject
 Summary(ja): GObject の Python バインディング
 Version: 2.28.6
-Release: 6%{?_dist_release}
+Release: 7%{?_dist_release}
 
 Group: Development/Languages
 License: LGPL
@@ -129,6 +129,9 @@ rm -fr $RPM_BUILD_ROOT
 %{_datadir}/gtk-doc/html/pygobject
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.28.6-7
+- rebuilt with libffi-3.3.
+
 * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-6
 - rebuild with libffi-3.0.13
 

+ 43 - 54
p/pygobject3/pygobject3-vl.spec

@@ -1,16 +1,19 @@
-%{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
+%bcond_without python2
+%bcond_without python3
 
 Name: pygobject3
 Summary: Python bindings for GObject Introspection
 Summary(ja): GObject Introspection の Python バインディング
-Version: 3.20.1
+Version: 3.34.0
 Release: 1%{?_dist_release}
-
 Group: Development/Languages
-License: LGPL
-URL: http://www.pygtk.org/
+Vendor: Project Vine
+Distribution: Vine Linux
 
-Source: http://ftp.gnome.org/pub/GNOME/sources/pygobject/3.20/pygobject-%{version}.tar.xz
+License: LGPL
+URL: https://pypi.org/project/PyGObject/
+%global shortver %(echo "%{version}" | sed -e 's/\.[0-9]*$//')
+Source: https://ftp.gnome.org/pub/GNOME/sources/pygobject/%{shortver}/pygobject-%{version}.tar.xz
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: glib2-devel >= 2.26.0
@@ -18,21 +21,24 @@ BuildRequires: python-devel >= 2.6
 BuildRequires: libffi-devel
 BuildRequires: libtool, automake
 BuildRequires: gobject-introspection-devel >= 0.9.8
+%if %{with python2}
+BuildRequires: python-devel >= 2.6
+BuildRequires: python-setuptools
+BuildRequires: python-rpm-macros
 BuildRequires: pycairo-devel >= 1.8.10
+%endif
 
 Obsoletes:	%{name}-doc < 3.10.0
 
-Vendor: Project Vine
-Distribution: Vine Linux
-Packager: Takemikaduchi
-
 %description
 pygobject provides a convenient wrapper for the GObject library
 for use in Python programs.
 
+
 %package devel
 Summary: Development files for building add-on libraries
 Group: Development/Libraries
+Provides: python3-pygobject-devel = %{version}-%{release}
 Requires: %{name} = %{version}-%{release}
 Requires: glib2-devel
 Requires: libffi-devel
@@ -42,72 +48,49 @@ Requires: pkgconfig
 This package contains files required to build wrappers for
 pygobject-based libraries such as pygtk2.
 
+
+%if %{with python3}
 %package -n python3-pygobject
 Summary: Python3 bindings for GObject Introspection
 Summary(ja): GObject Introspection の Python3 バインディング
-BuildRequires: python3-pycairo-devel >= 1.10.0
-Requires: python3 >= 3.3
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-rpm-macros
+BuildRequires: python3-pycairo-devel
 Obsoletes: python3-pygobject < 3.16.1
 
 %description -n python3-pygobject
 python3-pygobject provides a convenient wrapper for the GObject library
 for use in Python3 programs.
+%endif
 
 %prep
 %setup -q -n pygobject-%{version}
 
-# python3
-rm -rf ../python3
-cp -a . ../python3
 
 %build
-# --disable-docs doesn't work; it builds the docs anyway.
-%configure \
-	--with-python=python2 \
-    --enable-silent-rules \
-    --disable-static \
-    --enable-thread
-export tagname=CC
-make LIBTOOL=/usr/bin/libtool
-
-#  python3
-pushd ../python3
-%configure \
-	--with-python=python3 \
-    --enable-silent-rules \
-    --disable-static \
-    --enable-thread
-export tagname=CC
-make LIBTOOL=/usr/bin/libtool
-popd
+%if %{with python2}
+%py_build
+%endif
+%if %{with python3}
+%py3_build
+%endif
+
 
 %install
 rm -rf $RPM_BUILD_ROOT
-export tagname=CC
-
-# python3
-pushd ../python3
-make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
-
-find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
-rm -f examples/Makefile*
-popd
-rm -rf ../python3
-
-# python2
-make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
-
-find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
-rm -f examples/Makefile*
-
-# conflict with pygobject
-rm -rf $RPM_BUILD_ROOT%{python_sitearch}/gtk-2.0
-rm -rf $RPM_BUILD_ROOT%{_datadir}/pygobject
+%if %{with python2}
+%py_install
+%endif
+%if %{with python3}
+%py3_install
+%endif
 
 
 %clean
 rm -fr $RPM_BUILD_ROOT
 
+%if %{with python2}
 %files
 %defattr(-,root,root,-)
 %doc AUTHORS NEWS README ChangeLog
@@ -115,21 +98,27 @@ rm -fr $RPM_BUILD_ROOT
 %{_libdir}/python2.7/site-packages/pygtkcompat
 %{python_sitearch}/*.egg-info
 %{python_sitearch}/gi
+%endif
 
 %files devel
 %defattr(-,root,root,-)
 %{_includedir}/pygobject-3.0/pygobject.h
 %{_libdir}/pkgconfig/pygobject-3.0.pc
 
+%if %{with python3}
 %files -n python3-pygobject
 %defattr(-,root,root,-)
 %doc AUTHORS NEWS README ChangeLog
 %{python3_sitearch}/pygtkcompat
 %{python3_sitearch}/*.egg-info
 %{python3_sitearch}/gi
+%endif
 
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.34.0-1
+- new upstream release.
+
 * Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.1-1
 - new upstream release
 

+ 6 - 3
p/python-cffi/python-cffi-vl.spec

@@ -1,10 +1,10 @@
 Name:           python-cffi
-Version:        1.11.5
-Release:        7%{?_dist_release}
+Version:        1.14.0
+Release:        1%{?_dist_release}
 Summary:        Foreign Function Interface for Python to call C code
 Group:          Development/Libraries
 License:        MIT
-URL:            http://cffi.readthedocs.org/
+URL:            https://pypi.org/project/cffi/
 Vendor:         Project Vine
 Distribution:   Vine Linux
 Source0:        cffi-%{version}.tar.gz
@@ -69,6 +69,9 @@ based on LuaJIT’s FFI.
 %{python3_sitearch}/cffi-%{version}-py%{python3_version}.egg-info/
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.14.0-1
+- new upstream release.
+
 * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.11.5-7
 - initial build for Vine Linux.
 

+ 5 - 2
p/python/python-vl.spec

@@ -11,8 +11,8 @@
 Summary: An interpreted, interactive, object-oriented programming language.
 Summary(ja): オブジェクト指向言語 Python インタプリタ
 Name: python
-Version: %{pybasever}.16
-Release: 5%{?_dist_release}
+Version: %{pybasever}.17
+Release: 1%{?_dist_release}
 License: PSF
 Group: Development/Languages
 URL: https://www.python.org/%{pybasever}/
@@ -479,6 +479,9 @@ rm -fr $RPM_BUILD_ROOT
 
 
 %changelog
+* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.17-1
+- new upstream release.
+
 * Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.16-5
 - rebuilt with tix-8.4.3-5.
 

+ 11 - 8
p/python3/python3-vl.spec

@@ -7,13 +7,16 @@
 Summary: An interpreted, interactive, object-oriented programming language.
 Summary(ja): オブジェクト指向 Python3 インタプリタ
 Name: python3
-Version: 3.5.7
-Release: 5%{?_dist_release}
-License: PSF
+Version: 3.5.9
+Release: 1%{?_dist_release}
 Group: Development/Languages
+Vendor: Project Vine
+Distribution: Vine Linux
+
+License: PSF
 URL: http://www.python.org/download/releases/%{version}
-Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
-Source1: https://docs.python.org/3.5/archives/python-%{version}-docs-html.tar.bz2
+Source0: https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
+Source1: https://docs.python.org/ftp/python/doc/%{version}/python-%{version}-docs-html.tar.bz2
 Patch1: python-3.5.2-lib64.patch
 Patch2: python3-3.4.4-revert-makefile.patch
 
@@ -42,9 +45,6 @@ Requires: readline
 Requires: sqlite3
 Requires: zlib
 
-Vendor: Project Vine
-Distribution: Vine Linux
-
 %description
 Python is an interpreted, interactive, object-oriented programming
 language.  It incorporates modules, exceptions, dynamic typing, very high
@@ -296,6 +296,9 @@ rm -fr $RPM_BUILD_ROOT
 
 
 %changelog
+* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.9-1
+- new upstream release.
+
 * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-5
 - fixed %%files.
 

+ 43 - 9
r/ruby/ruby-vl.spec

@@ -1,8 +1,9 @@
 %bcond_without test
+%bcond_with json
 
 %global major_version 2
 %global minor_version 6
-%global teeny_version 5
+%global teeny_version 6
 
 %global major_minor_version %{major_version}.%{minor_version}
 
@@ -23,26 +24,37 @@
 %global gem_extdir %{_libdir}/gems
 %global gem_extdirs %{_exec_prefix}/lib{,64}/gems
 
+# lib/bundler
 %global bundler_version 1.17.2
+# lib/fileutils
 %global bundler_fileutils_version 1.1.0
+# lib/bundler/vendor/molinillo/lib/molinillo/gem_metadata.rb
 %global bundler_molinillo_version 0.6.6
+# lib/bundler/vendor/net-http-persistent/lib/net/http/persistent.rb
 %global bundler_net_http_persistent_version 2.9.4
+# lib/bundler/vendor/thor/lib/thor
 %global bundler_thor_version 0.20.0
 
 # TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
 # http://redmine.ruby-lang.org/issues/5313
 %global irb_version %{ruby_version}
 
-%global rake_version 12.3.2
-%global rdoc_version 6.1.2
+# ext/bigdecimal
 %global bigdecimal_version 1.4.1
+# ext/io/console
 %global io_console_version 0.4.7
+# ext/json
 %global json_version 2.1.0
-%global minitest_version 5.11.3
+# ext/psych
 %global psych_version 3.1.0
+# gems
+%global minitest_version 5.11.3
 %global power_assert_version 1.1.3
+%global rake_version 12.3.3
 %global test_unit_version 3.2.9
 %global xmlrpc_version 0.3.0
+# lib/rdoc
+%global rdoc_version 6.1.2
 
 # Note:
 # As seen on perl srpm, as this (ruby) srpm contains several sub-components,
@@ -52,7 +64,7 @@
 #
 # 全てのサブパッケージのバージョンが上がる場合を除き、rubyのmainバージョンが
 # 更新されても1には戻さずに必ず+1してください。
-%global ruby_rel 1
+%global ruby_rel 2
 
 %bcond_without emacsen
 %define rbmode          ruby-mode
@@ -127,7 +139,7 @@ Patch2: ruby-2.1.0-Enable-configuration-of-archlibdir.patch
 Patch3: ruby-2.1.0-always-use-i386.patch
 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
 # http://bugs.ruby-lang.org/issues/5617
-Patch4: ruby-2.1.0-custom-rubygems-location.patch
+Patch4: ruby-2.6.6-custom-rubygems-location.patch
 # Make mkmf verbose by default
 Patch5: ruby-1.9.3-mkmf-verbose.patch
 # Adds support for '--with-prelude' configuration option. This allows to built
@@ -325,7 +337,7 @@ License:    GPLv2 and Ruby and MIT
 Requires:   ruby(release) = %{ruby_release}
 Requires:   ruby(rubygems) >= %{rubygems_version}
 Requires:   ruby(irb) = %{irb_version}
-Requires:   rubygem(json) = %{json_version}
+Requires:   rubygem(json) >= %{json_version}
 Provides:   rdoc = %{version}-%{release}
 Provides:   ri = %{version}-%{release}
 Provides:   rubygem(rdoc) = %{version}-%{release}
@@ -392,7 +404,7 @@ Provides:   rubygem(io-console) = %{version}-%{release}
 IO/Console provides very simple and portable access to console. It doesn't
 provide higher layer features, such like curses and readline.
 
-
+%if %{with json}
 %package -n rubygem-json
 Summary:    This is a JSON implementation as a Ruby extension in C
 Version:    %{json_version}
@@ -407,7 +419,7 @@ This is a implementation of the JSON specification according to RFC 4627.
 You can think of it as a low fat alternative to XML, if you want to store
 data to disk or transmit it over a network rather than use a verbose
 markup language.
-
+%endif
 
 %package -n rubygem-minitest
 Summary:    Minitest provides a complete suite of testing facilities.
@@ -733,6 +745,17 @@ sed -i '/^end$/ i\
 sed -i '/^end$/ i\
   s.require_paths = ["lib"]' %{buildroot}%{gem_dir}/%{ruby_release}/specifications/minitest-%{minitest_version}.gemspec
 
+%if !%{with json}
+pushd %{buildroot}
+rm -rf .%{ruby_libdir}/%{ruby_release}/json
+rm -rf .%{ruby_libarchdir}/%{ruby_release}/json
+rm -rf .%{gem_extdir}/%{ruby_release}/exts/json-%{json_version}
+rm -rf .%{gem_dir}/%{ruby_release}/gems/json-%{json_version}
+rm -f .%{gem_dir}/%{ruby_release}/specifications/json-%{json_version}.gemspec
+popd
+%endif
+
+
 %if %{with test}
 %check
 DISABLE_TESTS=""
@@ -972,14 +995,18 @@ fi
 %exclude %{_exec_prefix}/lib*/gems/%{ruby_release}/exts/bigdecimal-%{bigdecimal_version}
 %exclude %{_exec_prefix}/lib*/gems/%{ruby_release}/exts/bundler-%{bundler_version}
 %exclude %{_exec_prefix}/lib*/gems/%{ruby_release}/exts/io-console-%{io_console_version}
+%if %{with json}
 %exclude %{_exec_prefix}/lib*/gems/%{ruby_release}/exts/json-%{json_version}
+%endif
 %exclude %{_exec_prefix}/lib*/gems/%{ruby_release}/exts/psych-%{psych_version}
 %exclude %{gem_dir}/%{ruby_release}/gems/rake-%{rake_version}
 %exclude %{gem_dir}/%{ruby_release}/gems/rdoc-%{rdoc_version}
 %exclude %{gem_dir}/%{ruby_release}/specifications/bigdecimal-%{bigdecimal_version}.gemspec
 %exclude %{gem_dir}/%{ruby_release}/specifications/bundler-%{bundler_version}.gemspec
 %exclude %{gem_dir}/%{ruby_release}/specifications/io-console-%{io_console_version}.gemspec
+%if %{with json}
 %exclude %{gem_dir}/%{ruby_release}/specifications/json-%{json_version}.gemspec
+%endif
 %exclude %{gem_dir}/%{ruby_release}/specifications/minitest-%{minitest_version}.gemspec
 %exclude %{gem_dir}/%{ruby_release}/specifications/rake-%{rake_version}.gemspec
 %exclude %{gem_dir}/%{ruby_release}/specifications/rdoc-%{rdoc_version}.gemspec
@@ -1034,12 +1061,14 @@ fi
 %{gem_dir}/%{ruby_release}/gems/io-console-%{io_console_version}
 %{gem_dir}/%{ruby_release}/specifications/io-console-%{io_console_version}.gemspec
 
+%if %{with json}
 %files -n rubygem-json
 %{ruby_libdir}/%{ruby_release}/json
 %{ruby_libarchdir}/%{ruby_release}/json
 %{gem_extdir}/%{ruby_release}/exts/json-%{json_version}
 %{gem_dir}/%{ruby_release}/gems/json-%{json_version}
 %{gem_dir}/%{ruby_release}/specifications/json-%{json_version}.gemspec
+%endif
 
 %files -n rubygem-minitest
 #%{ruby_libdir}/%{ruby_release}/minitest
@@ -1088,6 +1117,11 @@ fi
 
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-2
+- updated to 2.6.6.
+- disabled json (provided by another srpm temporalily for CVE-2020-10663).
+- updated Patch4.
+
 * Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.5-1
 - updated to 2.6.5.
 - dropped Patch10-11 and 100-102.

+ 8 - 10
u/uim/uim-vl.spec

@@ -61,27 +61,22 @@ Summary: Uim an input method library
 Summary(ja): 入力メソッドライブラリ
 Version: 1.8.8
 #Release: 6.git%{shortcommit}%{?_dist_release}
-Release: 2%{?_dist_release}
-
-# pinyin-big5.scm and elatin-rules.scm are licensed under GPL
-License: BSD, LGPLv2 and GPL
+Release: 3%{?_dist_release}
 Group: System Environment/Libraries
-URL: https://github.com/uim/uim
-
 Vendor: Project Vine
 Distribution: Vine Linux
 Packager: iwaim
 
-#Source0: http://uim.googlecode.com/files/uim-%{version}%{?extraver:-%extraver}.tar.bz2
-#Source0: https://github.com/uim/%{name}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
-Source0: %{name}-%{version}.tar.bz2
+# pinyin-big5.scm and elatin-rules.scm are licensed under GPL
+License: BSD, LGPLv2 and GPL
+URL: https://github.com/uim/uim
+Source0: https://github.com/uim/uim/releases/download/%{version}/uim-%{version}.tar.bz2
 Source1: uim-el-install.sh
 Source2: uim-el-remove.sh
 Source3: uim-update-installed-modules.sh.in
 Source4: vine-default-uim-el.el
 Source5: uim-el-init.el
 Source6: https://github.com/uim/sigscheme/releases/download/%{sigscheme_version}/sigscheme-%{sigscheme_version}.tar.bz2
-#Source7: https://github.com/uim/libgcroots/archive/%{libgcroots_commit}/libgcroots-%{libgcroots_shortcommit}.tar.gz
 Source7: https://github.com/uim/libgcroots/releases/download/%{libgcroots_version}/libgcroots-%{libgcroots_version}.tar.bz2
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
@@ -882,6 +877,9 @@ fi
 %{_libdir}/pkgconfig/*
 
 %changelog
+* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.8-3
+- rebuilt with libffi-3.3.
+
 * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.8-2
 - disabled gtk2, qt3 and kde.