Browse Source

updated 5 packages

abiword-3.0.4-1

autoconf-archive-2021.02.19-1

gnumeric-1.12.48-1

t1lib-5.1.2-5

wv-1.2.9-2
Tomohiro "Tomo-p" KATO 1 year ago
parent
commit
15b5c600d1
5 changed files with 303 additions and 254 deletions
  1. 105 128
      a/abiword/abiword-vl.spec
  2. 16 7
      a/autoconf-archive/autoconf-archive-vl.spec
  3. 63 54
      g/gnumeric/gnumeric-vl.spec
  4. 86 47
      t/t1lib/t1lib-vl.spec
  5. 33 18
      w/wv/wv-vl.spec

+ 105 - 128
a/abiword/abiword-vl.spec

@@ -1,66 +1,70 @@
-%define desktop_file_utils_version 0.16
-%define abiver 3.0
+%define desktop_file_utils_version 0.26
 
 Summary: The AbiWord word processor
 Summary(ja): AbiWord ワードプロセッサ
 Name: abiword
-Version: 3.0.1
-Release: 3%{?_dist_release}
 Epoch: 1
-Group: Applications/Productivity
+Version: 3.0.4
+Release: 1%{?_dist_release}
+%global abiver %(echo %{version} | cut -d . -f 1-2)
+%global docver 3.0.1
+Group: office
+Vendor: Project Vine
+Distribution: Vine Linux
+
 License: GPLv2+
+URL: http://www.abisource.com/
 Source0: http://abisource.com/downloads/abiword/%{version}/source/abiword-%{version}.tar.gz
-Source3: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
+Source1: http://abisource.com/downloads/abiword/%{docver}/source/abiword-docs-%{docver}.tar.gz
 Source11: abiword.mime
+Source12: abiword.keys
+Source13: abiword.xml
 
-BuildRoot: %{_tmppath}/%{name}-%{version}-root
+Patch0: abiword-2.6.0-windowshelppaths.patch
+Patch1: abiword-2.8.3-desktop.patch
+Patch2: abiword-2.6.0-boolean.patch
+Patch3: abiword-3.0.0-librevenge.patch
+Patch4: abiword-3.0.2-explicit-python.patch
+Patch5: abiword-3.0.4-pygobject.patch
 
-Vendor: Project Vine
-Distribution: Vine Linux
-#Packager:
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
 
-# for abiword
-BuildRequires: flex
+BuildRequires: autoconf-archive
+BuildRequires: automake
 BuildRequires: bison
+BuildRequires: bzip2-devel
+BuildRequires: cairo-devel
+BuildRequires: dbus-glib-devel
+BuildRequires: desktop-file-utils
+BuildRequires: enchant2-devel
+BuildRequires: flex
+BuildRequires: fribidi-devel
 BuildRequires: gcc-c++
-BuildRequires: gtk2-devel
+BuildRequires: gobject-introspection-devel
+BuildRequires: goffice-devel
+BuildRequires: gtk3-devel
+BuildRequires: libboost-devel
+BuildRequires: libgsf-devel
 BuildRequires: libpng-devel
-BuildRequires: libxml2-devel
-BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
-BuildRequires: fribidi-devel
-BuildRequires: enchant-devel
-BuildRequires: libgnomeprint-devel
-BuildRequires: libgnomeprintui-devel
-BuildRequires: wv-devel
-BuildRequires: gucharmap-devel
-BuildRequires: libSM-devel
-
-# some plugin build deps
-BuildRequires: readline-devel
-BuildRequires: bzip2-devel
-BuildRequires: poppler-devel >= 0.14.2
-BuildRequires: libwpd-devel >= 0.8.0
 BuildRequires: librsvg2-devel
-BuildRequires: libgsf-devel >= 1.12.1
-BuildRequires: libboost-devel >= 1.33.1
-
-# gnome build deps
-BuildRequires: libbonobo-devel
-BuildRequires: libbonoboui-devel
-BuildRequires: libgnomeui-devel
-
+BuildRequires: libsoup-devel
+BuildRequires: libwmf-devel
+BuildRequires: libxslt-devel
+BuildRequires: poppler-devel
+BuildRequires: popt-devel
+BuildRequires: python3-pygobject
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: readline-devel
+BuildRequires: t1lib-devel
+BuildRequires: wv-devel
+BuildRequires: zlib-devel
 
+Requires: libabiword = %{epoch}:%{version}-%{release}
+Requires: python3-pygobject
 Requires(pre): desktop-file-utils >= %{desktop_file_utils_version}
 Obsoletes: abiword-fonts abiword-plugins
 
-URL: http://www.abisource.com/
-
-Patch0: abiword-2.6.0-windowshelppaths.patch
-Patch1: abiword-2.6.4-desktop.patch
-Patch2: abiword-2.6.0-boolean.patch
-Patch3: abiword-2.8.6-no-undefined.patch
-
-
 %description
 AbiWord is a cross-platform Open Source word processor. The goal is to make
 AbiWord full-featured, and remain lean.
@@ -69,10 +73,11 @@ AbiWord full-featured, and remain lean.
 AbiWord はクロスプラットフォームのオープンソースなワードプロセッサーです。
 多機能で機敏に動くことを目標としています。
 
+
 %package -n libabiword
 Summary: Library for developing applications based on AbiWord's core
 Summary(ja): AbiWord コアで稼動するアプリケーションを開発するためのライブラリ
-Group: System Environment/Libraries
+Group: system
 
 %description -n libabiword
 Library for developing applications based on AbiWord's core.
@@ -80,10 +85,11 @@ Library for developing applications based on AbiWord's core.
 %description -n libabiword -l ja
 AbiWord コアで稼動するアプリケーションを開発するためのライブラリです。
 
+
 %package -n libabiword-devel
 Summary: Files for developing with libabiword
 Summary(ja): libabiword を用いた開発に必要なファイル群
-Group: Development/Libraries
+Group: programming
 Requires: libabiword = %{epoch}:%{version}-%{release}
 
 %description -n libabiword-devel
@@ -92,130 +98,101 @@ Includes and definitions for developing with libabiword.
 %description -n libabiword-devel -l ja
 libabiword で開発するためのインクルードファイル及び定義ファイルです。
 
+
+%debug_package
+
+
 %prep
-%setup -q 
-## %patch1 -p1 -b .desktop
-%patch2 -p1 -b .boolean
+%setup -q  -a 1
 
-# setup abiword extras
-## %setup -q -T -b 2 -n abiword-extras-%{version}
+%patch1 -p1 -b .desktop
+%patch2 -p1 -b .boolean
+%patch3 -p0 -b .librevenge
+%patch4 -p1 -b .explicit_python
+%patch5 -p1 -b .pygo
 
 # setup abiword documentation
-%setup -q -T -b 3 -n abiword-docs-%{version}
+pushd abiword-docs-%{docver}
 %patch0 -p1 -b .windowshelppaths
+# some of the help dirs have bad perms (#109261)
+find . -type d -exec chmod -c o+rx {} \;
+popd
+
 
 %build
-# build libabiword and abiword
-cd $RPM_BUILD_DIR/abiword-%{version}
-%configure  -enable-static=no
-make %{?_smp_mflags}
-
-# build abiword-plugins
-## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
-## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
-## CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --disable-gda --enable-libabiword --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
-## # Remove libtool predep_objects and postdep_objects wonkiness so that
-## # building without -nostdlib doesn't include them twice.  Because we
-## # already link with g++, weird stuff happens if you don't let the
-## # compiler handle this.
-## sed 's/^predep_objects=.*/predep_objects=\"\"/' < libtool > libtool.foo
-## sed 's/^postdep_objects=.*/postdep_objects=\"\"/' < libtool.foo > libtool.foobar
-## sed 's/-shared -nostdlib/-shared/' < libtool.foobar > libtool
-## make %{?_smp_mflags}
-
-# build abiword-extras
-## cd $RPM_BUILD_DIR/abiword-extras-%{version}
-## # abiword-extras looks at the abiword-%{version}.pc pkg-config file to get its location info 
-## # however, that file is not installed yet, so just point to it in the abiword source tree 
-## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
-## %configure
-## make
+# Needed while explicit-python.patch touches gi-overrides/Makefile.am
+aclocal
+automake
+
+export CXXFLAGS="-std=c++14 $RPM_OPT_FLAGS -DASIO_ENABLE_BOOST"
+%configure --enable-plugins --enable-clipart --enable-templates --enable-introspection
+%{make_build} V=1
 
 # build the documentation
-cd $RPM_BUILD_DIR/abiword-docs-%{version}
-ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/wp/main/unix/abiword ./make-html.sh
+pushd abiword-docs-%{docver}
+ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/abiword ./make-html.sh
+popd
+
 
 %install 
 rm -rf $RPM_BUILD_ROOT
-
-# install abiword
-cd $RPM_BUILD_DIR/abiword-%{version}
-make install DESTDIR=$RPM_BUILD_ROOT
-# overwrite the static binary with the dynamic one
-## mv -f $RPM_BUILD_DIR/abiword-%{version}/src/wp/main/unix/abiword-dynamic $RPM_BUILD_ROOT%{_bindir}/abiword
-
-# Fix script permission
-#chmod +x $RPM_BUILD_ROOT%{_datadir}/%{name}-%{abiver}/scripts/abw2html.pl
-
-# install abiword-plugins
-## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
-## make install DESTDIR=$RPM_BUILD_ROOT
-
-# install the extras
-## cd $RPM_BUILD_DIR/abiword-extras-%{version}
-## make install DESTDIR=$RPM_BUILD_ROOT
+%{make_install}
 
 # install the documentation
-cd $RPM_BUILD_DIR/abiword-docs-%{version}
+pushd abiword-docs-%{docver}
 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help
 cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/
-# some of the help dirs have bad perms (#109261)
-find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
-
-# finish up
-## mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
-## cp $RPM_BUILD_DIR/abiword-extras-%{version}/icons/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
-
-cd $RPM_BUILD_DIR/abiword-%{version}
-mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
-desktop-file-install \
-  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
-  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
-  --add-category Applications --add-category Office \
-  ./abiword.desktop
-# remove the original one (which has X-Red-Hat-Base)  (#107023)
-#rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
-
-mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime-info
-install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info
-
-# nuke .la files
-rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{abiver}/plugins/*.la
-rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
-# nuke .a files
-rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
-# nuke custom dictionary files
-rm -f $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/dictionary/ispell_dictionary_list.xml
+popd
+
+install -p -m 0644 -D %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info/abiword.mime
+install -p -m 0644 -D %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/mime-info/abiword.keys
+install -p -m 0644 -D %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/mime/packages/abiword.xml
+
+# Remove libtool archives and static libs
+find %{buildroot} -name '*.la' -delete
+find %{buildroot} -name '*.a' -delete
 
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-update-desktop-database -q %{_datadir}/applications
 
-%postun
-update-desktop-database -q %{_datadir}/applications
+%ldconfig_scriptlets -n libabiword
+
 
 %files
 %defattr(-,root,root)
 %{_bindir}/abiword
+%{_datadir}/appdata/*.appdata.xml
 %{_datadir}/applications/*
 %{_datadir}/mime-info/*
+%{_datadir}/mime/packages/abiword.xml
 %{_datadir}/icons/*/*/*/abiword.*
+%{_datadir}/%{name}-%{abiver}/AbiWord
 %{_mandir}/man1/abiword.1.gz
 
 %files -n libabiword
 %doc $RPM_BUILD_DIR/%{name}-%{version}/docs $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT $RPM_BUILD_DIR/%{name}-%{version}/README.TXT
 %{_libdir}/abiword-%{abiver}
 %{_libdir}/libabiword-%{abiver}.so
+%{_libdir}/girepository-1.0/Abi-3.0.typelib
 %{_datadir}/abiword-%{abiver}
 
 %files -n libabiword-devel
 %{_includedir}/abiword-%{abiver}
 %{_libdir}/pkgconfig/*.pc
+%{_datadir}/gir-1.0/Abi-3.0.gir
+
 
 %changelog
+* Mon Mar 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1:3.0.4-1
+- new upstream release.
+- updated Source11.
+- added Source12-13.
+- updated Patch0-2.
+- dropped Patch3.
+- imported Patch3-5 from rawhide.
+
 * Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:3.0.1-3
 - rebuild with gcc-5.4.0
 

+ 16 - 7
a/autoconf-archive/autoconf-archive-vl.spec

@@ -1,14 +1,14 @@
-Name:           autoconf-archive
-Version:        2018.03.13
-Release:        3%{?_dist_release}
 Summary:        The Autoconf Macro Archive
 Summary(ja):    Autoconfマクロ集
-License:        GPLv3+ with exceptions
-URL:            http://www.gnu.org/software/autoconf-archive/
-
+Name:           autoconf-archive
+Version:        2021.02.19
+Release:        1%{?_dist_release}
+Group:          programming
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
+License:        GPLv3+ with exceptions
+URL:            http://www.gnu.org/software/autoconf-archive/
 Source0:        http://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
 BuildArch:      noarch
 Requires:       autoconf
@@ -25,19 +25,23 @@ supporters of the cause from all over the Internet.
 ウェアとして、その支持者により提供された450を超えるautoconf用マクロの
 コレクションです。
 
+
 %prep
 %setup -q
 
+
 %build
 %configure
 %make_build
 
+
 %install
 %make_install INSTALL="install -p"
 # remove dir file which will be generated by /sbin/install-info
 rm -frv %{buildroot}%{_infodir}/dir
 # document files are installed another location
-rm -frv %{buildroot}%{_datadir}/%{name}
+rm -frv %{buildroot}%{_docdir}/%{name}
+
 
 %post
 install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
@@ -47,13 +51,18 @@ if [ $1 = 0 ]; then
   install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
 fi
 
+
 %files
 %doc AUTHORS NEWS README TODO
 %license COPYING*
 %{_datadir}/aclocal/*.m4
 %{_infodir}/autoconf-archive.info*
 
+
 %changelog
+* Mon Mar 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2021.02.19-1
+- ne upstream release.
+
 * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2018.03.13-3
 - initial build for Vine Linux.
 

+ 63 - 54
g/gnumeric/gnumeric-vl.spec

@@ -1,12 +1,14 @@
+%bcond_with devel
+
 %define gnumeric_version %{version}-bonobo
 %define goffice_version  0.10.44
 
 Summary:        A spreadsheet program for GNOME.
 Summary(ja):    GNOME スプレッドシート
 Name:           gnumeric
-Version:        1.12.46
+Version:        1.12.48
 Release:        1%{?_dist_release}
-Group:          Applications/Productivity
+Group:          office
 Distribution:   Vine Linux
 Vendor:         Project Vine
 
@@ -24,17 +26,16 @@ BuildRequires:  flex
 BuildRequires:  goffice-devel >= %{goffice_version}
 #BuildRequires:  python3-devel
 #BuildRequires:  python3-pygobject
-BuildRequires:  python-devel
-BuildRequires:  pygobject3
-BuildRequires:  pygobject3-devel
+#BuildRequires:  python-devel
+#BuildRequires:  pygobject3
+#BuildRequires:  pygobject3-devel
 BuildRequires:  perl
 BuildRequires:  automake
 BuildRequires:  gnome-doc-utils
 BuildRequires:  desktop-file-utils
 BuildRequires:  itstool
 
-Requires(postun,posttrans): glib2
-Requires(post,postun): desktop-file-utils
+Requires(post,postun): gtk3
 
 Obsoletes:      %{name}-devel
 
@@ -58,19 +59,34 @@ MS Excelファイルや他の多くのフォーマット(csv, latex, xbase, appl
 を読込み、出力できます.
 
 
+%if %{with devel}
+%package devel
+Summary:          Files necessary to develop gnumeric-based applications
+Group:            programming
+Requires:         %{name}%{?_isa} = %{version}-%{release}
+
+%description devel
+Gnumeric is a spreadsheet program for the GNOME GUI desktop
+environment. The gnumeric-devel package includes files necessary to
+develop gnumeric-based applications.
+%endif
+
+%debug_package
+
+
 %prep
 %setup -q
 %patch0 -p1 -b .vlgothic
 
 
 %build
-export PYTHON=%{__python}
+#export PYTHON=%{__python}
 
-%configure \
-    --without-gda \
-    --with-perl \
-    --with-python
-make
+%configure --disable-silent-rules --disable-maintainer-mode
+# Don't use rpath!
+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+%make_build
 
 
 %install
@@ -78,73 +94,66 @@ make
 
 make DESTDIR=$RPM_BUILD_ROOT install
 
-desktop-file-install \
-    --vendor gnome --delete-original \
-    --dir $RPM_BUILD_ROOT%{_datadir}/applications       \
-    --add-category Office                               \
-    --add-category Application                          \
-    --add-category Spreadsheet                          \
-    --remove-mime-type="zz-application/zz-winassoc-xls" \
-    $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
+%find_lang %{name} --all-name --with-gnome
 
-%find_lang %{name}-%{version}
-%find_lang %{name}-%{version}-functions
-cat %{name}-%{version}-functions.lang >> %{name}-%{version}.lang
+mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
+desktop-file-install --delete-original                                  \
+  --remove-category Science                                             \
+  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
 
-find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
+#remove unused mime type icons
+rm $RPM_BUILD_ROOT/%{_datadir}/pixmaps/gnome-application-*.png
+rm $RPM_BUILD_ROOT/%{_datadir}/pixmaps/%{name}/gnome-application-*.png
 
-rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
-rm -rf $RPM_BUILD_ROOT%{_includedir}/libspreadsheet-1.12
-rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
+#remove spurious .ico thing
+rm $RPM_BUILD_ROOT/usr/share/pixmaps/win32-%{name}.ico
+rm $RPM_BUILD_ROOT/usr/share/pixmaps/%{name}/win32-%{name}.ico
 
+#remove .la files
+find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
 
-%clean
-[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
+%if !%{with devel}
+rm -rf %{buildroot}%{_libdir}/libspreadsheet.so
+rm -rf %{buildroot}%{_libdir}/pkgconfig
+rm -rf %{buildroot}%{_includedir}/*
+%endif
 
 
-%post
-/sbin/ldconfig
-scrollkeeper-update > /dev/null 2>&1 || :
-touch --no-create %{_datadir}/icons/hicolor || :
-if [ -x %{_bindir}/gtk-update-icon-cache ]; then
-   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
-fi
-update-desktop-database -q &> /dev/null || :
+%clean
+[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
 
-%postun
-/sbin/ldconfig
-scrollkeeper-update > /dev/null 2>&1 || :
-touch --no-create %{_datadir}/icons/hicolor || :
-if [ -x %{_bindir}/gtk-update-icon-cache ]; then
-   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
-fi
-update-desktop-database -q &> /dev/null || :
-glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
 
-%posttrans
-glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
+%ldconfig_scriptlets
 
 
-%files -f %{name}-%{version}.lang
+%files -f %{name}.lang
 %defattr (-, root, root)
 %license COPYING*
 %doc AUTHORS BUGS *ChangeLog* HACKING NEWS README
 %{_bindir}/*
-%{_libdir}/libspreadsheet*.so
+%{_libdir}/libspreadsheet-*.so
 %{_libdir}/%{name}
 %{_libdir}/goffice/0.10/plugins/%{name}
 %{_datadir}/appdata/gnumeric.appdata.xml
 %{_datadir}/applications/*.desktop
 %{_datadir}/glib-2.0/schemas/*.xml
-%{_datadir}/help/*
 %{_datadir}/%{name}
 %{_datadir}/pixmaps/*
-%{_datadir}/icons/hicolor/*
+%{_datadir}/icons/hicolor/*/*/*.png
 %{_mandir}/man*/*
-%exclude %{_datadir}/pixmaps/win32-gnumeric.ico
 
+%if %{with devel}
+%files devel
+%{_libdir}/libspreadsheet.so
+%{_libdir}/pkgconfig/libspreadsheet-*.pc
+%{_includedir}/libspreadsheet-*
+%endif
 
 %changelog
+* Mon Mar 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.48-1
+- new upstream release.
+- added devel package.
+
 * Sat May 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.46-1
 - new upstream release.
 

+ 86 - 47
t/t1lib/t1lib-vl.spec

@@ -1,27 +1,31 @@
 Summary:	PostScript Type 1 font rasterizer
 Name:		t1lib
-Version:	5.1.2
-Release:	4%{?_dist_release}
 Epoch: 		1
+Version:	5.1.2
+Release:	5%{?_dist_release}
+Group:		system
+Vendor: 	Project Vine
+Distribution: 	Vine Linux
 
-Group:		System Environment/Libraries
 License:	LGPLv2+
-URL:            ftp://sunsite.unc.edu/pub/Linux/libs/graphics/t1lib-%{version}.lsm
-
+URL:		ftp://sunsite.unc.edu/pub/Linux/libs/graphics/t1lib-%{version}.lsm
 Source:		ftp://sunsite.unc.edu/pub/Linux/libs/graphics/%{name}-%{version}.tar.gz
-Patch1:		%{name}-doc.patch.bz2
-Patch2:         %{name}-config.patch.bz2
-Patch3:         %{name}-5.1.2-segf.patch
-# security fixes
-Patch10:	t1lib-5.1.2-CVE-2010-2642.patch
-Patch11:	t1lib-5.1.2-CVE-2011-0764.patch
+Patch0:         http://ftp.de.debian.org/debian/pool/main/t/t1lib/t1lib_5.1.2-3.diff.gz
+Patch1:		t1lib-5.1.2-segf.patch
+# Fixes CVE-2010-2642, CVE-2011-0433
+# http://bugzilla.redhat.com/show_bug.cgi?id=679732
+Patch2:		t1lib-5.1.2-afm-fix.patch
+# Fixes CVE-2011-0764, CVE-2011-1552, CVE-2011-1553, CVE-2011-1554
+# http://bugzilla.redhat.com/show_bug.cgi?id=692909
+Patch3:		t1lib-5.1.2-type1-inv-rw-fix.patch
+# Add aarch64 support
+# https://bugzilla.redhat.com/show_bug.cgi?id=926603
+Patch4:		t1lib-5.1.2-aarch64.patch
+Patch5:		t1lib-5.1.2-format-security.patch
 
 BuildRoot:	%{_tmppath}/%{name}-%{version}-root
-BuildRequires:	libICE-devel libX11-devel libXaw-devel libXpm-devel
-BuildRequires:  texlive texlive-common
+BuildRequires:	libXaw-devel
 
-Vendor: 	Project Vine
-Distribution: 	Vine Linux
 
 %description
 T1lib is a library for generating character and string-glyphs from
@@ -32,7 +36,7 @@ T1lib also includes a support for antialiasing.
 
 %package devel
 Summary: 	Header files for PostScript Type 1 font rasterizer
-Group: 		Development/Libraries
+Group: 		programming
 Requires: 	%{name} = %{epoch}:%{version}-%{release}
 Provides: 	%{name}-devel = %{version}-%{release}
 
@@ -40,9 +44,10 @@ Provides: 	%{name}-devel = %{version}-%{release}
 Header files required for compiling packages
 needing the t1lib.
 
+
 %package static-devel
 Summary:        Static libraries for PostScript Type 1 font rasterizer
-Group:          Development/Libraries
+Group: 		programming
 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
 Provides:       %{name}-static-devel = %{version}-%{release}
 
@@ -50,8 +55,8 @@ Provides:       %{name}-static-devel = %{version}-%{release}
 Static libraries required for staticaly compiling packages needing the t1lib.
 
 %package progs
-Summary: 	Programs dor manipulating Type 1 font
-Group: 		Applications/Graphics
+Summary: 	Programs for manipulating Type 1 font
+Group: 		graphics
 License: 	GPLv2+
 Requires: 	%{name} = %{epoch}:%{version}
 Provides: 	%{name}-progs
@@ -60,51 +65,74 @@ Provides: 	%{name}-progs
 The t1lib-progs contains the programs "xglyph" and "type1afm"
 It also contains the "t1libconfig" script used to configure t1lib.
 
+
+%debug_package
+
+
 %prep
 %setup -q
-%patch1 -p0
-%patch2 -p0
-%patch3 -p1 -b .segf
-%patch10 -p1 -b .CVE-2010-2642
-%patch11 -p1 -b .CVE-2011-0764
+%patch0 -p1
+%patch1 -p1 -b .segf
+%patch2 -p1 -b .afm-fix
+%patch3 -p1 -b .type1-inv-rw-fix
+%patch4 -p1 -b .aarch64
+%patch5 -p1 -b .format-security
+
+# use debian patches directly instead of duplicating them
+#patch -p1 < debian/patches/segfault.diff -b -z .segf
+patch -p1 < debian/patches/no-config.diff
+patch -p1 < debian/patches/no-docs.diff
+patch -p1 < debian/patches/lib-cleanup.diff
 
 iconv -f latin1 -t utf8 < Changes > Changes.utf8
 touch -r Changes Changes.utf8
 mv Changes.utf8 Changes
 
+
 %build
 %configure
 #export tagname=CC
 perl -pi -e 's,-DGLOBAL_CONFIG_DIR="\\"/usr/share/t1lib\\"",-DGLOBAL_CONFIG_DIR="\\"/etc/t1lib\\"",;' Makefile
-#(cd lib
-#perl -pi -e 's,$(DESTDIR)/usr/share/t1lib,$(DESTDIR)$(datedir)t1lib,;' Makefile
-#)
-make without_doc 
-#LIBTOOL=/usr/bin/libtool
+# remove rpaths
+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+
+make %{?_smp_mflags} without_doc 
 touch -r lib/t1lib/t1lib.h.in lib/t1lib.h
 touch -r lib/t1lib/t1libx.h lib/t1libx.h
 ln README.t1lib-%{version} README
+sed -e 's;/usr/share/X11/fonts;%{_datadir}/X11/fonts;' \
+  -e 's;/usr/share/fonts/type1;%{_datadir}/fonts %{_datadir}/texmf/fonts;' \
+  -e 's;/etc/t1lib/;%{_datadir}/t1lib/;' \
+ debian/t1libconfig > t1libconfig
+touch -r README.t1lib-%{version} t1libconfig
 
-(cd doc
-make clean
-make pdf)
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir} \
-	$RPM_BUILD_ROOT%{_datadir} \
-	$RPM_BUILD_ROOT%{_bindir} \
-        $RPM_BUILD_ROOT%{_includedir}
 make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
-
-rm -f $RPM_BUILD_ROOT%{_libdir}/libt1*.la
+rm $RPM_BUILD_ROOT%{_libdir}/libt1*.la
 chmod a+x $RPM_BUILD_ROOT%{_libdir}/libt1*.so.*
 
-mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/t1lib
-mv $RPM_BUILD_ROOT%{_datadir}/t1lib/t1lib.config $RPM_BUILD_ROOT%{_sysconfdir}/t1lib
+mkdir -p $RPM_BUILD_ROOT%{_mandir}/man{1,5,8}
+install -p -m 644 debian/man/FontDatabase.5 $RPM_BUILD_ROOT%{_mandir}/man5/
+install -p -m 644 debian/man/t1libconfig.8 $RPM_BUILD_ROOT%{_mandir}/man8/
+install -p -m 644 debian/man/type1afm.1 $RPM_BUILD_ROOT%{_mandir}/man1/
+install -p -m 644 debian/man/xglyph.1 $RPM_BUILD_ROOT%{_mandir}/man1/
+touch -r README.t1lib-%{version} $RPM_BUILD_ROOT%{_mandir}/man?/*.*
+
+mkdir -p $RPM_BUILD_ROOT%{_sbindir}
+install -p -m 755 t1libconfig $RPM_BUILD_ROOT%{_sbindir}/
+
+mkdir -p $RPM_BUILD_ROOT%{_datadir}/t1lib/
+touch $RPM_BUILD_ROOT%{_datadir}/t1lib/{FontDatabase,t1lib.config}
+
+%post
+%{?ldconfig}
+%{_sbindir}/t1libconfig --force > /dev/null
+
+%ldconfig_postun
 
-%post 	-p /sbin/ldconfig
-%postun -p /sbin/ldconfig
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -112,27 +140,38 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n %{name}
 %defattr(-,root,root)
-%config(noreplace) %{_sysconfdir}/t1lib/t1lib.config
-%doc Changes LGPL README.t1*
+%license LGPL LICENSE
+%doc Changes README.t1*
+%dir %{_datadir}/t1lib
+%ghost %verify(not size mtime md5) %{_datadir}/t1lib/t1lib.config
+%ghost %verify(not size mtime md5) %{_datadir}/t1lib/FontDatabase
 %{_libdir}/libt1*.so.*
+%{_mandir}/man5/*
+%{_mandir}/man8/*
+%{_sbindir}/t1libconfig
 
 %files -n %{name}-devel
 %defattr(-,root,root)
-%doc LGPL doc/t1lib_doc.pdf
+%license LGPL
 %{_includedir}/*
 %{_libdir}/*.so
 
 %files -n %{name}-static-devel
 %defattr(-,root,root)
-%doc LGPL
+%license LGPL
 %{_libdir}/*.a
 
 %files -n %{name}-progs
 %defattr(-,root,root)
-%doc LICENSE README.t1python
+%license LICENSE
 %{_bindir}/*
+%{_mandir}/man1/*
+
 
 %changelog
+* Mon Mar 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.2-5
+- re-imported all patches from rawhide.
+
 * Sun Aug 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.2-4
 - rebuild with VineSeed environment
 

+ 33 - 18
w/wv/wv-vl.spec

@@ -1,17 +1,17 @@
-# option for not using libwmf-0.2.0 or higher
-# rpmbuild -ba | --rebuild --without libwmf
-%define           LIBWMF  1
-%{?_without_libwmf:%define LIBWMF 0}
+%bcond_without libwmf
 
 Summary: an MS-Word document converter
 Summary(ja): MS Word 文章コンバータ
 Name:  wv
 Version: 1.2.9
-Release: 1%{?_dist_release}
-Group: Applications/Text
+Release: 2%{?_dist_release}
+Group: publishing
+
 License: GPLv2
 URL: http://www.abisource.com/
 Source0: http://www.abisource.com/downloads/wv/%{version}/wv-%{version}.tar.gz
+Patch1: wv-aarch64.patch
+Patch2: format-security.patch
 
 Buildroot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: zlib-devel
@@ -20,7 +20,7 @@ BuildRequires: libgsf-devel
 BuildRequires: libpng-devel
 BuildRequires: libxml2-devel
 BuildRequires: libjpeg-devel
-%if %{LIBWMF}
+%if %{with libwmf}
 BuildRequires: libwmf-devel >= 0.2.6
 Requires: libwmf >= 0.2.6
 %endif
@@ -32,7 +32,7 @@ wvHtml foobar.doc foobar.html.utf8
 iconv -f UTF-8 -t EUC-JP foobar.html.utf8 | \
 sed 's/UTF-8/EUC-JP/g' > foobar.html.euc
 
-%if %{LIBWMF}
+%if %{with libwmf}
 This package is configured to use libwmf, so it can convert wmf files
 into png.  Please install libwmf-0.2.0 or higher too.
 %else
@@ -48,7 +48,7 @@ wvHtml foobar.doc foobar.html.utf8
 iconv -f UTF-8 -t EUC-JP foobar.html.utf8 | \
 sed 's/UTF-8/EUC-JP/g' > foobar.html.euc
 
-%if %{LIBWMF}
+%if %{with libwmf}
 このパッケージは libwmf を使用するように設定されているので,wmf 
 ファイルを png に変換することができます.libwmf のバージョン 0.2.0 以上
 をあわせてインストールしてください.
@@ -57,10 +57,11 @@ sed 's/UTF-8/EUC-JP/g' > foobar.html.euc
 wmf ファイルを png に変換することはできません.
 %endif
 
+
 %package devel
 Summary: Development tools for programs to manipulate MS-Word documents
 Summary(ja): MS Word ドキュメントを処理するプログラムを開発するためのツール
-Group: Development/Libraries
+Group: programming
 Requires: wv = %{version}
 Requires: zlib-devel
 Requires: glib2-devel
@@ -68,7 +69,7 @@ Requires: libgsf-devel
 Requires: libpng-devel
 Requires: libxml2-devel
 Requires: libjpeg-devel
-%if %{LIBWMF}
+%if %{with libwmf}
 Requires: libwmf-devel >= 0.2.6
 %endif
 
@@ -87,29 +88,39 @@ MS Word ドキュメントを処理するプログラムを開発したいので
 wv-devel パッケージをインストールすべきです.wv パッケージを
 インストールする必要もあります.
 
+
+%debug_package
+
+
 %prep
 %setup -q
+%patch1 -p1
+%patch2 -p1
+
 
 %build
 %configure --disable-static \
-%if %{LIBWMF}
+%if %{with libwmf}
 	--with-libwmf \
 %endif
+	%{nil}
 
 make %{?_smp_mflags}
 
+
 %install
 rm -rf $RPM_BUILD_ROOT
 %makeinstall
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
+find $RPM_BUILD_ROOT%{_libdir} -name "*.la" -exec rm -f {} \;
+
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
 
-%postun -p /sbin/ldconfig
+%ldconfig_scriptlets
+
 
 %files
 %defattr(-,root,root)
@@ -126,7 +137,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/lib*.so
 %{_libdir}/pkgconfig/*.pc
 
+
 %changelog
+* Mon Mar 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.9-2
+- imported Patch1-2 from rawhide.
+
 * Sat Jul 19 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.2.9-1
 - new upstream release
 - changed URL, Source0 tag
@@ -150,7 +165,7 @@ rm -rf $RPM_BUILD_ROOT
 * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.0-0vl4
 - rebuild
 
-* Thu May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl3
+* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl3
 - added Requires: libwmf-devel to wv-devel
 
 * Tue Mar 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl2
@@ -166,7 +181,7 @@ rm -rf $RPM_BUILD_ROOT
 - added --with-expat to %configure
 - rewrite build option "--without libwmf"
 
-* Sat Sep 29 2004 SATO Masakiyo <info@pocomoco.net> 1.0.0-0vl3
+* Wed Sep 29 2004 SATO Masakiyo <info@pocomoco.net> 1.0.0-0vl3
 - correct wv.spec for CAN-2004-0645
 
 * Sat Aug 28 2004 SATO Masakiyo <info@pocomoco.net> 1.0.0-0vl2
@@ -184,7 +199,7 @@ rm -rf $RPM_BUILD_ROOT
 - 0.6.7-0vl1: was ported to VineSeedPlus with better macros
 - build with libwmf by default
 
-* Fri Jun  2 2001 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
+* Sat Jun  2 2001 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
 - 0.6.5-0vl1
 - subpackage devel
 - not to require libwmf by default