Browse Source

2015-02-11 Ryoichi INAGAKI <ryo1@toki.waseda.jp>

	* WindowMaker, wmakerconf: fixed spec
	* libPropList: split devel files to devel subpackage
	


git-svn-id: http://trac.vinelinux.org/repos/projects/specs@9350 ec354946-7b23-47d6-9f5a-488ba84defc7
inagaki 7 years ago
parent
commit
0d93726612

+ 37 - 14
W/WindowMaker/WindowMaker-vl.spec

@@ -11,7 +11,7 @@ Summary: Window Maker - a window manager for X11
 Summary(ja): X11 用ウィンドウ・マネージャ
 Name: WindowMaker
 Version: %{version}
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 License: GPLv2/OPL
 Group: User Interface/Desktops
 URL: http://windowmaker.info/
@@ -46,9 +46,10 @@ Patch31: libdockapp-0.4.0-config.sub.patch
 Patch41: WMMail.app-0.63a.config.patch
 Patch42: asclock-2.0.12.patch
 
+Buildroot: %{_tmppath}/%{name}-%{version}-root
 # libPropList is not necessary for Window Maker >= 0.70, but
 # for items around WindowMaker.
-BuildRequires: libPropList
+BuildRequires: libPropList-devel
 BuildRequires: automake automake14
 BuildRequires: autoconf >= 2.59
 BuildRequires: libtool
@@ -62,20 +63,25 @@ BuildRequires: libXrandr-devel
 BuildRequires: libICE-devel
 BuildRequires: libXpm-devel
 
+BuildRequires: giflib-devel
+BuildRequires: libexif-devel
 BuildRequires: libjpeg-turbo-devel
 BuildRequires: libtiff-devel
 BuildRequires: libwebp-devel
 BuildRequires: ImageMagick-devel
 
 Requires: WindowMaker-libs = %{version}
-#Requires: libPropList >= 0.10.0
 Requires: WindowMaker-Icons, vine-backgrounds, cpp
 Requires: vine-logos, vutils, sed
 Requires: xterm
 Requires: xorg-x11-jpfonts
 
+# for WMMail
+Requires: libSM libXau libXdmcp libxcb
+# for WPrefs
+Requires: libXrender libexpat libtool-ltdl lcms2 xz-libs  
+
 Provides: libwraster.so.2
-Buildroot: %{_tmppath}/%{name}-%{version}-root
 
 %description
 WindowMaker is a window manager designed to emulate the look
@@ -107,8 +113,19 @@ wmakerconf や wdm 等にも必要です。
 
 %package devel
 Summary: Development files using WindowMaker related libraries
+Summary(ja): WindowMaker 関連ライブラリの開発用ファイル
 Group: Development/Libraries
-Requires: WindowMaker-libs = %{version}
+Requires: WindowMaker-libs = %{version}-%{release}
+Requires: libX11-devel
+Requires: libXext-devel
+Requires: xorg-x11-proto-devel
+# get-wraster-flags uses the following libraries 
+Requires: giflib-devel
+Requires: libXpm-devel
+Requires: libjpeg-devel
+Requires: libpng-devel
+Requires: libtiff-devel
+Requires: libwebp-devel
 
 %description devel
 This package contains the WindowMaker related library and header files 
@@ -246,7 +263,7 @@ make DESTDIR=%{buildroot} install -C %{libdockapp}
 	install -m 755 %{SOURCE21} %{buildroot}%{_bindir}
 	# prepare docs
 	pwd
-	mkdir ../WMMail.app
+	mkdir -p ../WMMail.app
 	cp -p AUTHORS COPYING ChangeLog INSTALL NEWS README Defaults/WMMail ../WMMail.app
 )
 
@@ -317,6 +334,8 @@ rm WMState
 %{_bindir}/getstyle
 %{_bindir}/seticons
 %{_bindir}/setstyle
+%{_bindir}/wdread
+%{_bindir}/wdwrite
 %{_bindir}/wkdemenu.pl
 %{_bindir}/wm-oldmenu2new
 %{_bindir}/wmagnify
@@ -332,32 +351,36 @@ rm WMState
 %{_datadir}/WindowMaker/
 %{_mandir}/*/*
 %{_localedir}/*/*/*
-%{gnustepdir}/Applications/WPrefs.app/
-%{_libdir}/pkgconfig/
+%{gnustepdir}/Applications/WPrefs.app
 
-%{gnustepdir}/Applications/WMMail.app/
+%{gnustepdir}/Applications/WMMail.app
 %doc WMMail.app/
 %{_bindir}/dockit
 
 %files libs
 %defattr(-,root,root)
-%{_bindir}/get-wings-flags
-%{_bindir}/get-wraster-flags
-%{_bindir}/get-wutil-flags
-%{_bindir}/wdread
-%{_bindir}/wdwrite
 %{_libdir}/lib*.so.*
 
 %files devel
 %defattr(-,root,root)
+%{_bindir}/get-wings-flags
+%{_bindir}/get-wraster-flags
+%{_bindir}/get-wutil-flags
 %{_includedir}/WINGs
 %{_includedir}/WMaker.h
 %{_includedir}/dockapp.h
 %{_includedir}/wraster.h
 %{_libdir}/lib*.so
+%{_libdir}/pkgconfig/*.pc
 
 
 %changelog 
+* Tue Feb 10 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.95.6-2
+- moved %%{_bindir}/*-flags and %%{_libdir}/pkgconfig/+.pc to devel subpackage
+- added BuildRequires: giflib-devel and libexif-devel
+- added Requires for WMMail and WPrefs to main package
+- added Requires for get-wraster-flags to devel subpackage
+
 * Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.95.6-1
 - update to 0.95.6
 - update Patch7 (WindowMaker-0.95.6-wheel.diff.gz)

+ 33 - 6
lib/libP/libPropList/libPropList-vl.spec

@@ -2,12 +2,14 @@ Summary: Ensures program compatibility with GNUstep/OPENSTEP.
 Summary(ja): GNUstep/OPENSTEP のプログラム互換性を保つライブラリ
 Name: libPropList
 Version: 0.10.1
-Release: 13%{?_dist_release}
-License: LGPL
-Group: Development/Libraries
+Release: 14%{?_dist_release}
+License: LGPLv2
+Group: System Environment/Libraries
+
 Source: ftp://ftp.windowmaker.org/pub/libs/%{name}-%{version}.tar.gz
 Patch0: libPropList-0.10.1-config64.patch
 Patch1: libPropList-0.10.1-ltconfig.patch
+
 Buildroot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: flex
 
@@ -24,6 +26,17 @@ LibPropList enables programs that use configuration or preference
 files to make them compatible with GNUstep/OPENSTEP's user defaults
 handling mechanism, without using Objective-C or GNUstep/OPENSTEP.
 
+#'
+%package devel
+Summary: Development files for %{name}
+Summary(ja): %{name} の開発用ファイル
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description    devel
+The %{name}-devel package contains libraries and header files for
+developing applications that use %{name}.
+
 
 %prep 
 %setup -q
@@ -36,20 +49,34 @@ make
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%makeinstall 
+make install DESTDIR=$RPM_BUILD_ROOT 
+
 ## remove unuse files
 rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(-,root,root)
-%{_libdir}/libPropList.so*
-%{_includedir}/proplist.h
+%doc AUTHORS COPYING* ChangeLog NEWS README
+%{_libdir}/libPropList.so.*
 
+%files devel
+%defattr(-,root,root)
+%{_includedir}/proplist.h
+%{_libdir}/libPropList.so
 
 %changelog
+* Tue Feb 10 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.1-14
+- rebuilt on current Vine Seed
+- added %%post and %%postun section
+- split development files into devel subpackage
+
 * Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 0.10.1-13
 - rebuilt with rpm-4.8.1-3
 

+ 20 - 16
w/wmakerconf/wmakerconf-vl.spec

@@ -1,6 +1,6 @@
 Name: wmakerconf
 Version: 2.12
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 Summary: Configuration tool for Window Maker
 Summary(ja): Window Maker の設定ツール
 
@@ -11,16 +11,16 @@ Source: http://downloads.sf.net/%{name}/wmakerconf_%{version}.tar.gz
 Source1: wmakerconf-2.12-ja.po
 Source2: wmakerconf-2.11.data.ja.po
 
-Patch0:         %{name}-2.9.dif
-Patch1:         %{name}-fix-bad-po.patch
-Patch3:         %{name}-2.9-destdir.patch
-Patch4:         %{name}-2.9-config.patch
-Patch5:         %{name}-no-imlib.patch
-Patch7:         %{name}-2.9-varargs.diff
-Patch9:         %{name}-datarootdir.patch
-Patch10:        %{name}-2.12-wmaker-0.95_support.patch
+Patch0:        %{name}-2.9.dif
+Patch1:        %{name}-fix-bad-po.patch
+Patch3:        %{name}-2.9-destdir.patch
+Patch4:        %{name}-2.9-config.patch
+Patch5:        %{name}-no-imlib.patch
+Patch7:        %{name}-2.9-varargs.diff
+Patch9:        %{name}-datarootdir.patch
+Patch10:       %{name}-2.12-wmaker-0.95_support.patch
 # PATCH - Fix SUSE: implicit-pointer-decl
-Patch11:        %{name}-implicit-pointer-decl.patch
+Patch11:       %{name}-implicit-pointer-decl.patch
 
 Buildroot:     %{_tmppath}/%{name}-%{version}-root
 BuildRequires: WindowMaker
@@ -28,17 +28,15 @@ BuildRequires: WindowMaker-devel >= 0.92.0
 BuildRequires: bison
 BuildRequires: gettext
 BuildRequires: gtk2-devel >= 2.4.0
-BuildRequires: libXpm-devel
-BuildRequires: libjpeg-devel
-BuildRequires: libtiff-devel
-BuildRequires: libwebp-devel
 BuildRequires: perl-libwww-perl
+BuildRequires: xdg-utils
 BuildRequires: tar gzip bzip2
 Requires:      WindowMaker
+Requires:      xdg-utils
 Obsoletes:     wmakerconf-data
 
-Vendor: Project Vine
-Distribution: Vine Linux
+Vendor:        Project Vine
+Distribution:  Vine Linux
 
 %description
 wmakerconf is a GTK+ based configuration tool for the window manager
@@ -88,6 +86,8 @@ export CFLAGS CPPFLAGS NLSDIR LINGUAS GNUSTEP_LOCAL_ROOT CPP_PATH
 	--prefix=%{_prefix} \
 	--includedir=%{_includedir} \
 	--disable-imlibtest \
+	--disable-upgrade \
+	--with-webbrowser=xdg-open \
 	--with-wmakerdataprefix=%{_datadir} \
 	--with-wmakeretcprefix=%{_sysconfdir}/X11
 
@@ -128,6 +128,10 @@ rm -rf %{buildroot}
 
 
 %changelog
+* Wed Feb 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.12-2
+- added BR: xdg-utils, R: xdg-utils
+- removed BR: libXpm-devel. libjpeg-devel, libtiff-devel, libwebp-devel
+
 * Mon Feb  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.12-1
 - updated to 2.12
 - added Patch0, 7, 9, 10 and 11 from OpenSuSE